Errors on installing RT 3.8.1

Hi All,

ubuntu server 7.10
apache 2.2.4
RT 3.8.1
perl v5.8.8

this is my first posting, so let me know if i’ve done anything against
protocol.

Ok, so i’ve had an installation of RT3.6 (from source - i didnt know it
was in repository) running for about 3 weeks now, no worries. And i saw
that i’d missed the upgrades provided with v3.8, so i’ve attempted to
install this on a virtual machine for deployment in a virtual
environment.

the install for RT3.8.1 though seems much harder/messier. everything
went well, following from the readme in the .tar.gz package, until i got
to the Web Installation section.

Now i’ve been using linux now for 6months, and apache virtual hosts do
my head in. i didnt find the instructions in the readme particularly
clear either…

so… in my …apache2/sites-available folder i’ve left the 'default’
file, and added another one for the RT site called example.com.conf
(historical reasons) and dumped in the config listed in the readme (see
bottom of this post). then i a2ensite’d it and restarted apache

result?

error 500 when i browse to the site (using lynx on the local machine,
I’ve also set a mapping from example.com to 127.0.0.1 in /etc/hosts)

now, if i comment out the bit in the virtual hosts file that says:

SetHandler perl-script PerlResponseHandler RT::Mason

then when i go to the site with lynx, i get the RT webdir, but with the
warning message saying i havent installed lib_perl/fastcgi etc

so i guess i’m missing either one of the perl modules… though i’m sure
i got all of them when i did the make test during the install…

STUFF I’VE TRIED

  • i’ve tried updating mod_perl to the latest version , but i couldnt
    get this to run because it was looking for something in httpd.conf
    instead of apache2.conf (where ubuntu puts all the conf stuff)
  • i’ve tried removing the all the info from the ‘default’ file
    from …/apache2/sites-available and replacing it with the config from
    the README as per this post (and removing the example.conf entry)
  • i’ve tried reinstalling HTML::Mason from CPAN

so yeah… would appreciate any help on this one… as i’m way out of my
depths…

Cheers,

ps here’s the config i’ve been using from the README file:

mod_perl 2.xx

WARNING: mod_perl 1.99_xx is not supported.

Add a few lines to your Apache 2.xx configuration file, so that
it knows where to find RT:

ServerName supportrt.ourdomain.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
# ErrorLog /opt/rt3/var/log/apache2.error
# TransferLog /opt/rt3/var/log/apache2.access

PerlRequire "/opt/rt3/bin/webmux.pl"

<Location /NoAuth/images>
    SetHandler default
</Location>
<Location />
    SetHandler perl-script
    PerlResponseHandler RT::Mason
</Location>

Calvin Chiang
Network Admin
Utilyx
1st Floor, 55 North Wharf Road
Paddington
London, W2 1LA
Tel: 020 7087 8673
www.utilyx.com

“Utilyx” is the trading name of “Utilyx Limited” and “Utilyx Risk Management Limited” (URML). URML is authorised and regulated by the Financial Services Authority (FSA). This message contains information that may be privileged or confidential and is the property of Utilyx. It is intended only for the person to whom it is addressed. No confidentiality or privilege is waived or lost by any mistransmission. Any views or opinions expressed in this message are solely those of the author and do not necessarily represent those of Utilyx. Unless otherwise stated, any pricing information given in this message is indicative only and does not constitute an offer to deal at any price quoted. If you are not the intended recipient, you are not authorized to read, print, retain, copy, disseminate, distribute or use this message or any part thereof. If you receive this message in error, please notify the sender immediately and delete all copies of this message.
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email

I am right with you. It’s like there is a missing step somewhere. Have you
found anything?On Thu, Sep 11, 2008 at 12:04 PM, calvin chiang calvinchiang@utilyx.comwrote:

Hi All,

ubuntu server 7.10
apache 2.2.4
RT 3.8.1
perl v5.8.8

this is my first posting, so let me know if i’ve done anything against
protocol.

Ok, so i’ve had an installation of RT3.6 (from source - i didnt know it was
in repository) running for about 3 weeks now, no worries. And i saw that i’d
missed the upgrades provided with v3.8, so i’ve attempted to install this on
a virtual machine for deployment in a virtual environment.

the install for RT3.8.1 though seems much harder/messier. everything went
well, following from the readme in the .tar.gz package, until i got to the
Web Installation section.

Now i’ve been using linux now for 6months, and apache virtual hosts do my
head in. i didnt find the instructions in the readme particularly clear
either…

so… in my …apache2/sites-available folder i’ve left the ‘default’ file,
and added another one for the RT site called example.com.conf (historical
reasons) and dumped in the config listed in the readme (see bottom of this
post). then i a2ensite’d it and restarted apache

result?

error 500 when i browse to the site (using lynx on the local machine, I’ve
also set a mapping from example.com to 127.0.0.1 in /etc/hosts)

now, if i comment out the bit in the virtual hosts file that says:

SetHandler perl-script PerlResponseHandler RT::Mason

then when i go to the site with lynx, i get the RT webdir, but with the
warning message saying i havent installed lib_perl/fastcgi etc

so i guess i’m missing either one of the perl modules… though i’m sure i
got all of them when i did the make test during the install…

STUFF I’VE TRIED

  • i’ve tried updating mod_perl to the latest versionhttp://search.cpan.org/~pgollucci/mod_perl-2.0.3/
    , but i couldnt get this to run because it was looking for something in
    httpd.conf instead of apache2.conf (where ubuntu puts all the conf stuff)
  • i’ve tried removing the all the info from the ‘default’ file from
    …/apache2/sites-available and replacing it with the config from the README as
    per this posthttp://www.gossamer-threads.com/lists/rt/users/77770?page=last(and removing the example.conf entry)
  • i’ve tried reinstalling HTML::Mason from CPAN

so yeah… would appreciate any help on this one… as i’m way out of my
depths…

Cheers,

ps here’s the config i’ve been using from the README file:

mod_perl 2.xx

WARNING: mod_perl 1.99_xx is not supported.

Add a few lines to your Apache 2.xx configuration file, so that
it knows where to find RT:

ServerName supportrt.ourdomain.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
# ErrorLog /opt/rt3/var/log/apache2.error
# TransferLog /opt/rt3/var/log/apache2.access

PerlRequire "/opt/rt3/bin/webmux.pl"

<Location /NoAuth/images>
    SetHandler default
</Location>
<Location />
    SetHandler perl-script
    PerlResponseHandler RT::Mason
</Location>


Calvin Chiang
Network Admin
Utilyx
1st Floor, 55 North Wharf Road
Paddington
London, W2 1LA
Tel: 020 7087 8673www.utilyx.com


“Utilyx” is the trading name of “Utilyx Limited” and “Utilyx Risk
Management Limited” (URML). URML is authorised and regulated by the
Financial Services Authority (FSA). This message contains information that
may be privileged or confidential and is the property of Utilyx. It is
intended only for the person to whom it is addressed. No confidentiality or
privilege is waived or lost by any mistransmission. Any views or opinions
expressed in this message are solely those of the author and do not
necessarily represent those of Utilyx. Unless otherwise stated, any pricing
information given in this message is indicative only and does not constitute
an offer to deal at any price quoted. If you are not the intended recipient,
you are not authorized to read, print, retain, copy, disseminate, distribute
or use this message or any part thereof. If you receive this message in
error, please notify the sender immediately and delete all copies of this
message.


This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

You can check what the server is running by using telnet on port 80.

telnet localhost 80
HEAD / HTTP 1.0

It should respond with the server header and installed modules (usually).

In most apache/mod_perl installs it should be working as is. The files
to load it are in /etc/apache2/mods-enabled/perl.load which links to
/etc/apache2/mods-available/perl.load. This is for debian based linux’
so ubuntu etc… The package which installs it is libapache2-mod-perl2.
You could of course use fastcgi or whichever RT support but make sure
when you install RT you specify which handler you want to use. Your
config looks ok at first glance though.

Chris Nelson wrote:

Yeah something is up there, those two responses are completely
different, os and apache version. So make sure the host is valid, you
could probably have it in hosts.conf but it would only work from the
server itself. Also note that the apache/fastcgi config is different
then mod_perl2.

calvin chiang wrote:

it’s working!!

ok i’m just posting this in case anybody comes across it and wants to
find out what happened.

it’s pretty simple - i wasnt checking the logs. the apache logs to be
precise which for me are in /var/log/apache2/error.log

the error i was getting was:
DBI connect(‘dbname=rtdb’,‘rtuser’,…) failed: Access denied for user
’rtuser’@’’ to database ‘rtdb’
at /usr/local/share/perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Wed Sep 10 16:19:25 2008] [error] [client 127.0.1.1] Connect Failed
Access denied for user ‘rtuser’@’’ to database ‘rtdb’\n
at /opt/rt3/bin/…/lib/RT.pm line 204\n

that makes a lot more sense - nothing to do with modperl at all.

then from there it took me a while again to realise that it was looking
for rtuser@ … instead of rtuser@localhost

found out that it was there was a problem in my RT_SiteConfig.pm… i had
the two lines:

Set($DatabaseHost , ‘’);
Set($DatabaseRTHost , ‘’);

now i’m sure i only added these entries because i read a post that said
i should.

so just filled the blanks with localhost as per:
Set($DatabaseHost , ‘localhost’);
Set($DatabaseRTHost , ‘localhost’);

reloaded apache. bob’s your uncle.

thanks Curtis for your help on this oneOn Fri, 2008-09-12 at 15:21 +0100, Curtis Bruneau wrote:

Yeah something is up there, those two responses are completely
different, os and apache version. So make sure the host is valid, you
could probably have it in hosts.conf but it would only work from the
server itself. Also note that the apache/fastcgi config is different
then mod_perl2.

calvin chiang wrote:

Hi Curtis,

thanks for the reply!
ok.
when i run the telnet to localhost i get this:
Apache/2.2.4 (Ubuntu) PHP/5.2.3-1ubuntu6 mod_perl/2.0.2 Perl/v5.8.8
Server at SupportRT.localdomain Port 80

which looks pretty right to me.

when i run telnet to example.com (which is the virtual host for my
RT
installation) i get this:
Apache/2.2.3 (CentOS) Server at example.com Port 80

which made me wonder whether the mod_perl thingy isnt being applied
to
the virtual server.

So just to check i dropped the configuration script into
the /sites-available/default, and once again getting that 500 error.
when i comment out the section

SetHandler perl-script PerlResponseHandler RT::Mason

then it loads the page that tells me that mod_perl/fastcgi hasnt
been
installed. same as before.

so i guess it’s got nothing to do with my virtual hosts then.

btw i did try to install libapache2-mod-perl2 but said it was
already
installed.

going to try with fastcgi and see how i go

thanks for your help!

On Fri, 2008-09-12 at 14:44 +0100, Curtis Bruneau wrote:

You can check what the server is running by using telnet on port

telnet localhost 80
HEAD / HTTP 1.0

It should respond with the server header and installed modules
(usually).

In most apache/mod_perl installs it should be working as is. The
files

to load it are in /etc/apache2/mods-enabled/perl.load which links
to

/etc/apache2/mods-available/perl.load. This is for debian based
linux’

so ubuntu etc… The package which installs it is
libapache2-mod-perl2.

You could of course use fastcgi or whichever RT support but make
sure

when you install RT you specify which handler you want to use. Your
config looks ok at first glance though.

Chris Nelson wrote:

I am right with you. It’s like there is a missing step somewhere.

Have

you found anything?

On Thu, Sep 11, 2008 at 12:04 PM, calvin chiang <calvinchiang@utilyx.com mailto:calvinchiang@utilyx.com> wrote:

Hi All,

ubuntu server 7.10
apache 2.2.4
RT 3.8.1
perl v5.8.8

this is my first posting, so let me know if i've done anything
against protocol.

Ok, so i've had an installation of RT3.6 (from source - i

didnt

know it was in repository) running for about 3 weeks now, no
worries. And i saw that i'd missed the upgrades provided with
v3.8, so i've attempted to install this on a virtual machine

for

deployment in a virtual environment.

the install for RT3.8.1 though seems much harder/messier.
everything went well, following from the readme in the .tar.gz
package, until i got to the Web Installation section.

Now i've been using linux now for 6months, and apache virtual
hosts do my head in. i didnt find the instructions in the

readme

particularly clear either...

so.. in my ..apache2/sites-available folder i've left the
'default' file, and added another one for the RT site called
example.com.conf (historical reasons) and dumped in the config
listed in the readme (see bottom of this post). then i

a2ensite’d

it and restarted apache

result?

error 500 when i browse to the site (using lynx on the local
machine, I've also set a mapping from example.com
<http://example.com> to 127.0.0.1 <http://127.0.0.1>

in /etc/hosts)

now, if i comment out the bit in the virtual hosts file that

says:

<Location />
        SetHandler perl-script
        PerlResponseHandler RT::Mason
    </Location>

then when i go to the site with lynx, i get the RT webdir, but
with the warning message saying i havent installed
lib_perl/fastcgi etc

so i guess i'm missing either one of the perl modules...

though

i'm sure i got all of them when i did the make test during the
install....

....

STUFF I'VE TRIED
* i've tried updating mod_perl to the latest version
<http://search.cpan.org/%7Epgollucci/mod_perl-2.0.3/>   , but

i

couldnt get this to run because it was looking for something

in

httpd.conf instead of apache2.conf (where ubuntu puts all the

conf

stuff)
* i've tried removing the all the info from the 'default' file
from ../apache2/sites-available and replacing it with the

config

from the README as per this post

http://www.gossamer-threads.com/lists/rt/users/77770?page=last

(and removing the example.conf entry)
* i've tried reinstalling HTML::Mason from CPAN

so yeah.. would appreciate any help on this one.. as i'm way

out

of my depths..

Cheers,

ps here's the config i've been using from the README file:

mod_perl 2.xx
-------------

WARNING: mod_perl 1.99_xx is not supported.

Add a few lines to your Apache 2.xx configuration file, so

that

it knows where to find RT:

<VirtualHost example.com <http://example.com>>
    ServerName supportrt.ourdomain.com
<http://supportrt.ourdomain.com>

    DocumentRoot /opt/rt3/share/html
    AddDefaultCharset UTF-8

    # optional apache logs for RT
    # ErrorLog /opt/rt3/var/log/apache2.error
    # TransferLog /opt/rt3/var/log/apache2.access

    PerlRequire "/opt/rt3/bin/webmux.pl"

    <Location /NoAuth/images>
        SetHandler default
    </Location>
    <Location />
        SetHandler perl-script
        PerlResponseHandler RT::Mason
    </Location>
</VirtualHost>

--
Calvin Chiang
Network Admin
Utilyx
1st Floor, 55 North Wharf Road
Paddington
London, W2 1LA
Tel: 020 7087 8673
www.utilyx.com <http://www.utilyx.com>

"Utilyx" is the trading name of "Utilyx Limited" and "Utilyx

Risk

Management Limited" (URML). URML is authorised and regulated

by

the Financial Services Authority (FSA). This message contains
information that may be privileged or confidential and is the
property of Utilyx. It is intended only for the person to whom

it

is addressed. No confidentiality or privilege is waived or

lost

by

any mistransmission. Any views or opinions expressed in this
message are solely those of the author and do not necessarily
represent those of Utilyx. Unless otherwise stated, any

pricing

information given in this message is indicative only and does

not

constitute an offer to deal at any price quoted. If you are

not

the intended recipient, you are not authorized to read, print,
retain, copy, disseminate, distribute or use this message or

any

part thereof. If you receive this message in error, please

notify

the sender immediately and delete all copies of this message.

This email has been scanned by the MessageLabs Email Security

System.

For more information please visit

http://www.messagelabs.com/email


_______________________________________________

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com
<mailto:sales@bestpractical.com>


Discover RT's hidden secrets with RT Essentials from O'Reilly

Media.

Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly
Media.

Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly
Media.

Buy a copy at http://rtbook.bestpractical.com


This email has been scanned by the MessageLabs Email Security
System.

For more information please visit http://www.messagelabs.com/email



This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email


Calvin Chiang
Network Admin
Utilyx
1st Floor, 55 North Wharf Road
Paddington
London, W2 1LA
Tel: 020 7087 8673
www.utilyx.com

“Utilyx” is the trading name of “Utilyx Limited” and “Utilyx Risk Management Limited” (URML). URML is authorised and regulated by the Financial Services Authority (FSA). This message contains information that may be privileged or confidential and is the property of Utilyx. It is intended only for the person to whom it is addressed. No confidentiality or privilege is waived or lost by any mistransmission. Any views or opinions expressed in this message are solely those of the author and do not necessarily represent those of Utilyx. Unless otherwise stated, any pricing information given in this message is indicative only and does not constitute an offer to deal at any price quoted. If you are not the intended recipient, you are not authorized to read, print, retain, copy, disseminate, distribute or use this message or any part thereof. If you receive this message in error, please notify the sender immediately and delete all copies of this message.
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email