Error "You are almost there!"

Hi,
I re-post this messages. Aynone can point out what the problem is ??
Will be due to permission problems? There is no any messages in the log!!!
I got error messages for “You are almost there!” and redicted to
/rt-broken-install.html page. After checking many postings, I still
can’t find the error for my configuration. This is rt-3.4.5 with fastcgi
on Solaris 10. Anyone can help? Thanks.

RT_SiteConfig.pm
Set( $rtname, ‘uchicago.edu’);
Set($WebBaseURL , “http://test.uchicago.edu:8080”);
Set($WebPath , “”);
Set($LogDir, ‘/opt/http/docs/internal/rt/var/log’);
Set($LogToFileNamed , “/tmp/rt.log”); #log to rt.log

httpd.conf
<VirtualHost *:8080>
ServerName test.uchicago.edu:8080
DocumentRoot “/opt/http/docs/internal/rt/html/”
ScriptAlias / /opt/http/docs/internal/rt/bin/mason_handler.fcgi/
Alias /NoAuth/images /opt/http/docs/internal/rt/html/NoAuth/images
<Directory “/opt/http/docs/internal/rt/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Hi Andrew,

Thanks for the information. The addhandler was missing in my 

posting. but actually it was in the configuration.
I changed the configuration as follows, but it still can’t work.
Others mentioned change webpath to “/rt”. But it is same result, no
matter it is “” or “/rt”. I also tried "<Location /rt/> DirectoryIndex
index.html " and it didn’t help.
Any idea?

httpd.conf
<VirtualHost *:8080>
ServerName test.uchicago.edu:8080
DocumentRoot “/opt/pkgs/rt/3.4.5/html”
AddHandler fastcgi-script .fcgi
<Directory “/opt/pkgs/rt/3.4.5/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Alias /NoAuth/images/ /opt/pkgs/rt/stable/html/NoAuth/images/
ScriptAlias /rt/ /opt/pkgs/rt/stable/bin/mason_handler.fcgi/

RT_SiteConfig.pm
Set($WebBaseURL , “http://test.uchicago.edu:8080”);
Set($WebPath , “”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);
Set($LogDir, ‘/opt/pkgs/rt/3.4.5/var/log’);
Set($LogToFileNamed , “/tmp/rt.log”); #log to rt.log

Andrew Nicols wrote:> On 9/20/06, Yongrui Tang <ytang@uchicago.edu mailto:ytang@uchicago.edu> wrote:

Hi,
httpd.conf
<VirtualHost *:8080>
   ServerName test.uchicago.edu:8080 <http://test.uchicago.edu:8080>
   DocumentRoot "/opt/http/docs/internal/rt/html/"
ScriptAlias / /opt/http/docs/internal/rt/bin/mason_handler.fcgi/
Alias /NoAuth/images /opt/http/docs/internal/rt/html/NoAuth/images
  <Directory "/opt/http/docs/internal/rt/html">
     Options FollowSymLinks ExecCGI
     AllowOverride None
   </Directory>
</VirtualHost>

Hi,

I’m not running fastcgi myself, but I the line:
ScriptAlias / /opt/http/docs/internal/rt/bin/mason_handler.fcgi/
Looks suspicious - mason_handler.fcgi is a file… not a directory.
Also, I don’t see an AddHandler anywhere in there.

I’m running Apache 1.3 with mod_perl 1, but using the debian package
which has the following in an example configuration file for fcgi:

AddHandler fastcgi-script fcgi
FastCgiIpcDir /var/run/fastcgi
FastCgiServer /usr/share/request-tracker3.6/libexec/mason_handler.fcgi

ScriptAlias /rt /usr/share/request-tracker3.6/libexec/mason_handler.fcgi

<Location /rt/>
DirectoryIndex index.html


Hope that helps,

Andrew

Yongrui Tang
University of Chicago
Data Network Operations
ytang@uchicago.edu
1-773-702-5592

Hi,
I re-post this messages. Aynone can point out what the problem is ??
Will be due to permission problems? There is no any messages in the log!!!
I got error messages for “You are almost there!” and redicted to
/rt-broken-install.html page.
[snip happens]
httpd.conf
<VirtualHost *:8080>
ServerName test.uchicago.edu:8080
DocumentRoot “/opt/http/docs/internal/rt/html/”
ScriptAlias / /opt/http/docs/internal/rt/bin/mason_handler.fcgi/
Alias /NoAuth/images /opt/http/docs/internal/rt/html/NoAuth/images
<Directory “/opt/http/docs/internal/rt/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Where is your FastCGIServer directive?
http://wiki.bestpractical.com/index.cgi?FastCGIConfiguration

Michael
Michael S. Liebman m-liebman@northwestern.edu
http://msl521.freeshell.org/
“I have vision and the rest of the world wears bifocals.”
-Paul Newman in “Butch Cassidy & the Sundance Kid”

Hi Michael,

The FastCGIServer is outside of <VirtualHost *:8080>. It is "
FastCgiServer /opt/pkgs/rt/3.4.5/bin/mason_handler.fcgi" . Thanks for
reply. BTW, /stable/ is just a link of /3.4.5/. I made the change. But
still the same error.

httpd.conf
FastCgiServer /opt/pkgs/rt/3.4.5/bin/mason_handler.fcgi
<VirtualHost *:8080>
ServerName test.uchicago.edu:8080
DocumentRoot “/opt/pkgs/rt/3.4.5/html”
AddHandler fastcgi-script .fcgi
<Directory “/opt/pkgs/rt/3.4.5”>
Options FollowSymLinks ExecCGI
AllowOverride None

Alias /NoAuth/images/ /opt/pkgs/rt/3.4.5/html/NoAuth/images/
ScriptAlias /rt/ /opt/pkgs/rt/3.4.5/bin/mason_handler.fcgi/

RT_SiteConfig.pm
Set($WebBaseURL , “http://test.uchicago.edu:8080”);
Set($WebPath , “”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);
Set($LogDir, ‘/opt/pkgs/rt/3.4.5/var/log’);
Set($LogToFileNamed , “/tmp/rt.log”); #log to rt.log

Hi Mike,

Thanks for the reply. I tried with .fcgi or fcgi and they have the
same result. Any suggestions would be appreciately.

Mike Friedman wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1On Wed, 20 Sep 2006 at 14:06 (-0500), Yongrui Tang wrote:

httpd.conf
<VirtualHost *:8080>
ServerName test.uchicago.edu:8080
DocumentRoot “/opt/pkgs/rt/3.4.5/html”
AddHandler fastcgi-script .fcgi

FWIW: my apache config has ‘fcgi’, not ‘.fcgi’. I don’t know if this is
significant.

Mike

Mike Friedman IST/System and Network Security
mikef@berkeley.edu 2484 Shattuck Avenue
1-510-642-1410 University of California at Berkeley
Socrates and Berkeley Scholars Web Hosting Services Have Been Retired | Web Platform Services http://security.berkeley.edu

-----BEGIN PGP SIGNATURE-----
Version: PGP 6.5.8

iQA/AwUBRRGbqq0bf1iNr4mCEQKE+wCfXASrOu2FbcoBdjzq9hpFik7gD2gAn0HB
5mB/pDH3QAxU8bdkLPltYDAe
=QlZy
-----END PGP SIGNATURE-----

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Yongrui Tang wrote:

Hi Mike,

Thanks for the reply. I tried with .fcgi or fcgi and they have the
same result. Any suggestions would be appreciately.

Mike Friedman wrote:

httpd.conf
<VirtualHost *:8080>
ServerName test.uchicago.edu:8080
DocumentRoot “/opt/pkgs/rt/3.4.5/html”
AddHandler fastcgi-script .fcgi

I’m not 100% sure, but I’d guess that you don’t want the :8080 in your
ServerName directive.

so it should probably look something like:

<VirtualHost *:8080>
ServerName test.uchicago.edu
DocumentRoot “/opt/pkgs/rt/3.4.5/html”

more detailed information can be found here:

http://httpd.apache.org/docs/2.0/vhosts/examples.html

Alan
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFFF6GcE2gsBSKjZHQRAsmpAJ440JWFiTPqYapebov1TbZ69MD9xwCfZYTW
I0JdReJs37SYm2d1wpKumSQ=
=6wfV
-----END PGP SIGNATURE-----