Error upgrading RT 303 to 305 - Invalid user www!

Hi !

I was to bring up to upgrade the RT 3.0.3 to 3.0.5 version with command “make upgrade” and
get this error :

chown: www: invalid user
make: *** [fixperms] Error 1

My apache user is nobody.

How can I fix this ?

Please, help me!

Ana Paula Prado ap@webhostbrasil.com.br

Vi your /etc/httpd/conf/httpd.conf file to see what user your httpd runs
as and then edit the makefile where www user/group is and put your info
there. I had to do it and it worked.

Michael-----Original Message-----
From: Ana Paula Prado [mailto:ap@webhostbrasil.com.br]
Posted At: Thursday, September 11, 2003 2:27 PM
Posted To: RT
Conversation: [rt-users] Error upgrading RT 303 to 305 - Invalid user
www !
Subject: [rt-users] Error upgrading RT 303 to 305 - Invalid user www !

Hi !

I was to bring up to upgrade the RT 3.0.3 to 3.0.5 version with command
“make upgrade” and
get this error :

chown: www: invalid user
make: *** [fixperms] Error 1

My apache user is nobody.

How can I fix this ?

Please, help me!

Ana Paula Prado ap@webhostbrasil.com.br

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

On 11 September 2003, RT <RT@InterCept.Net> wrote:

> Vi your /etc/httpd/conf/httpd.conf file to see what user your

> httpd runs as and then edit the makefile where www user/group

> is and put your info there. I had to do it and it worked.

There is no need to edit the makefile directly. Run ./configure with the --with-web-user and --with-web-group options. While you are running configure make sure you use the appropriate options for modperl or fastcgi and the proper database. This is all documented in the README.

Michael

--

Michael S. Liebman

Viacom Networks N.O.C. ENGINEERING

Email: michael.liebman@mtvstaff.com

Phone: 631-435-4900 x3304

Fax: 631-231-8051

| Vi your /etc/httpd/conf/httpd.conf file to see what user your httpd runs
| as and then edit the makefile where www user/group is and put your info
| there. I had to do it and it worked.
|
| Michael

Thank you Michael !
Now, its work !
Ana Paula Prado ap@webhostbrasil.com.br