Error on startup -- new install

Does anyone have an idea about this issue?

This is a new install on a fedora core 3 box, utilizing the pre-build
apache 2x and modperl… All CPAN modules are installed (I utilized
the fedora core 2 howto on the wiki).

I would love to figure out why this is not working… I was originally
planning on upgrading our RT box and had this problem when going from a
version a few back (3.0.11) to the current rev and thought I might as
well start over, and add a new HD to our RT box. (I have the SQL
running on a separate machine).

[root@rt log]# service httpd start
Starting httpd: [Mon Jan 24 19:03:11 2005] [error] Can’t locate
/apps/rt3/bin/webmux.pl in @INC (@INC contains:
/usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at (eval
2) line 1.\n
[Mon Jan 24 19:03:11 2005] [error] Can’t load Perl file:
/apps/rt3/bin/webmux.pl for server rt.pocketinet.com:0, exiting…
[FAILED]

[Mon Jan 24 19:03:11 2005] [error] Can’t load Perl file:
/apps/rt3/bin/webmux.pl for server rt.pocketinet.com:0, exiting…
[FAILED]

The error message is quite clear. Make sure you’re pointing to the
correct location to allow it to find the webmux.pl file.

Andy Harrison

This may be related to the default SE-Linux settings
on FC3 installation? I had to set set it to “disabled”
(not the default) to get Apache to startup initially
after the RT install.

Message: 3
Date: Mon, 24 Jan 2005 18:36:58 -0800
From: “John van Oppen” john@vanoppen.com
Subject: [rt-users] Error on startup – new install
To: rt-users@lists.bestpractical.com
Message-ID:

A431146554A0EA4A8C8842D94311BA6DAF99@server-ww.home.vanoppen.com

Content-Type: text/plain; charset=“us-ascii”

Does anyone have an idea about this issue?

This is a new install on a fedora core 3 box,
utilizing the pre-build
apache 2x and modperl… All CPAN modules are
installed (I utilized
the fedora core 2 howto on the wiki).

I would love to figure out why this is not
working… I was originally
planning on upgrading our RT box and had this
problem when going from a
version a few back (3.0.11) to the current rev and
thought I might as
well start over, and add a new HD to our RT box.
(I have the SQL
running on a separate machine).

ALL-NEW Yahoo! Messenger - all new features - even more fun! http://uk.messenger.yahoo.com

Ok… I had a few missing dependencies before (make testdeps finds more than the command listed in the howto for modperl2)… However, now I am totally stumped, anyone have any idea what I can do to get this one resolved?

John :slight_smile:

Starting httpd: [Tue Jan 25 07:58:20 2005] [error] Can’t locate /apps/rt3/bin/webmux.pl in @INC (@INC contains: /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at (eval 4) line 1.\n
[Tue Jan 25 07:58:20 2005] [error] Can’t load Perl file: /apps/rt3/bin/webmux.pl for server rt.pocketinet.com:0, exiting…
[FAILED]
[root@rt mail]#Von: brian mccabe [mailto:thealbs@yahoo.co.uk]
Gesendet: Tuesday, January 25, 2005 5:09 AM
An: rt-users@lists.bestpractical.com
Betreff: [rt-users] Re: Error on startup – new install

This may be related to the default SE-Linux settings
on FC3 installation? I had to set set it to “disabled”
(not the default) to get Apache to startup initially
after the RT install.

Message: 3
Date: Mon, 24 Jan 2005 18:36:58 -0800
From: “John van Oppen” john@vanoppen.com
Subject: [rt-users] Error on startup – new install
To: rt-users@lists.bestpractical.com
Message-ID:

A431146554A0EA4A8C8842D94311BA6DAF99@server-ww.home.vanoppen.com

Content-Type: text/plain; charset=“us-ascii”

Does anyone have an idea about this issue?

This is a new install on a fedora core 3 box,
utilizing the pre-build
apache 2x and modperl… All CPAN modules are
installed (I utilized
the fedora core 2 howto on the wiki).

I would love to figure out why this is not
working… I was originally
planning on upgrading our RT box and had this
problem when going from a
version a few back (3.0.11) to the current rev and
thought I might as
well start over, and add a new HD to our RT box.
(I have the SQL
running on a separate machine).

ALL-NEW Yahoo! Messenger - all new features - even more fun! http://uk.messenger.yahoo.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon! (Boston, San Francisco, Austin, Sydney) Contact training@bestpractical.com for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

John,

We are running RT on Fedora Core 3 here (also with Apache2 and modperl
1.99 & with sulinux disabled ) so I do not think your problem is with
the Fedora Core setup. It looks to me like you have incorrect paths in
your RT_SiteConfig.pm file or in your Apache (virtual server?) setup.
Our setup looks like this:

Apache:

<VirtualHost 192.168.1.100:80>
ServerName rt.ourdomain.com
DocumentRoot /usr/local/rt3/share/html
AddDefaultCharset UTF-8

   PerlSetVar MasonArgsMethod CGI
   PerlModule Apache2 Apache::compat
   RewriteEngine On
   RewriteRule ^(.*)/$ $1/index.html

   PerlModule Apache::DBI
   PerlRequire /usr/local/rt3/bin/webmux.pl

           <Location />
             SetHandler perl-script
             PerlHandler RT::Mason
           </Location>
   ErrorLog /var/log/rt-error_log
   CustomLog /var/log/rt-access_log common

RT - (/usr/local/rt3/etc/RT_SiteConfig.pm)

Set($rtname , “OurName”);
Set($Organization , “ourdomain.com”);
Set($DatabaseUser , ‘rt_user’);
Set($DatabasePassword , ‘********’);
Set($DatabaseName , ‘rt3’);
Set($CanonicalizeEmailAddressMatch , ‘rt.ourdomain.com$’);
Set($CanonicalizeEmailAddressReplace , ‘ourservername.ourdomain.com’);
Set($CorrespondAddress , ‘support@rt.ourdomain.com’);
Set($CommentAddress , ‘support@rt.ourdomain.com’);
Set($WebPath, “”);
Set($WebBaseURL , “http://rt.ourdomain.com”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);
Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

I’m sure there are other configs that work and this may not be the
best solution but it works for us. We have RT in /usr/local and not
the default /opt location.

Stephen HancockOn Tue, 25 Jan 2005 07:00:33 -0800, John van Oppen john@vanoppen.com wrote:

Ok… I had a few missing dependencies before (make testdeps finds more than the command listed in the howto for modperl2)… However, now I am totally stumped, anyone have any idea what I can do to get this one resolved?

John :slight_smile:

Starting httpd: [Tue Jan 25 07:58:20 2005] [error] Can’t locate /apps/rt3/bin/webmux.pl in @INC (@INC contains: /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at (eval 4) line 1.\n
[Tue Jan 25 07:58:20 2005] [error] Can’t load Perl file: /apps/rt3/bin/webmux.pl for server rt.pocketinet.com:0, exiting…
[FAILED]
[root@rt mail]#
-----Ursprüngliche Nachricht-----
Von: brian mccabe [mailto:thealbs@yahoo.co.uk]
Gesendet: Tuesday, January 25, 2005 5:09 AM
An: rt-users@lists.bestpractical.com
Betreff: [rt-users] Re: Error on startup – new install

This may be related to the default SE-Linux settings
on FC3 installation? I had to set set it to “disabled”
(not the default) to get Apache to startup initially
after the RT install.

Message: 3
Date: Mon, 24 Jan 2005 18:36:58 -0800
From: “John van Oppen” john@vanoppen.com
Subject: [rt-users] Error on startup – new install
To: rt-users@lists.bestpractical.com
Message-ID:

A431146554A0EA4A8C8842D94311BA6DAF99@server-ww.home.vanoppen.com

Content-Type: text/plain; charset=“us-ascii”

Does anyone have an idea about this issue?

This is a new install on a fedora core 3 box,
utilizing the pre-build
apache 2x and modperl… All CPAN modules are
installed (I utilized
the fedora core 2 howto on the wiki).

I would love to figure out why this is not
working… I was originally
planning on upgrading our RT box and had this
problem when going from a
version a few back (3.0.11) to the current rev and
thought I might as
well start over, and add a new HD to our RT box.
(I have the SQL
running on a separate machine).


ALL-NEW Yahoo! Messenger - all new features - even more fun! http://uk.messenger.yahoo.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon! (Boston, San Francisco, Austin, Sydney) Contact training@bestpractical.com for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon! (Boston, San Francisco, Austin, Sydney) Contact training@bestpractical.com for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com