Error moving File to External Storage (Disk)

Hi RT Team,

We have configured RT External Storage (Disk) in our RT landscape as per the documentation provided in RT, but when we are trying to run the below command we are getting error

“[9308] [Tue Apr 26 12:07:54 2022] [critical]: %ExternalStorage is not configured (/opt/rt5/sbin/…/lib/
%ExternalStorage is not configured”

Command we are executing
“./rt-externalize-attachments --age=700 --verbose --batchsize=10”

Configuration we have done in RT Site Config (we have also restarted the web service after configuration)


Type => ‘Disk’,
Path => ‘/opt/rt5/var/attachments’

Kindly help us on this error.

  1. I don’t believe you want the “Plugin” line as external storage is core for RT 5.

  2. Maybe you need to set the config in the web UI Admin->Tools->System configuration->features

Still the same error i have removed the pulgin and changes done in features

Was the directory “/opt/rt5/var/attachments” created?

Here a comma is missing:
Path => ‘/opt/rt5/var/attachments’,

Yes, the directory is created and we have tried the same with comma as well, but getting same error.