Enhanced functionality SelfServiceSimpleSearch RT 4.4

Hello, I wanted to ask you to have someone install the SelfServiceSimpleSearch extension into RT 4.4? I have installed, but I do not search for tickets, only a blank page appears after the search. Could any of RT or Pearl be found to happen inside the RT when trying to search for a ticket? It would be like a log or trace. There are no errors in the RT log. I thank everyone who answers

Hi petr0707,

I installed it and it’s working on our end.


Thank you for answer. Can the customer search the body of the ticket?

Same as the simple search in Privileged RT.

Did you install the extension somehow or did it need to modify or edit the user’s rights? I downloaded the package, compiled it and added the line Plugin (“RT :: Extension :: SelfServiceSimpleSearch”) to RT_SiteConfig.pm; Performed cache removal and restarting the webserver. When a user logs in, the search appears, but I can not find the tickets using obsdahu. Could you please specify what RT version you have? Thank you


It’s under the Tickets then Simple search. You can only search ticket # on the upper right search ‘Go to Ticket’. If you want to search other details just go to ‘Simple Search’. We are using RT 4.4.1-5.

In my RT, I have the same as you describe, but when I use Simple search as a customer and I will search for the contents of the Ticket so the ticket will not be displayed.

You cannot search the content of the ticket.

You can only search these

" Search for tickets by entering id numbers, subject words “in quotes”, queues by name, Owners by username, Requestors by email address, and ticket statuses. Searching for @domainname.com will return tickets with requestors from that domain.

Any word not recognized by RT is searched for in ticket subjects.

Entering initial, active, inactive, or any limits results to tickets with one of the respective types of statuses. Any individual status name limits results to just the statuses named.

Start the search term with the name of a supported field followed by a colon, as in queue:“Example Queue” and owner:email@example.com, to explicitly specify the search type.

CFs may be searched using a similar syntax as above with cf.Name:value."

I tried to find tickets using the queue name in my case queue: “test3”, but no result was displayed, even if the queue exists and when I leave the tickets under the test3 user I can see the tickets. I tried to search also by owner ie. owner: test3@test.cz, and I did not see anything even when the mail is set for the user.

Did you try checking the Unprivileged rights?

Yes. Test3 is in test3 and uses test3. When I look at the test queue3, I have set the test3 for the test group.

Hi Petr

Are you trying to search for tickets from other users, via self service, or are these all tickets of the user you’re logged in as?


Hi G.Booth I’m looking for tickets to the user who I am logged in tzn test3. I will create a test ticket3 and I can show it under test3. Tickets can not be searched using simplesearch.

Is there a tool for debugging why ticketing does not work?

The web server logs are the first port of call. If the normal level of logging doesn’t show up the issues, you can turn the debug options on in RT_SiteConfig.pm. Beyond that you can add debugging statements in the scripts themselves

How can I add a debug statement to the script itself? what is the command?

I turned on logging in RT_SiteConfig.pm to delete the cache and restart the apache and tried to find the ticket but nothing was logged. Logging is enabled as follows:

Set($LogToSyslog, “debug”);
Set($LogToFileNamed, ‘rt.log’);
Set($LogDir, ‘/opt/rt4/var/log’);

Could you please tell me how you have set user rights to show you ticketing on simple search? I would create a test user. Thank you

Does your web server have rights to write to /opt/rt4/var/log? We tend to dump ours into a directory outside the RT directory tree (/tmp/rt4log) that apache can definitely write into:

Set($LogToFile , 'debug');
Set($LogDir, '/tmp/rt4log');
Set($LogToFileNamed , "rt.log");

Bare in mind that debugging turned on can generate lots of output, so shouldn’t be left on for production servers (you’ll also potentially need quite a bit of disc space in /tmp!).

How can I write from the perl script to the rt log?