End of script output before headers: rt-server.fcgi


#1

Receiving this error message when attempting to deploy RT 4.0.8 on RHEL7.2. Works fine on RHEL6.9 and CentOS 7.2 using same installation procedures. I am using some customizations which is why some references point to /opt/rt4/as/Linux… But all works as desired on other OS’s.

Here’s my configurations:
/etc/httpd/conf.d/rt.conf

RT4 configuration for Apache

Optional apache logs for RT

Ensure that your log rotation scripts know about these files

ErrorLog /opt/rt4/var/log/apache2.error

TransferLog /opt/rt4/var/log/apache2.access

LogLevel debug

AddDefaultCharset UTF-8

Alias /rt/NoAuth/images /opt/rt4/share/html/NoAuth/images/

ScriptAlias /rt /opt/rt4/sbin/rt-server.fcgi/

DocumentRoot “/opt/rt4/share/html”

<Location /rt>

For Centos7/Apache 2.4 this line:

Require all granted

For Centos6/Apache 2.2 these two lines:

Order allow,deny

Allow from all

Options +ExecCGI
AddHandler fcgid-script fcgi

/etc/httpd/conf.d/fcgid.conf

This is the Apache server configuration file for providing FastCGI support

through mod_fcgid

Documentation is available at

http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html

Use FastCGI to process .fcg .fcgi & .fpl scripts

AddHandler fcgid-script fcg fcgi fpl

Sane place to put sockets and shared memory file

#FcgidIPCDir /run/mod_fcgid
FcgidIPCDir /opt/rt4/as/Linux/var/fastcgi/
FcgidWrapper /opt/rt4/sbin/rt-server.fcgi
FcgidProcessTableFile /run/mod_fcgid/fcgid_shm
FcgidMaxRequestLen 1073741824
FcgidMaxProcesses 1200

/etc/httpd/conf.d/ssl.conf
Listen 443
SSLPassPhraseDialog builtin
SSLSessionCache shmcb:/var/cache/mod_ssl/scache(512000)
SSLSessionCacheTimeout 300
SSLRandomSeed startup file:/dev/urandom 256
SSLRandomSeed connect builtin
SSLCryptoDevice builtin

ServerName 192.168.70.22
SetEnvIf X-Forwarded-User (.*) REMOTE_USER=$1
SSLOptions +ExportCertData +StdEnvVars
ErrorLog logs/ssl_error_log
LogFormat "%h %l %u %t “%r” %>s %b “%{Referer}i” “%{User-Agent}i” %I %O"
TransferLog logs/ssl_access_log
LogLevel debug
SSLEngine on
SSLCertificateFile /etc/pki/tls/certs/localhost.crt
SSLCertificateKeyFile /etc/pki/tls/private/localhost.key
<Files ~ “.(cgi|shtml|phtml|php3?)$”>
SSLOptions +ExportCertData +StdEnvVars

<Directory “/var/www/cgi-bin”>
SSLOptions +ExportCertData +StdEnvVars

SetEnvIf User-Agent “.MSIE.
nokeepalive ssl-unclean-shutdown
downgrade-1.0 force-response-1.0
CustomLog logs/ssl_request_log
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x “%r” %b"
AddDefaultCharset UTF-8
AddHandler fastcgi-script fcgi

<Directory “/opt/rt4” >
Options FollowSymLinks ExecCGI
AllowOverride None

/etc/httpd/conf/httpd.conf
TraceEnable off
ServerTokens OS
ServerRoot "/etc/httpd"
PidFile run/httpd.pid
LimitRequestBody 1024000
LimitRequestFields 100
LimitRequestFieldSize 8190
LimitRequestLine 8190
Timeout 120
KeepAlive Off
MaxKeepAliveRequests 100
KeepAliveTimeout 15

StartServers 8
MinSpareServers 5
MaxSpareServers 10
ServerLimit 3000
MaxClients 256
MaxRequestsPerChild 4000


StartServers 2
MaxClients 3000
MinSpareThreads 25
MaxSpareThreads 75
ThreadsPerChild 25
MaxRequestsPerChild 0

Listen 80
ExtendedStatus On
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule include_module modules/mod_include.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule env_module modules/mod_env.so
LoadModule mime_magic_module modules/mod_mime_magic.so
LoadModule expires_module modules/mod_expires.so
LoadModule deflate_module modules/mod_deflate.so
LoadModule headers_module modules/mod_headers.so
LoadModule usertrack_module modules/mod_usertrack.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule mime_module modules/mod_mime.so
LoadModule vhost_alias_module modules/mod_vhost_alias.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule dir_module modules/mod_dir.so
LoadModule actions_module modules/mod_actions.so
LoadModule speling_module modules/mod_speling.so
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule suexec_module modules/mod_suexec.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_anon_module modules/mod_authn_anon.so
LoadModule authn_dbm_module modules/mod_authn_dbm.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule authz_owner_module modules/mod_authz_owner.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_dbm_module modules/mod_authz_dbm.so
LoadModule logio_module modules/mod_logio.so
LoadModule ext_filter_module modules/mod_ext_filter.so
LoadModule version_module modules/mod_version.so
LoadModule status_module modules/mod_status.so
Include conf.modules.d/.conf
IncludeOptional conf.d/
.conf
User apache
Group apache
ServerAdmin root@localhost
UseCanonicalName Off
DocumentRoot “/var/www/html”
<Directory “/var/www/html”>
Options Indexes SymLinksifOwnerMatch
AllowOverride None
Order allow,deny
Allow from all


UserDir disabled

DirectoryIndex index.html index.html.var
AccessFileName .htaccess
<Files ~ “^.ht”>
Order allow,deny
Deny from all

TypesConfig /etc/mime.types
DefaultType text/plain

MIMEMagicFile conf/magic

HostnameLookups Off
ErrorLog syslog:local6
LogLevel warn
LogFormat “%h %A %h %H %l %m %s %t %u %U “%r” %>s %b “%{Referer}i” “%{User-Agent}i”” custom
CustomLog “|/bin/logger -thttpd -plocal6.notice” custom
ServerSignature On
Alias /icons/ “/var/www/icons/”
<Directory “/var/www/icons”>
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all

ScriptAlias /cgi-bin/ “/var/www/cgi-bin/”
<Directory “/var/www/cgi-bin”>
AllowOverride None
Options None
Order allow,deny
Allow from all

LanguagePriority en ca cs da de el eo es et fr he hr it ja ko ltz nl nn no pl pt pt-BR ru sv zh-CN zh-TW
ForceLanguagePriority Prefer Fallback
AddDefaultCharset UTF-8
AddType application/x-compress .Z
AddType application/x-gzip .gz .tgz
AddType application/x-x509-ca-cert .crt
AddType application/x-pkcs7-crl .ai
AddHandler imap-file map
AddHandler type-map var
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Alias /error/ “/var/www/error/”


<Directory “/var/www/error”>
AllowOverride None
Options IncludesNoExec
AddOutputFilter Includes html
AddHandler type-map var
Order allow,deny
Allow from all
LanguagePriority en es de fr
ForceLanguagePriority Prefer Fallback



<Location /server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from localhost

BrowserMatch “Mozilla/2” nokeepalive
BrowserMatch “MSIE 4.0b2;” nokeepalive downgrade-1.0 force-response-1.0
BrowserMatch “RealPlayer 4.0” force-response-1.0
BrowserMatch “Java/1.0” force-response-1.0
BrowserMatch “JDK/1.0” force-response-1.0
BrowserMatch “Microsoft Data Access Internet Publishing Provider” redirect-carefully
BrowserMatch “^WebDrive” redirect-carefully
BrowserMatch “^WebDAVFS/1.[0123]” redirect-carefully
BrowserMatch “^gnome-vfs/1.0” redirect-carefully
BrowserMatch “^XML Spy” redirect-carefully
BrowserMatch “^Dreamweaver-WebDAV-SCM1” redirect-carefully
<VirtualHost :80>
ServerName 192.168.70.22
RewriteEngine On
RewriteRule ^.
$ https://192.168.70.22/ [R,L]
RewriteCond %{REQUEST_METHOD} !^(GET|POST|HEAD)$
RewriteRule .* - [F]


Header set Cache-Control "private, no-cache, no-store, proxy-revalidate, no-transform"
Header set Pragma “no-cache”