Encoding of subject line in outgoing messages

Hello list,

I just installed RT 4.0.4 on Debian Squeeze with mySQL.

If I create a ticket in the web interface with french special characters like é à in the subject, the subject line of the outgoing mail for the requestor is not OK. Here is the mail header :

 =?us-ascii?Q?k6IENyw6nDqSBkYW5zIFJUIGF2ZWM=3D=3F=3D?=

Seems to be utf-8 surrounded by us-ascii !?

EmailOutputEncoding is set to ‘utf-8’ ( that was the default config ). Where does this us-ascii come from ?

Everything shows OK in the web interface.

No problem with the special characters in the description of issue.

The outgoing emails are handeled by mailx. No problem with special characters when using mailx from the console.

Stephane

If I create a ticketin the web interface with french special characters
like é àin the subject, the subject line of the outgoing mail for the
requestorisnot OK. Here is the mail header :

Subject: =?us-ascii?Q?=3D=3FUTF-8=3FB=3FW3NlZmFuZXQgIzE2XSBBdXRvUmVwbH?=

 =?us-ascii?Q?k6IENyw6nDqSBkYW5zIFJUIGF2ZWM=3D=3F=3D?=

Seems tobe utf-8 surrounded by us-ascii !?

This is a correct encoding of Subject lines according to mail standards.
Is it actually causing problems in your mail client?

Thomas

If I create a ticketin the web interface with french special characters
like é àin the subject, the subject line of the outgoing mail for the
requestorisnot OK. Here is the mail header :

Subject: =?us-ascii?Q?=3D=3FUTF-8=3FB=3FW3NlZmFuZXQgIzE2XSBBdXRvUmVwbH?=

 =?us-ascii?Q?k6IENyw6nDqSBkYW5zIFJUIGF2ZWM=3D=3F=3D?=

Seems tobe utf-8 surrounded by us-ascii !?

This is a correct encoding of Subject lines according to mail standards.
Is it actually causing problems in your mail client?

Actually, it is a little weird since it’s doubly MIME header encoded (as
I just noticed). You’ve said it appears to be mailx, so I’ll clam up
now. :wink:

Thomas