Enabling full text index, getting "MySQL server has gone away"

Hi all,
As the subject says, I’m trying to enable full text indexing. I’ve updated
MySQL to 5.7 (on Debian 8) and ran

/opt/rt4/sbin/rt-setup-fulltext-index --dba root --dba-password pwd

However, I get a bunch of warnings about executing the SQL statements and,
after that, that attachments can’t be indexed. In all cases, the main
problem is the same: “the MySQL server has gone away”. The initial
connection was successful, so I’m not sure what the problem is. I also
tested the root login after the 5.7 update, just to be sure it worked, and
it was fine. Has anyone ever seen this happen? Any suggestions on what to
do about it? Thanks!

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

I should also say that I’ve already tried setting my MySQL max_packet_size.
500M didn’t do it, so I upped it to 5000M, restarting the service both
times. That hasn’t changed the warnings I’m getting, and I really don’t
think any attachments are over 5GB. Plus, the first few warnings are that
"st execute failed", not about attachments not being indexed.On Mon, Nov 14, 2016 at 7:46 AM, Alex Hall ahall@autodist.com wrote:

Hi all,
As the subject says, I’m trying to enable full text indexing. I’ve updated
MySQL to 5.7 (on Debian 8) and ran

/opt/rt4/sbin/rt-setup-fulltext-index --dba root --dba-password pwd

However, I get a bunch of warnings about executing the SQL statements and,
after that, that attachments can’t be indexed. In all cases, the main
problem is the same: “the MySQL server has gone away”. The initial
connection was successful, so I’m not sure what the problem is. I also
tested the root login after the 5.7 update, just to be sure it worked, and
it was fine. Has anyone ever seen this happen? Any suggestions on what to
do about it? Thanks!


Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

Hi Alex,

I think the mysql configuration be “max_allowed_packet” rather than
"max_packet_size".

Best Regards

MartinOn 2016-11-14 13:54, Alex Hall wrote:

I should also say that I’ve already tried setting my MySQL
max_packet_size. 500M didn’t do it, so I upped it to 5000M, restarting
the service both times. That hasn’t changed the warnings I’m getting,
and I really don’t think any attachments are over 5GB. Plus, the first
few warnings are that “st execute failed”, not about attachments not
being indexed.

On Mon, Nov 14, 2016 at 7:46 AM, Alex Hall ahall@autodist.com wrote:

Hi all,
As the subject says, I’m trying to enable full text indexing. I’ve
updated MySQL to 5.7 (on Debian 8) and ran

/opt/rt4/sbin/rt-setup-fulltext-index --dba root --dba-password pwd

However, I get a bunch of warnings about executing the SQL
statements and, after that, that attachments can’t be indexed. In
all cases, the main problem is the same: “the MySQL server has gone
away”. The initial connection was successful, so I’m not sure what
the problem is. I also tested the root login after the 5.7 update,
just to be sure it worked, and it was fine. Has anyone ever seen
this happen? Any suggestions on what to do about it? Thanks!

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com


RT 4.4 and RTIR training sessions, and a new workshop day!
https://bestpractical.com/training

  • Los Angeles - January 9-11 2017

Thanks for the correction. I hate to say it, but this didn’t change the
results I’m seeing at all. I just updated /etc/mysql/conf.d/mysql.cnf,
restarted MySQL, and ran the full-text index command again. I got the exact
same errors as before.On Mon, Nov 14, 2016 at 11:50 AM, Martin Wheldon < martin.wheldon@greenhills-it.co.uk> wrote:

Hi Alex,

I think the mysql configuration be “max_allowed_packet” rather than
"max_packet_size".

Best Regards

Martin

On 2016-11-14 13:54, Alex Hall wrote:

I should also say that I’ve already tried setting my MySQL
max_packet_size. 500M didn’t do it, so I upped it to 5000M, restarting
the service both times. That hasn’t changed the warnings I’m getting,
and I really don’t think any attachments are over 5GB. Plus, the first
few warnings are that “st execute failed”, not about attachments not
being indexed.

On Mon, Nov 14, 2016 at 7:46 AM, Alex Hall ahall@autodist.com wrote:

Hi all,

As the subject says, I’m trying to enable full text indexing. I’ve
updated MySQL to 5.7 (on Debian 8) and ran

/opt/rt4/sbin/rt-setup-fulltext-index --dba root --dba-password pwd

However, I get a bunch of warnings about executing the SQL
statements and, after that, that attachments can’t be indexed. In
all cases, the main problem is the same: “the MySQL server has gone
away”. The initial connection was successful, so I’m not sure what
the problem is. I also tested the root login after the 5.7 update,
just to be sure it worked, and it was fine. Has anyone ever seen
this happen? Any suggestions on what to do about it? Thanks!

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com


RT 4.4 and RTIR training sessions, and a new workshop day!
https://bestpractical.com/training

  • Los Angeles - January 9-11 2017

RT 4.4 and RTIR training sessions, and a new workshop day!
https://bestpractical.com/training

  • Los Angeles - January 9-11 2017

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

I had success by using Debian’s snapshot server and downgrading MySQL 5.6.27-2 and then running rt-setup-fulltext-index. That worked perfectly.

You can safely “upgrade” back to your current version after the setup script runs – the fulltext index maintenance script will run fine.

If downgrading worked, please update my Debian bug report with the version that did not work for you: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=840780

JamesFrom: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Alex Hall
Sent: Monday, November 14, 2016 7:57 AM
To: martin.wheldon@greenhills-it.co.uk
Cc: rt-users
Subject: Re: [rt-users] Enabling full text index, getting “MySQL server has gone away”

Thanks for the correction. I hate to say it, but this didn’t change the results I’m seeing at all. I just updated /etc/mysql/conf.d/mysql.cnf, restarted MySQL, and ran the full-text index command again. I got the exact same errors as before.

For future readers, my own solution was–thankfully–much simpler. Nowhere
that I found in the docs I was reading did it say you had to add the
max_allowed_packet setting under a section called [mysqld] in my.cnf. As
soon as I did that, my setting took effect, and the full text setup ran
perfectly.On Mon, Nov 14, 2016 at 12:10 PM, James Zuelow James.Zuelow@juneau.org wrote:

I had success by using Debian’s snapshot server and downgrading MySQL
5.6.27-2 and then running rt-setup-fulltext-index. That worked perfectly.

You can safely “upgrade” back to your current version after the setup
script runs – the fulltext index maintenance script will run fine.

If downgrading worked, please update my Debian bug report with the version
that did not work for you: http://bugs.debian.org/cgi-
bin/bugreport.cgi?bug=840780

James

From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] *On
Behalf Of *Alex Hall
Sent: Monday, November 14, 2016 7:57 AM
To: martin.wheldon@greenhills-it.co.uk
Cc: rt-users
Subject: Re: [rt-users] Enabling full text index, getting “MySQL server
has gone away”

Thanks for the correction. I hate to say it, but this didn’t change the
results I’m seeing at all. I just updated /etc/mysql/conf.d/mysql.cnf,
restarted MySQL, and ran the full-text index command again. I got the exact
same errors as before.

On Mon, Nov 14, 2016 at 11:50 AM, Martin Wheldon < martin.wheldon@greenhills-it.co.uk> wrote:

Hi Alex,

I think the mysql configuration be “max_allowed_packet” rather than
"max_packet_size".

Best Regards

Martin

On 2016-11-14 13:54, Alex Hall wrote:

I should also say that I’ve already tried setting my MySQL
max_packet_size. 500M didn’t do it, so I upped it to 5000M, restarting
the service both times. That hasn’t changed the warnings I’m getting,
and I really don’t think any attachments are over 5GB. Plus, the first
few warnings are that “st execute failed”, not about attachments not
being indexed.

On Mon, Nov 14, 2016 at 7:46 AM, Alex Hall ahall@autodist.com wrote:

Hi all,
As the subject says, I’m trying to enable full text indexing. I’ve
updated MySQL to 5.7 (on Debian 8) and ran

/opt/rt4/sbin/rt-setup-fulltext-index --dba root --dba-password pwd

However, I get a bunch of warnings about executing the SQL
statements and, after that, that attachments can’t be indexed. In
all cases, the main problem is the same: “the MySQL server has gone
away”. The initial connection was successful, so I’m not sure what
the problem is. I also tested the root login after the 5.7 update,
just to be sure it worked, and it was fine. Has anyone ever seen
this happen? Any suggestions on what to do about it? Thanks!

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com


RT 4.4 and RTIR training sessions, and a new workshop day!
https://bestpractical.com/training

  • Los Angeles - January 9-11 2017

RT 4.4 and RTIR training sessions, and a new workshop day!
https://bestpractical.com/training

  • Los Angeles - January 9-11 2017

Alex Hall

Automatic Distributors, IT department

ahall@autodist.com

Alex Hall
Automatic Distributors, IT department
ahall@autodist.com

That’s good. I was concerned that you had the same issue with MySQL 5.7 and the implications for RT on Stretch.

Max_allowed_packet does not work with 5.6.29 or 5.6.30 (at least not the Debian packages at those versions).

JamesFrom: Alex Hall [mailto:ahall@autodist.com]
Sent: Monday, November 14, 2016 1:33 PM
To: James Zuelow
Cc: martin.wheldon@greenhills-it.co.uk; rt-users
Subject: Re: [rt-users] Enabling full text index, getting “MySQL server has gone away”

For future readers, my own solution was–thankfully–much simpler. Nowhere that I found in the docs I was reading did it say you had to add the max_allowed_packet setting under a section called [mysqld] in my.cnf. As soon as I did that, my setting took effect, and the full text setup ran perfectly.