Email send problems

For some reason mail is not getting sent out when I update tickets or do
any sort of ticket activity. This isn’t just to my mail address but to
all the ones that I put in bcc cc and admincc etc. Here is what I have
in siteconfig

#Sendmail Configuration

Set($MailCommand , ‘sendmailpipe’);

Set($SendmailArguments , “-oi -t”);

Set($SendmailPath , “/var/qmail/bin/sendmail”);

I’m not sure what I’m missing since the logs show that the mail is being
sent

[Wed Apr 2 23:49:09 2003] [info]: RT::Scrip=HASH(0x939a1bc): Couldn’t
prepare Open Tickets (/usr/local/RT/lib/RT/Scrip_Overlay.pm:338)

[Wed Apr 2 23:49:10 2003] [info]:
rt-3.0.0-7-24.16.7961090247589@garnetws.com #7/24 - Scrip 4
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:10 2003] [info]:
rt-3.0.0-7-24.16.7961090247589@garnetws.com sent To: Cc: Bcc:
exothermic@softhome.net (/usr/local/RT/lib/RT/Action/SendEmail.pm:205)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.9.25383705275721@garnetws.com #7/24 - Scrip 5
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.9.25383705275721@garnetws.com sent To:
miles.scruggs@garnetws.com Cc: exothermic@digitalphotobox.net Bcc:
(/usr/local/RT/lib/RT/Action/SendEmail.pm:205)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.18.4358909494154@garnetws.com #7/24 - Scrip 6
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.18.4358909494154@garnetws.com No recipients found. Not
sending. (/usr/local/RT/lib/RT/Action/SendEmail.pm:170)

I’m a little disconcerned with that fist line in the log file

[Wed Apr 2 23:49:09 2003] [info]: RT::Scrip=HASH(0x939a1bc): Couldn’t
prepare Open Tickets (/usr/local/RT/lib/RT/Scrip_Overlay.pm:338)

but instincts tell me that isn’t where my mail problem lies

My MTA is qmail and has been working great for two years. Qmail-smtp
logs don’t turn up any mail being sent to it from rt

Any help

Miles

have a feeling my post fell between the cracks so I’m going to try
again.

Miles

For some reason mail is not getting sent out when I update tickets or do
any sort of ticket activity. This isn’t just to my mail address but to
all the ones that I put in bcc cc and admincc etc. Here is what I have
in siteconfig

#Sendmail Configuration

Set($MailCommand , ‘sendmailpipe’);

Set($SendmailArguments , “-oi -t”);

Set($SendmailPath , “/var/qmail/bin/sendmail”);

I’m not sure what I’m missing since the logs show that the mail is being
sent

[Wed Apr 2 23:49:09 2003] [info]: RT::Scrip=HASH(0x939a1bc): Couldn’t
prepare Open Tickets (/usr/local/RT/lib/RT/Scrip_Overlay.pm:338)

[Wed Apr 2 23:49:10 2003] [info]:
rt-3.0.0-7-24.16.7961090247589@garnetws.com #7/24 - Scrip 4
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:10 2003] [info]:
rt-3.0.0-7-24.16.7961090247589@garnetws.com sent To: Cc: Bcc:
exothermic@softhome.net (/usr/local/RT/lib/RT/Action/SendEmail.pm:205)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.9.25383705275721@garnetws.com #7/24 - Scrip 5
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.9.25383705275721@garnetws.com sent To:
miles.scruggs@garnetws.com Cc: exothermic@digitalphotobox.net Bcc:
(/usr/local/RT/lib/RT/Action/SendEmail.pm:205)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.18.4358909494154@garnetws.com #7/24 - Scrip 6
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.18.4358909494154@garnetws.com No recipients found. Not
sending. (/usr/local/RT/lib/RT/Action/SendEmail.pm:170)

I’m a little disconcerned with that fist line in the log file

[Wed Apr 2 23:49:09 2003] [info]: RT::Scrip=HASH(0x939a1bc): Couldn’t
prepare Open Tickets (/usr/local/RT/lib/RT/Scrip_Overlay.pm:338)

but instincts tell me that isn’t where my mail problem lies

My MTA is qmail and has been working great for two years. Qmail-smtp
logs don’t turn up any mail being sent to it from rt

Any help

Miles

I’m kinda at a loss for what to do. I have posted to the list twice
now. Haven’t heard a peep from anyone. I’m not even sure if my posts
are making it to the lists. Anyway I’ll have another go at, before a
try another system. Are my posts not clear enough? Or is the problem
so simple/hard that no one bothers?

Miles

have a feeling my post fell between the cracks so I’m going to try
again.

Miles

For some reason mail is not getting sent out when I update tickets or do
any sort of ticket activity. This isn’t just to my mail address but to
all the ones that I put in bcc cc and admincc etc. Here is what I have
in siteconfig

#Sendmail Configuration

Set($MailCommand , ‘sendmailpipe’);

Set($SendmailArguments , “-oi -t”);

Set($SendmailPath , “/var/qmail/bin/sendmail”);

I’m not sure what I’m missing since the logs show that the mail is being
sent

[Wed Apr 2 23:49:09 2003] [info]: RT::Scrip=HASH(0x939a1bc): Couldn’t
prepare Open Tickets (/usr/local/RT/lib/RT/Scrip_Overlay.pm:338)

[Wed Apr 2 23:49:10 2003] [info]:
rt-3.0.0-7-24.16.7961090247589@garnetws.com #7/24 - Scrip 4
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:10 2003] [info]:
rt-3.0.0-7-24.16.7961090247589@garnetws.com sent To: Cc: Bcc:
exothermic@softhome.net (/usr/local/RT/lib/RT/Action/SendEmail.pm:205)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.9.25383705275721@garnetws.com #7/24 - Scrip 5
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.9.25383705275721@garnetws.com sent To:
miles.scruggs@garnetws.com Cc: exothermic@digitalphotobox.net Bcc:
(/usr/local/RT/lib/RT/Action/SendEmail.pm:205)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.18.4358909494154@garnetws.com #7/24 - Scrip 6
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.18.4358909494154@garnetws.com No recipients found. Not
sending. (/usr/local/RT/lib/RT/Action/SendEmail.pm:170)

I’m a little disconcerned with that fist line in the log file

[Wed Apr 2 23:49:09 2003] [info]: RT::Scrip=HASH(0x939a1bc): Couldn’t
prepare Open Tickets (/usr/local/RT/lib/RT/Scrip_Overlay.pm:338)

but instincts tell me that isn’t where my mail problem lies

My MTA is qmail and has been working great for two years. Qmail-smtp
logs don’t turn up any mail being sent to it from rt

Any help

Miles

Miles,

What version of RT are you using?

John

At 03:27 PM 4/3/2003, Miles Scruggs wrote:

I m kinda at a loss for what to do. I have posted to the list twice
now. Haven t heard a peep from anyone. I m not even sure if my posts are
making it to the lists. Anyway I ll have another go at, before a try
another system. Are my posts not clear enough? Or is the problem so
simple/hard that no one bothers?

Miles

have a feeling my post fell between the cracks so I m going to try again.

Miles

For some reason mail is not getting sent out when I update tickets or do
any sort of ticket activity. This isn t just to my mail address but to
all the ones that I put in bcc cc and admincc etc. Here is what I have in
siteconfig

#Sendmail Configuration

Set($MailCommand , ‘sendmailpipe’);

Set($SendmailArguments , “-oi -t”);

Set($SendmailPath , “/var/qmail/bin/sendmail”);

I m not sure what I m missing since the logs show that the mail is being sent

[Wed Apr 2 23:49:09 2003] [info]: RT::Scrip=HASH(0x939a1bc): Couldn’t
prepare Open Tickets (/usr/local/RT/lib/RT/Scrip_Overlay.pm:338)

[Wed Apr 2 23:49:10 2003] [info]:
rt-3.0.0-7-24.16.7961090247589@garnetws.com #7/24 - Scrip
4 (/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:10 2003] [info]:
rt-3.0.0-7-24.16.7961090247589@garnetws.com sent To: Cc: Bcc:
exothermic@softhome.net (/usr/local/RT/lib/RT/Action/SendEmail.pm:205)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.9.25383705275721@garnetws.com #7/24 - Scrip
5 (/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.9.25383705275721@garnetws.com sent To:
miles.scruggs@garnetws.com Cc: exothermic@digitalphotobox.net
Bcc: (/usr/local/RT/lib/RT/Action/SendEmail.pm:205)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.18.4358909494154@garnetws.com #7/24 - Scrip
6 (/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.18.4358909494154@garnetws.com No recipients found. Not
sending. (/usr/local/RT/lib/RT/Action/SendEmail.pm:170)

I m a little disconcerned with that fist line in the log file

[Wed Apr 2 23:49:09 2003] [info]: RT::Scrip=HASH(0x939a1bc): Couldn’t
prepare Open Tickets (/usr/local/RT/lib/RT/Scrip_Overlay.pm:338)

but instincts tell me that isn t where my mail problem lies

My MTA is qmail and has been working great for two years. Qmail-smtp logs
don t turn up any mail being sent to it from rt

Any help

Miles

<>< Proverbs 3:5-6 “Trust in the Lord with all your heart and lean not on
your own understanding;
in all your ways acknowledge him, and he
will make your paths straight.”

3.0.0 witht the lastest versions of pretty much everything else.

Miles

John Gedeon writes:

Yes I have blank Scrips. I’m not sure what you mean by reply. I know
the mailing list is frustrating because it defaults to taking replys off
the list and to an indevidual level which is the dumbest way I have ever
seen a mailing list setup. Usually the reply to address is the same as
the mailing list address not the posters address.

Anyway as far as error handling I don’t see any errors on the side of RT
so I’m suspecting that somehting is getting lost in the MTA (qmail in my
case), but I can’t find any errors over there, and I’m thinking that
qmail is more likely to be report correctly. Thanks for the post your
like the only one that has even looked at it.

Miles

I fixed my problems, which presented in the exact same way as
yours. My
problems were that I was using Sendmailpipe and it had
sendmail defined as
/usr/sbin/sendmail, which isn’t where sendmail lives on Solairs.

As my first post stated. I have mine defined as

Set($SendmailPath , “/var/qmail/bin/sendmail”);

Since I’m using qmail and not sendmail per say. Were you really
getting the same feed back as me? You mean to say that if you have the
wrong path for sendmail RT doesn’t fail in anyway, and shows nothing in
the logs? Hmm interesting.

I guess what I need to know is how can I test “sendmail” like
/var/qmail/bin/sendmail to see if it works?

Note, this wasn’t logged. :frowning:

Sounds like something that needs to go into a bug report.

Anyway, don’t know if this helps you or not.

It’s a start

Thanks for the help
Miles

At 03:55 PM 4/4/2003, Miles Scruggs wrote:

Yes I have blank Scrips.

In RT2 (which I am familiar with) if you have no scrips no emails will go
out of the RT system and no errors will be reported since the scrips define
the actions for rt to take including sending email when someone updates a
ticket. I would check out those and set them before looking into the MTA

Then again I am not familiar with RT 3

John

I’m not sure what you mean by reply. I know
the mailing list is frustrating because it defaults to taking replys off
the list and to an indevidual level which is the dumbest way I have ever
seen a mailing list setup. Usually the reply to address is the same as
the mailing list address not the posters address.
Anyway as far as error handling I don’t see any errors on the side of RT
so I’m suspecting that somehting is getting lost in the MTA (qmail in my
case), but I can’t find any errors over there, and I’m thinking that
qmail is more likely to be report correctly. Thanks for the post your
like the only one that has even looked at it.

Miles

FYI: I’m finally getting around to installing rt 3.0.0 and
have the exact
same problem. I’m still looking into it. I currently suspect it has
something to do with the scrips that its trying to use. I
haven’t messed with
mine so I presume they are blank. Are yours?

This isn’t the first issue I’ve run into with RT’s
pretty-less-than-helpful
error handling. Maybe there is some ‘permission’ that needs
to be granted so
that people can reply to things?

-Jeff

3.0.0 witht the lastest versions of pretty much everything else.

Miles

John Gedeon writes:

Miles,

What version of RT are you using?

John

At 03:27 PM 4/3/2003, Miles Scruggs wrote:

I m kinda at a loss for what to do. I have posted to the list
twice now.
Haven t heard a peep from anyone. I m not even sure if
my posts are

making it to the lists. Anyway I ll have another go at,
before a try

another system. Are my posts not clear enough? Or is
the problem so

simple/hard that no one bothers?

Miles

have a feeling my post fell between the cracks so I m
going to try

again.

Miles

For some reason mail is not getting sent out when I
update tickets

or do
any sort of ticket activity. This isn t just to my mail
address but to

all the ones that I put in bcc cc and admincc etc. Here
is what I have

in siteconfig

#Sendmail Configuration

Set($MailCommand , ‘sendmailpipe’);

Set($SendmailArguments , “-oi -t”);

Set($SendmailPath , “/var/qmail/bin/sendmail”);

I m not sure what I m missing since the logs show that
the mail is

being
sent

[Wed Apr 2 23:49:09 2003] [info]: RT::Scrip=HASH(0x939a1bc):
Couldn’t
prepare Open Tickets (/usr/local/RT/lib/RT/Scrip_Overlay.pm:338)

[Wed Apr 2 23:49:10 2003] [info]:
rt-3.0.0-7-24.16.7961090247589@garnetws.com #7/24 - Scrip 4
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:10 2003] [info]:
rt-3.0.0-7-24.16.7961090247589@garnetws.com sent To:
Cc: Bcc:

exothermic@softhome.net
(/usr/local/RT/lib/RT/Action/SendEmail.pm:205)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.9.25383705275721@garnetws.com #7/24 - Scrip 5
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.9.25383705275721@garnetws.com sent To:
miles.scruggs@garnetws.com Cc:
exothermic@digitalphotobox.net Bcc:

(/usr/local/RT/lib/RT/Action/SendEmail.pm:205)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.18.4358909494154@garnetws.com #7/24 - Scrip 6
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.18.4358909494154@garnetws.com No
recipients found. Not

sending. (/usr/local/RT/lib/RT/Action/SendEmail.pm:170)

I m a little disconcerned with that fist line in the log file

[Wed Apr 2 23:49:09 2003] [info]: RT::Scrip=HASH(0x939a1bc):
Couldn’t
prepare Open Tickets (/usr/local/RT/lib/RT/Scrip_Overlay.pm:338)

but instincts tell me that isn t where my mail problem lies

My MTA is qmail and has been working great for two years.
Qmail-smtp
logs don t turn up any mail being sent to it from rt

Any help

Miles


<>< Proverbs 3:5-6 "Trust in the Lord with all your heart
and lean

not on
your own understanding;
in all your ways
acknowledge him, and he

will make your paths straight."


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm


-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
-=-=-=-=-=-=-=-=-
Jeff Ballard ballard@engr.wisc.edu 608-265-5090
Assistant Director and Unix Systems Manager
Computer-Aided Engineering


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

<>< Proverbs 3:5-6 “Trust in the Lord with all your heart and lean not on
your own understanding;
in all your ways acknowledge him, and he
will make your paths straight.”

John Gedeon said:

At 03:55 PM 4/4/2003, Miles Scruggs wrote:

Yes I have blank Scrips.

Actually I lied, I guess I don’t have blank global scrips. There is a
script and it does send out some mail for every action. (as you can see
from the logs that I posted.) Now I can’t tell for the life of me what is
happening. I’m not getting a whole lot help from the list either.

Miles

In RT2 (which I am familiar with) if you have no scrips no emails will go
out of the RT system and no errors will be reported since the scrips
define
the actions for rt to take including sending email when someone updates a
ticket. I would check out those and set them before looking into the MTA

Then again I am not familiar with RT 3

RT 3 is probaly the same, since scrips are the actions for everything done
is looks like.

John Gedeon said:

At 03:55 PM 4/4/2003, Miles Scruggs wrote:

Yes I have blank Scrips.

Actually I lied, I guess I don’t have blank global scrips. There is a
script and it does send out some mail for every action. (as you can see
from the logs that I posted.) Now I can’t tell for the life of me what
is
happening. I’m not getting a whole lot help from the list either.

Miles

In RT2 (which I am familiar with) if you have no scrips no emails will
go
out of the RT system and no errors will be reported since the scrips
define
the actions for rt to take including sending email when someone
updates a
ticket. I would check out those and set them before looking into the
MTA

Then again I am not familiar with RT 3

RT 3 is probaly the same, since scrips are the actions for everything
done
is looks like.

For some reason mail is not getting sent out when I
update tickets

or do
any sort of ticket activity. This isn t just to my mail
address but to

all the ones that I put in bcc cc and admincc etc. Here
is what I have

in siteconfig

#Sendmail Configuration

Set($MailCommand , ‘sendmailpipe’);

Set($SendmailArguments , “-oi -t”);

Set($SendmailPath , “/var/qmail/bin/sendmail”);

I m not sure what I m missing since the logs show that
the mail is

being
sent

[Wed Apr 2 23:49:09 2003] [info]: RT::Scrip=HASH(0x939a1bc):
Couldn’t
prepare Open Tickets
(/usr/local/RT/lib/RT/Scrip_Overlay.pm:338)

[Wed Apr 2 23:49:10 2003] [info]:
rt-3.0.0-7-24.16.7961090247589@garnetws.com #7/24 - Scrip 4
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:10 2003] [info]:
rt-3.0.0-7-24.16.7961090247589@garnetws.com sent To:
Cc: Bcc:

exothermic@softhome.net
(/usr/local/RT/lib/RT/Action/SendEmail.pm:205)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.9.25383705275721@garnetws.com #7/24 - Scrip 5
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.9.25383705275721@garnetws.com sent To:
miles.scruggs@garnetws.com Cc:
exothermic@digitalphotobox.net Bcc:

(/usr/local/RT/lib/RT/Action/SendEmail.pm:205)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.18.4358909494154@garnetws.com #7/24 - Scrip 6
(/usr/local/RT/lib/RT/Action/SendEmail.pm:91)

[Wed Apr 2 23:49:11 2003] [info]:
rt-3.0.0-7-24.18.4358909494154@garnetws.com No
recipients found. Not

sending. (/usr/local/RT/lib/RT/Action/SendEmail.pm:170)

I m a little disconcerned with that fist line in the log file

[Wed Apr 2 23:49:09 2003] [info]: RT::Scrip=HASH(0x939a1bc):
Couldn’t
prepare Open Tickets
(/usr/local/RT/lib/RT/Scrip_Overlay.pm:338)