Email replies to existing tickets created over email do not add to existing ticket, but create a new

Hi

I have a problem that is driving me nuts, I have just installed the
latest RT, using almost default settings.

When a user writes to requests@myisp.com an ticket gets created and he
gets an email greeting reply where the ticket number is in the subject,
if the user then replies

to this email he gets a new ticket and a new email reply.

The desired result was that if the user replied to a existing ticket,
his reply is added as an comment to the existing ticket.

I have also tried to create an extra email for the comments, called
requests_comment@myisp.com and configured the “Reply Address” and
"Comment Address" but still no success, I get an new ticket every time.

I am using fetchmail

requests@myisp.com

poll 192.11.11.11

protocol pop3

username requests password Bla Bla

mda “/opt/rt3/bin/rt-mailgate --queue General --action correspond --url
http://www.myisp.com/rt/

no keep

poll 192.11.11.11

protocol pop3

username requests_comment password Bla Bla

mda “/opt/rt3/bin/rt-mailgate --queue General --action comment --url
http://www.myisp.com/rt/

no keep

What am I doing wrong.

Best regards

Sune K. Bech

Sune,

Tell the user to NOT use the “Reply All”, but the “Reply” only.
Additionally, if they make sure that the RT email address is a “Bcc” or
"cc" that will keep a new ticket from being created.

Kenn
LBNLOn 11/11/2009 11:00 AM, Sune K. Bech wrote:

Hi

I have a problem that is driving me nuts, I have just installed the
latest RT, using almost default settings.

When a user writes to requests@myisp.com an ticket gets created and he
gets an email greeting reply where the ticket number is in the
subject, if the user then replies

to this email he gets a new ticket and a new email reply.

The desired result was that if the user replied to a existing ticket,
his reply is added as an comment to the existing ticket.

I have also tried to create an extra email for the comments, called
requests_comment@myisp.com mailto:requests_comment@myisp.com and
configured the “Reply Address” and “Comment Address” but still no
success, I get an new ticket every time.

I am using fetchmail

requests@myisp.com

poll 192.11.11.11

protocol pop3

username requests password Bla Bla

mda “/opt/rt3/bin/rt-mailgate --queue General --action correspond
–url http://www.myisp.com/rt/

no keep

poll 192.11.11.11

protocol pop3

username requests_comment password Bla Bla

mda “/opt/rt3/bin/rt-mailgate --queue General --action comment --url
http://www.myisp.com/rt/

no keep

What am I doing wrong.

Best regards

Sune K. Bech



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

The only thing I can think of is that your RT name isn’t the same in the
subject line… so it thinks the [rtname #rtnumber] isn’t anything
related to RT.

Does the new ticket have a subject line that has the tag of the old
ticket in it?

By tag I mean the [rtname #rtnumber] in the subject line? or does RT
strip that out?

Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: 807.766.7331
Email: mike.johnson@normed.ca
Technology assistance: email nosmhelpdesk@normed.ca
Technology Emergency Contact (TEC) Mon-Fri, 8am to 5pm excluding stat
holidays:
Off campus toll free 1-800-461-8777, option 8, or locally either
(705)-662-7120 or (807)-766-7500

“Sune K. Bech” skbech@bio.ku.dk 11/11/2009 2:00 pm >>>

Hi

I have a problem that is driving me nuts, I have just installed the
latest RT, using almost default settings.

When a user writes to requests@myisp.com an ticket gets created and he
gets an email greeting reply where the ticket number is in the subject,
if the user then replies
to this email he gets a new ticket and a new email reply.

The desired result was that if the user replied to a existing ticket,
his reply is added as an comment to the existing ticket.

I have also tried to create an extra email for the comments, called
requests_comment@myisp.com and configured the “Reply Address” and
“Comment Address” but still no success, I get an new ticket every
time.

I am using fetchmail

requests@myisp.com

poll 192.11.11.11
protocol pop3
username requests password Bla Bla
mda "/opt/rt3/bin/rt-mailgate --queue General --action correspond --url
http://www.myisp.com/rt/"
no keep

poll 192.11.11.11
protocol pop3
username requests_comment password Bla Bla
mda "/opt/rt3/bin/rt-mailgate --queue General --action comment --url
http://www.myisp.com/rt/"
no keep

What am I doing wrong.

Best regards

Sune K. Bech