Email from Web interface?

Hi,

I’m using rt2 2.0.6 and I’m having trouble replying to tickets from
the Web interface. I’m pretty sure that the scrips are set
correctly and email submitted to rt does get in the queueing system
just fine. I tried checking the rt log but it is zero bytes. How can
I increase the debug level to get more output in the log file?

Thanks,

  • Daniel

Daniel Blakeley (N2YEN) Cornell Center for Materials Research
daniel@ccmr.cornell.edu E20 Clark Hall

I’m also having this same issue. RT will except mail from the mailgate and
also send out the autoreply but if you try to reply to the ticket RT comes
back with mail sent but it never goes out? I have tried tweeking the
config.pm and also checked the privs on /usr/sbin/sendmail.

Has anyone else seen this? fixed it?? Any ideas would be great.

Greg
Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729----- Original Message -----
From: “Daniel Blakeley” daniel@ccmr.cornell.edu
To: rt-users@lists.fsck.com
Sent: Friday, September 07, 2001 12:59 PM
Subject: [rt-users] Email from Web interface?

Hi,

I’m using rt2 2.0.6 and I’m having trouble replying to tickets from
the Web interface. I’m pretty sure that the scrips are set
correctly and email submitted to rt does get in the queueing system
just fine. I tried checking the rt log but it is zero bytes. How can
I increase the debug level to get more output in the log file?

Thanks,

  • Daniel


Daniel Blakeley (N2YEN) Cornell Center for Materials Research
daniel@ccmr.cornell.edu E20 Clark Hall


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

What $MailCommand are you using? If you’re using ‘sendmail’, try ‘sendmailpipe’
. If you’re using ‘sendmailpipe’, try ‘sendmail’.

-jOn Fri, Sep 07, 2001 at 02:21:08PM -0700, Greg Dickerson wrote:

I’m also having this same issue. RT will except mail from the mailgate and
also send out the autoreply but if you try to reply to the ticket RT comes
back with mail sent but it never goes out? I have tried tweeking the
config.pm and also checked the privs on /usr/sbin/sendmail.

Has anyone else seen this? fixed it?? Any ideas would be great.

Greg

Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729

----- Original Message -----
From: “Daniel Blakeley” daniel@ccmr.cornell.edu
To: rt-users@lists.fsck.com
Sent: Friday, September 07, 2001 12:59 PM
Subject: [rt-users] Email from Web interface?

Hi,

I’m using rt2 2.0.6 and I’m having trouble replying to tickets from
the Web interface. I’m pretty sure that the scrips are set
correctly and email submitted to rt does get in the queueing system
just fine. I tried checking the rt log but it is zero bytes. How can
I increase the debug level to get more output in the log file?

Thanks,

  • Daniel


Daniel Blakeley (N2YEN) Cornell Center for Materials Research
daniel@ccmr.cornell.edu E20 Clark Hall


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

I’ve tried both ways in all possible combinations. The replied ticket never
makes it to the maillog. I’ve testes other scripts that shell out to
sendmail and they all make it out as well as into the maillog. I know were
NOT running the latest release so if there was an older bug maybe were
seeing it? I think were on RT 2.0 first release.

Greg
Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729From: “Jesse Vincent” jesse@bestpractical.com
To: “Greg Dickerson” greg@oreilly.com
Cc: “Daniel Blakeley” daniel@ccmr.cornell.edu; rt-users@lists.fsck.com
Sent: Friday, September 07, 2001 3:53 PM
Subject: Re: [rt-users] Email from Web interface?

What $MailCommand are you using? If you’re using ‘sendmail’, try
’sendmailpipe’
. If you’re using ‘sendmailpipe’, try ‘sendmail’.

-j

I’m also having this same issue. RT will except mail from the mailgate
and

also send out the autoreply but if you try to reply to the ticket RT
comes

back with mail sent but it never goes out? I have tried tweeking the
config.pm and also checked the privs on /usr/sbin/sendmail.

Has anyone else seen this? fixed it?? Any ideas would be great.

Greg

Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729

----- Original Message -----
From: “Daniel Blakeley” daniel@ccmr.cornell.edu
To: rt-users@lists.fsck.com
Sent: Friday, September 07, 2001 12:59 PM
Subject: [rt-users] Email from Web interface?

Hi,

I’m using rt2 2.0.6 and I’m having trouble replying to tickets from
the Web interface. I’m pretty sure that the scrips are set
correctly and email submitted to rt does get in the queueing system
just fine. I tried checking the rt log but it is zero bytes. How can
I increase the debug level to get more output in the log file?

Thanks,

  • Daniel


Daniel Blakeley (N2YEN) Cornell Center for Materials Research
daniel@ccmr.cornell.edu E20 Clark Hall


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

There have definitely been fixes to mail sending within the 2.0.x series,
as well as other important bugfix, usability and performance improvements.
If this is still an issue with 2.0.6, we can delve deeper.

-jOn Fri, Sep 07, 2001 at 04:43:53PM -0700, Greg Dickerson wrote:

I’ve tried both ways in all possible combinations. The replied ticket never
makes it to the maillog. I’ve testes other scripts that shell out to
sendmail and they all make it out as well as into the maillog. I know were
NOT running the latest release so if there was an older bug maybe were
seeing it? I think were on RT 2.0 first release.

Greg

Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729

----- Original Message -----
From: “Jesse Vincent” jesse@bestpractical.com
To: “Greg Dickerson” greg@oreilly.com
Cc: “Daniel Blakeley” daniel@ccmr.cornell.edu; rt-users@lists.fsck.com
Sent: Friday, September 07, 2001 3:53 PM
Subject: Re: [rt-users] Email from Web interface?

What $MailCommand are you using? If you’re using ‘sendmail’, try
’sendmailpipe’
. If you’re using ‘sendmailpipe’, try ‘sendmail’.

-j

On Fri, Sep 07, 2001 at 02:21:08PM -0700, Greg Dickerson wrote:

I’m also having this same issue. RT will except mail from the mailgate
and

also send out the autoreply but if you try to reply to the ticket RT
comes

back with mail sent but it never goes out? I have tried tweeking the
config.pm and also checked the privs on /usr/sbin/sendmail.

Has anyone else seen this? fixed it?? Any ideas would be great.

Greg

Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729

----- Original Message -----
From: “Daniel Blakeley” daniel@ccmr.cornell.edu
To: rt-users@lists.fsck.com
Sent: Friday, September 07, 2001 12:59 PM
Subject: [rt-users] Email from Web interface?

Hi,

I’m using rt2 2.0.6 and I’m having trouble replying to tickets from
the Web interface. I’m pretty sure that the scrips are set
correctly and email submitted to rt does get in the queueing system
just fine. I tried checking the rt log but it is zero bytes. How can
I increase the debug level to get more output in the log file?

Thanks,

  • Daniel


Daniel Blakeley (N2YEN) Cornell Center for Materials Research
daniel@ccmr.cornell.edu E20 Clark Hall


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

Greg Dickerson wrote:

I’ve tried both ways in all possible combinations. The replied ticket never
makes it to the maillog. I’ve testes other scripts that shell out to
sendmail and they all make it out as well as into the maillog. I know were
NOT running the latest release so if there was an older bug maybe were
seeing it? I think were on RT 2.0 first release.

Sanity check: The user making the “reply” is not the requestor, correct?

True. I will upgrade before taking this further. And yes the requester was
different than the sender.

Greg
Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729From: “Phil Homewood” pdh@lineo.com
To: “Greg Dickerson” greg@oreilly.com
Cc: rt-users@lists.fsck.com
Sent: Friday, September 07, 2001 9:15 PM
Subject: Re: [rt-users] Email from Web interface?

Greg Dickerson wrote:

I’ve tried both ways in all possible combinations. The replied ticket
never

makes it to the maillog. I’ve testes other scripts that shell out to
sendmail and they all make it out as well as into the maillog. I know
were

NOT running the latest release so if there was an older bug maybe were
seeing it? I think were on RT 2.0 first release.

Sanity check: The user making the “reply” is not the requestor, correct?

I’m using 2.0.6 and having this same problem, I tried both sendmailpipe and
sendmail. Any suggestions?

darren

Jesse Vincent is quoted as saying:

Okay, I’m an idiot. I needed to create more scrips, specifically a global
scrip to handle correspondence. RTFM!

darren

Darren Grabowski is quoted as saying:

I’m using 2.0.6 and having this same problem, I tried both sendmailpipe and
sendmail. Any suggestions?

darren

Jesse Vincent is quoted as saying:

There have definitely been fixes to mail sending within the 2.0.x series,
as well as other important bugfix, usability and performance improvements.
If this is still an issue with 2.0.6, we can delve deeper.

-j

I’ve tried both ways in all possible combinations. The replied ticket never
makes it to the maillog. I’ve testes other scripts that shell out to
sendmail and they all make it out as well as into the maillog. I know were
NOT running the latest release so if there was an older bug maybe were
seeing it? I think were on RT 2.0 first release.

Greg

Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729

----- Original Message -----
From: “Jesse Vincent” jesse@bestpractical.com
To: “Greg Dickerson” greg@oreilly.com
Cc: “Daniel Blakeley” daniel@ccmr.cornell.edu; rt-users@lists.fsck.com
Sent: Friday, September 07, 2001 3:53 PM
Subject: Re: [rt-users] Email from Web interface?

What $MailCommand are you using? If you’re using ‘sendmail’, try
’sendmailpipe’
. If you’re using ‘sendmailpipe’, try ‘sendmail’.

-j

I’m also having this same issue. RT will except mail from the mailgate
and

also send out the autoreply but if you try to reply to the ticket RT
comes

back with mail sent but it never goes out? I have tried tweeking the
config.pm and also checked the privs on /usr/sbin/sendmail.

Has anyone else seen this? fixed it?? Any ideas would be great.

Greg

Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729

----- Original Message -----
From: “Daniel Blakeley” daniel@ccmr.cornell.edu
To: rt-users@lists.fsck.com
Sent: Friday, September 07, 2001 12:59 PM
Subject: [rt-users] Email from Web interface?

Hi,

I’m using rt2 2.0.6 and I’m having trouble replying to tickets from
the Web interface. I’m pretty sure that the scrips are set
correctly and email submitted to rt does get in the queueing system
just fine. I tried checking the rt log but it is zero bytes. How can
I increase the debug level to get more output in the log file?

Thanks,

  • Daniel


Daniel Blakeley (N2YEN) Cornell Center for Materials Research
daniel@ccmr.cornell.edu E20 Clark Hall


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Darren Grabowski drg@verio.net
Team Lead - Verio Security http://www.verio.net
office: 214.290.8680 fax: 214.800.7771
"Carpe Diem Baby" - J. Hetfield

So am I that was my issue also…

Greg
Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729From: “Darren Grabowski” drg@verio.net
To: rt-users@lists.fsck.com
Sent: Monday, September 10, 2001 9:22 AM
Subject: Re: [rt-users] Email from Web interface?

Okay, I’m an idiot. I needed to create more scrips, specifically a global
scrip to handle correspondence. RTFM!

darren

Darren Grabowski is quoted as saying:

I’m using 2.0.6 and having this same problem, I tried both sendmailpipe
and

sendmail. Any suggestions?

darren

Jesse Vincent is quoted as saying:

There have definitely been fixes to mail sending within the 2.0.x
series,

as well as other important bugfix, usability and performance
improvements.

If this is still an issue with 2.0.6, we can delve deeper.

-j

I’ve tried both ways in all possible combinations. The replied
ticket never

makes it to the maillog. I’ve testes other scripts that shell out to
sendmail and they all make it out as well as into the maillog. I
know were

NOT running the latest release so if there was an older bug maybe
were

seeing it? I think were on RT 2.0 first release.

Greg

Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729

----- Original Message -----
From: “Jesse Vincent” jesse@bestpractical.com
To: “Greg Dickerson” greg@oreilly.com
Cc: “Daniel Blakeley” daniel@ccmr.cornell.edu;
rt-users@lists.fsck.com

Sent: Friday, September 07, 2001 3:53 PM
Subject: Re: [rt-users] Email from Web interface?

What $MailCommand are you using? If you’re using ‘sendmail’, try
’sendmailpipe’
. If you’re using ‘sendmailpipe’, try ‘sendmail’.

-j

I’m also having this same issue. RT will except mail from the
mailgate

and

also send out the autoreply but if you try to reply to the
ticket RT

comes

back with mail sent but it never goes out? I have tried tweeking
the

config.pm and also checked the privs on /usr/sbin/sendmail.

Has anyone else seen this? fixed it?? Any ideas would be great.

Greg

Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729

----- Original Message -----
From: “Daniel Blakeley” daniel@ccmr.cornell.edu
To: rt-users@lists.fsck.com
Sent: Friday, September 07, 2001 12:59 PM
Subject: [rt-users] Email from Web interface?

Hi,

I’m using rt2 2.0.6 and I’m having trouble replying to tickets
from

the Web interface. I’m pretty sure that the scrips are set
correctly and email submitted to rt does get in the queueing
system

just fine. I tried checking the rt log but it is zero bytes.
How can

I increase the debug level to get more output in the log file?

Thanks,

  • Daniel


Daniel Blakeley (N2YEN) Cornell Center for Materials
Research

daniel@ccmr.cornell.edu E20 Clark Hall


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


http://www.bestpractical.com/products/rt – Trouble Ticketing.
Free.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


Darren Grabowski drg@verio.net
Team Lead - Verio Security http://www.verio.net
office: 214.290.8680 fax: 214.800.7771
"Carpe Diem Baby" - J. Hetfield


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Are these tickets created by the same user as the owner?

What we’ve seen is the folowing:

1> Send a message to the queue.
2> The same person who requests, becomes the owner.
3> When this person puts a reply on the ticket, from within the web ui,
it’s recorded on the ticket, but no email goes out to that person (the
requestor).
4> If another user puts a reply on the ticket, the requestor DOES get an email.

At 06:53 PM 9/7/2001 -0400, Jesse Vincent wrote:

What $MailCommand are you using? If you’re using ‘sendmail’, try
’sendmailpipe’
. If you’re using ‘sendmailpipe’, try ‘sendmail’.

    -j

I’m also having this same issue. RT will except mail from the mailgate and
also send out the autoreply but if you try to reply to the ticket RT comes
back with mail sent but it never goes out? I have tried tweeking the
config.pm and also checked the privs on /usr/sbin/sendmail.

Has anyone else seen this? fixed it?? Any ideas would be great.

Greg

Greg Dickerson
Support Manager
O’Reilly & Associates, Inc.
101 Morris Street, Sebastopol, CA 95472
Phone (707) 829-0515 ext 729

----- Original Message -----
From: “Daniel Blakeley” daniel@ccmr.cornell.edu
To: rt-users@lists.fsck.com
Sent: Friday, September 07, 2001 12:59 PM
Subject: [rt-users] Email from Web interface?

Hi,

I’m using rt2 2.0.6 and I’m having trouble replying to tickets from
the Web interface. I’m pretty sure that the scrips are set
correctly and email submitted to rt does get in the queueing system
just fine. I tried checking the rt log but it is zero bytes. How can
I increase the debug level to get more output in the log file?

Thanks,

  • Daniel


Daniel Blakeley (N2YEN) Cornell Center for Materials Research
daniel@ccmr.cornell.edu E20 Clark Hall


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Russ Johnson
Stargate Online

http://www.dimstar.net
telnet://telnet.dimstar.net
ICQ: 3739685

Russ Johnson wrote:

1> Send a message to the queue.
2> The same person who requests, becomes the owner.
3> When this person puts a reply on the ticket, from within the web ui,
it’s recorded on the ticket, but no email goes out to that person (the
requestor).
4> If another user puts a reply on the ticket, the requestor DOES get an email.

http://www.helgrim.com/rtdocs/faq.html#65

What you are seeing is correct behaviour.

I think I know that one…

RT is very smart, it knows who is logged on the web and what is email is.
When an action implies sending a mail, and the mail address is the same as
the address for the logged person, it does not sent the mail probably
because you are supposed to know what you are doing, son you don’t need a
copy)

It makes testing a bit difficult, you have to define 2 different addresses
for yourself, one associated with your login, and one to send the mail to.

This is only guesses from my own experience facing the same behaviour.

Blaise

-----Message d’origine-----De : Phil Homewood [mailto:pdh@moreton.com.au]
Envoyé : mardi 11 septembre 2001 00:02
À : Russ Johnson
Cc : rt-users@lists.fsck.com
Objet : Re: [rt-users] Email from Web interface?

Russ Johnson wrote:

1> Send a message to the queue.
2> The same person who requests, becomes the owner.
3> When this person puts a reply on the ticket, from within the web ui,
it’s recorded on the ticket, but no email goes out to that person (the
requestor).
4> If another user puts a reply on the ticket, the requestor DOES get an
email.

http://www.helgrim.com/rtdocs/faq.html#65

What you are seeing is correct behaviour.

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users