Desperately ned Oracle help

Hey everyone!
As ive already mentioned - i’m being forced to use Oracle for my RT 3.6.3
instance.
Well, today i finally got an Oracle 10g instance up and loaded the
schema.Oracle file into it.
Did the ./configure for RT(./configure --prefix=/usr/local/rt3_ora
–with-db-type=Oracle --with-db-host=clorad1.example.com --with-db-port=1521
–with-db-rt-host=localhost --with-db-dba=rtusr --with-db-database=clorad1
–with-db-rt-user=rtusr --with-db-rt-pass=***** )

Everything was ok.

While doing make initialize-database i got this error: Unable to load
DBIx::SearchBuilder database handle for ‘Oracle’.

Realized that i don’t have DBD::Oracle installed, so i downloaded that from
CPAN and installed that.
There were errors during the install and i found a workaround to delete
-xarch=v9 from the Makefile. After that install finished.

Then i followed the Wiki and commented out the insert_schema() method call.

But i’m still getting errors trying to init the DB.

Test suggested by the Wiki (TWO_TASK=FOO perl -MDBI -le
’DBI->connect(“DBI:Oracle:”, “rt3”, “rt3”)’) seems to be successful. Or at
least it doesn’t give any errors.

This is the error i get while doing make initialize-database :

DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627
DBI connect(‘CLORAD1;port=1521’,‘rtusr’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME SERVER
SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 103
Failed to connect to dbi:Oracle:CLORAD1;port=1521 as rtusr: Can’t connect
using this syntax without specifying a HOST and one of SID INSTANCE_NAME
SERVER SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 103,
line 1.
make: *** [initialize-database] Error 255

PLEASE HELP !!!

Thanks in advance,
Sal.

Sal- It has to do with Apache and your CGI handler not knowing the
oracle parameters. We use Fast CGI on Redhat connecting to a remote
Oracle servers. I had to add the following lines to my httpd.conf file:

RT STUFF FOR APACHE

SetEnv LD_LIBRARY_PATH /u01/app/oracle/product/10.2.0/client_1/lib

SetEnv ORACLE_HOME /u01/app/oracle/product/10.2.0/client_1

SetEnv ORACLE_SID rt

SetEnv TWO_TASK rt

(change above variables to your implementation)

In Httpd conf I also had to change the initialization string for
Fastcgi, this is the line in my config.

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
-processes 4 -initial-env
LD_LIBRARY_PATH=/u01/app/oracle/product/10.2.0/client_1/lib -initial-env
ORACLE_HOME=/u01/app/oracle/product/10.2.0/client1 -initial-env
ORACLE_SID=rt -initial-env TWO_TASK=rt

Some of this might be a bit excessive but I was trying everything and
spent a ton of time on the fastcgi and apache websites trying to figure
this out. Once this was all completed I was successful in getting DBI
Searchbuilder working. This took about a 12 hours of research and trial
and error on my part, and I’ve meant to go back and put this information
in the wiki but haven’t had a chance.

Justin BrodleyFrom: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of
Baytalskiy, Sal
Sent: Wednesday, May 16, 2007 9:49 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Desperately ned Oracle help

Hey everyone!

As ive already mentioned - i’m being forced to use Oracle for my RT
3.6.3 instance.

Well, today i finally got an Oracle 10g instance up and loaded the
schema.Oracle file into it.

Did the ./configure for RT(./configure --prefix=/usr/local/rt3_ora
–with-db-type=Oracle --with-db-host=clorad1.example.com
–with-db-port=1521 --with-db-rt-host=localhost --with-db-dba=rtusr
–with-db-database=clorad1 --with-db-rt-user=rtusr
–with-db-rt-pass=***** )

Everything was ok.

While doing make initialize-database i got this error: Unable to load
DBIx::SearchBuilder database handle for ‘Oracle’.

Realized that i don’t have DBD::Oracle installed, so i downloaded that
from CPAN and installed that.

There were errors during the install and i found a workaround to delete
-xarch=v9 from the Makefile. After that install finished.

Then i followed the Wiki and commented out the insert_schema() method
call.

But i’m still getting errors trying to init the DB.

Test suggested by the Wiki (TWO_TASK=FOO perl -MDBI -le
’DBI->connect(“DBI:Oracle:”, “rt3”, “rt3”)’) seems to be successful. Or
at least it doesn’t give any errors.

This is the error i get while doing make initialize-database :

DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627
DBI connect(‘CLORAD1;port=1521’,‘rtusr’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME
SERVER SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line
103
Failed to connect to dbi:Oracle:CLORAD1;port=1521 as rtusr: Can’t
connect using this syntax without specifying a HOST and one of SID
INSTANCE_NAME SERVER SERVICE_NAME at
//usr/local/rt3_ora/sbin/rt-setup-database line 103, line 1.
make: *** [initialize-database] Error 255

PLEASE HELP !!!

Thanks in advance,

Sal.

Thanks a lot, Justin!!!
This is very valuable info!

However, i’m not at that step yet. I’ve just built RT with Oracle support
and was trying to run 'make initialize-database’
I’ve commented out the ‘insert_schema()’ method call, cause schema is
already in place.
I was expecting the thing to insert the initial RT data into the DB. But
that’s where it was failing.

Do you think i should set the variable you mentioned in the shell and try
running it again?From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Justin
Brodley
Sent: Thursday, May 17, 2007 1:20 PM
To: Baytalskiy, Sal; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

Sal- It has to do with Apache and your CGI handler not knowing the oracle
parameters. We use Fast CGI on Redhat connecting to a remote Oracle servers.
I had to add the following lines to my httpd.conf file:

RT STUFF FOR APACHE

SetEnv LD_LIBRARY_PATH /u01/app/oracle/product/10.2.0/client_1/lib

SetEnv ORACLE_HOME /u01/app/oracle/product/10.2.0/client_1

SetEnv ORACLE_SID rt

SetEnv TWO_TASK rt

(change above variables to your implementation)

In Httpd conf I also had to change the initialization string for Fastcgi,
this is the line in my config.

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 -processes 4
-initial-env LD_LIBRARY_PATH=/u01/app/oracle/product/10.2.0/client_1/lib
-initial-env ORACLE_HOME=/u01/app/oracle/product/10.2.0/client1 -initial-env
ORACLE_SID=rt -initial-env TWO_TASK=rt

Some of this might be a bit excessive but I was trying everything and spent
a ton of time on the fastcgi and apache websites trying to figure this out.
Once this was all completed I was successful in getting DBI Searchbuilder
working. This took about a 12 hours of research and trial and error on my
part, and I’ve meant to go back and put this information in the wiki but
haven’t had a chance.

Justin Brodley

From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Baytalskiy,
Sal
Sent: Wednesday, May 16, 2007 9:49 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Desperately ned Oracle help

Hey everyone!

As ive already mentioned - i’m being forced to use Oracle for my RT 3.6.3
instance.

Well, today i finally got an Oracle 10g instance up and loaded the
schema.Oracle file into it.

Did the ./configure for RT(./configure --prefix=/usr/local/rt3_ora
–with-db-type=Oracle --with-db-host=clorad1.example.com --with-db-port=1521
–with-db-rt-host=localhost --with-db-dba=rtusr --with-db-database=clorad1
–with-db-rt-user=rtusr --with-db-rt-pass=***** )

Everything was ok.

While doing make initialize-database i got this error: Unable to load
DBIx::SearchBuilder database handle for ‘Oracle’.

Realized that i don’t have DBD::Oracle installed, so i downloaded that from
CPAN and installed that.

There were errors during the install and i found a workaround to delete
-xarch=v9 from the Makefile. After that install finished.

Then i followed the Wiki and commented out the insert_schema() method call.

But i’m still getting errors trying to init the DB.

Test suggested by the Wiki (TWO_TASK=FOO perl -MDBI -le
’DBI->connect(“DBI:Oracle:”, “rt3”, “rt3”)’) seems to be successful. Or at
least it doesn’t give any errors.

This is the error i get while doing make initialize-database :

DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627
DBI connect(‘CLORAD1;port=1521’,‘rtusr’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME SERVER
SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 103
Failed to connect to dbi:Oracle:CLORAD1;port=1521 as rtusr: Can’t connect
using this syntax without specifying a HOST and one of SID INSTANCE_NAME
SERVER SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 103,
line 1.
make: *** [initialize-database] Error 255

PLEASE HELP !!!

Thanks in advance,

Sal.

I would make sure the variable is set everywhere, the initial data is
imported with the schema, that you commented out. Out of curiosity why
are you commenting out the “schema” the only reason you would do this is
if the database was already created with all the appropriate tables. Our
oracle guys just setup the RT user as per the oracle readme and then we
just ran initialize-database and it created the rest.

Justin BrodleyFrom: Baytalskiy, Sal [mailto:Sal.Baytalskiy@AIG.com]
Sent: Thursday, May 17, 2007 10:34 AM
To: Justin Brodley; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

Thanks a lot, Justin!!!

This is very valuable info!

However, i’m not at that step yet. I’ve just built RT with Oracle
support and was trying to run ‘make initialize-database’

I’ve commented out the ‘insert_schema()’ method call, cause schema is
already in place.

I was expecting the thing to insert the initial RT data into the DB. But
that’s where it was failing.

Do you think i should set the variable you mentioned in the shell and
try running it again?

From: rt-users-bounces@lists.bestpractical.com

[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Justin
Brodley
Sent: Thursday, May 17, 2007 1:20 PM
To: Baytalskiy, Sal; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

Sal- It has to do with Apache and your CGI handler not knowing

the oracle parameters. We use Fast CGI on Redhat connecting to a remote
Oracle servers. I had to add the following lines to my httpd.conf file:

# RT STUFF FOR APACHE

SetEnv LD_LIBRARY_PATH

/u01/app/oracle/product/10.2.0/client_1/lib

SetEnv ORACLE_HOME /u01/app/oracle/product/10.2.0/client_1

SetEnv ORACLE_SID rt

SetEnv TWO_TASK rt

(change above variables to your implementation)

 

In Httpd conf I also had to change the initialization string for

Fastcgi, this is the line in my config.

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120

-processes 4 -initial-env
LD_LIBRARY_PATH=/u01/app/oracle/product/10.2.0/client_1/lib -initial-env
ORACLE_HOME=/u01/app/oracle/product/10.2.0/client1 -initial-env
ORACLE_SID=rt -initial-env TWO_TASK=rt

Some of this might be a bit excessive but I was trying

everything and spent a ton of time on the fastcgi and apache websites
trying to figure this out. Once this was all completed I was successful
in getting DBI Searchbuilder working. This took about a 12 hours of
research and trial and error on my part, and I’ve meant to go back and
put this information in the wiki but haven’t had a chance.

 Justin Brodley

From: rt-users-bounces@lists.bestpractical.com

[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of
Baytalskiy, Sal
Sent: Wednesday, May 16, 2007 9:49 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Desperately ned Oracle help

Hey everyone!

As ive already mentioned - i'm being forced to use Oracle for my

RT 3.6.3 instance.

Well, today i finally got an Oracle 10g instance up and loaded

the schema.Oracle file into it.

Did the ./configure for RT(./configure

–prefix=/usr/local/rt3_ora --with-db-type=Oracle
–with-db-host=clorad1.example.com --with-db-port=1521
–with-db-rt-host=localhost --with-db-dba=rtusr
–with-db-database=clorad1 --with-db-rt-user=rtusr
–with-db-rt-pass=***** )

Everything was ok.

 

While doing make initialize-database i got this error: Unable to

load DBIx::SearchBuilder database handle for ‘Oracle’.

Realized that i don't have DBD::Oracle installed, so i

downloaded that from CPAN and installed that.

There were errors during the install and i found a workaround to

delete -xarch=v9 from the Makefile. After that install finished.

Then i followed the Wiki and commented out the insert_schema()

method call.

But i'm still getting errors trying to init the DB.

 

 

Test suggested by the Wiki (TWO_TASK=FOO perl -MDBI -le

‘DBI->connect(“DBI:Oracle:”, “rt3”, “rt3”)’) seems to be successful. Or
at least it doesn’t give any errors.

This is the error i get while doing make initialize-database :

 

DSN component 'CLORAD1' is not in 'name=value' format at

/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627
DBI connect(‘CLORAD1;port=1521’,‘rtusr’,…) failed: Can’t
connect using this syntax without specifying a HOST and one of SID
INSTANCE_NAME SERVER SERVICE_NAME at
//usr/local/rt3_ora/sbin/rt-setup-database line 103
Failed to connect to dbi:Oracle:CLORAD1;port=1521 as rtusr:
Can’t connect using this syntax without specifying a HOST and one of SID
INSTANCE_NAME SERVER SERVICE_NAME at
//usr/local/rt3_ora/sbin/rt-setup-database line 103, line 1.
make: *** [initialize-database] Error 255

PLEASE HELP !!!

 

Thanks in advance,

Sal.

The Oracle readme said that the DB needs to be prepared.
So i ran the schema.Oracle file via the SQLPlus and it inserted all the
tables and indexes.
So i now have the database setup, just empty. No data.
Then, while running the ‘make initialize-database’ there’s a step in that
script to insert the schema. Since i already did that - i commented it out,
just like the Wiki suggests.
So that step should be skipped and it should just try to insert the required
data into the DB.
And that’s where i’m stuck at this point.

After some googling i found that i might have a problem with the
DBD::Oracle. Apparently it tried installing that module as a 64-bit.
But my Perl is 32-bit. This seems to be a common occurence.

Here’s what i’m getting when trying to run ‘make initialize-database’ :

/usr/bin/perl //usr/local/rt3_ora/sbin/rt-setup-database --action init --dba
mwpoc --prompt-for-dba-password
Unquoted string “error” may clash with future reserved word at
/usr/local/rt3_ora/etc/RT_SiteConfig.pm line 286.
In order to create or update your RT database,this script needs to connect
to your Oracle instance on clorad1.aig.com as mwpoc.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:
DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627
DBI connect(‘CLORAD1;port=1521’,‘mwpoc’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME SERVER
SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 103
Failed to connect to dbi:Oracle:CLORAD1;port=1521 as mwpoc: Can’t connect
using this syntax without specifying a HOST and one of SID INSTANCE_NAME
SERVER SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 103,
line 1.
make: *** [initialize-database] Error 255

The hostname where oracle Db is running is clorad1.aig.com. Instance/Service
name is CLORAD1.From: Justin Brodley [mailto:jbrodley@sumtotalsystems.com]
Sent: Thursday, May 17, 2007 1:40 PM
To: Baytalskiy, Sal; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

I would make sure the variable is set everywhere, the initial data is
imported with the schema, that you commented out. Out of curiosity why are
you commenting out the “schema” the only reason you would do this is if the
database was already created with all the appropriate tables. Our oracle
guys just setup the RT user as per the oracle readme and then we just ran
initialize-database and it created the rest.

Justin Brodley

From: Baytalskiy, Sal [mailto:Sal.Baytalskiy@AIG.com]
Sent: Thursday, May 17, 2007 10:34 AM
To: Justin Brodley; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

Thanks a lot, Justin!!!

This is very valuable info!

However, i’m not at that step yet. I’ve just built RT with Oracle support
and was trying to run ‘make initialize-database’

I’ve commented out the ‘insert_schema()’ method call, cause schema is
already in place.

I was expecting the thing to insert the initial RT data into the DB. But
that’s where it was failing.

Do you think i should set the variable you mentioned in the shell and try
running it again?

From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Justin
Brodley
Sent: Thursday, May 17, 2007 1:20 PM
To: Baytalskiy, Sal; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

Sal- It has to do with Apache and your CGI handler not knowing the oracle
parameters. We use Fast CGI on Redhat connecting to a remote Oracle servers.
I had to add the following lines to my httpd.conf file:

RT STUFF FOR APACHE

SetEnv LD_LIBRARY_PATH /u01/app/oracle/product/10.2.0/client_1/lib

SetEnv ORACLE_HOME /u01/app/oracle/product/10.2.0/client_1

SetEnv ORACLE_SID rt

SetEnv TWO_TASK rt

(change above variables to your implementation)

In Httpd conf I also had to change the initialization string for Fastcgi,
this is the line in my config.

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 -processes 4
-initial-env LD_LIBRARY_PATH=/u01/app/oracle/product/10.2.0/client_1/lib
-initial-env ORACLE_HOME=/u01/app/oracle/product/10.2.0/client1 -initial-env
ORACLE_SID=rt -initial-env TWO_TASK=rt

Some of this might be a bit excessive but I was trying everything and spent
a ton of time on the fastcgi and apache websites trying to figure this out.
Once this was all completed I was successful in getting DBI Searchbuilder
working. This took about a 12 hours of research and trial and error on my
part, and I’ve meant to go back and put this information in the wiki but
haven’t had a chance.

Justin Brodley

From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Baytalskiy,
Sal
Sent: Wednesday, May 16, 2007 9:49 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Desperately ned Oracle help

Hey everyone!

As ive already mentioned - i’m being forced to use Oracle for my RT 3.6.3
instance.

Well, today i finally got an Oracle 10g instance up and loaded the
schema.Oracle file into it.

Did the ./configure for RT(./configure --prefix=/usr/local/rt3_ora
–with-db-type=Oracle --with-db-host=clorad1.example.com --with-db-port=1521
–with-db-rt-host=localhost --with-db-dba=rtusr --with-db-database=clorad1
–with-db-rt-user=rtusr --with-db-rt-pass=***** )

Everything was ok.

While doing make initialize-database i got this error: Unable to load
DBIx::SearchBuilder database handle for ‘Oracle’.

Realized that i don’t have DBD::Oracle installed, so i downloaded that from
CPAN and installed that.

There were errors during the install and i found a workaround to delete
-xarch=v9 from the Makefile. After that install finished.

Then i followed the Wiki and commented out the insert_schema() method call.

But i’m still getting errors trying to init the DB.

Test suggested by the Wiki (TWO_TASK=FOO perl -MDBI -le
’DBI->connect(“DBI:Oracle:”, “rt3”, “rt3”)’) seems to be successful. Or at
least it doesn’t give any errors.

This is the error i get while doing make initialize-database :

DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627
DBI connect(‘CLORAD1;port=1521’,‘rtusr’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME SERVER
SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 103
Failed to connect to dbi:Oracle:CLORAD1;port=1521 as rtusr: Can’t connect
using this syntax without specifying a HOST and one of SID INSTANCE_NAME
SERVER SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 103,
line 1.
make: *** [initialize-database] Error 255

PLEASE HELP !!!

Thanks in advance,

Sal.

Hmm, not sure at this point. Someone else who is more familiar with the
initialize-database part of the install will have to assist.

Justin Brodley
Supervisor of DataCenter Infrastructure
SumTotal Systems, Inc. (Nasdaq: SUMT
http://quotes.nasdaq.com/asp/summaryquote.asp?symbol=SUMT )
110-110th Ave NE Suite 700
Bellevue, WA 98004

OFFICE +1 425 637 1506
FAX +1 425 455 3071
MOBILE +1 425 753 7033
EMAIL jbrodley@sumtotalsystems.com

MSN justin_brodley msnim:chat?contact=justin_brodley@hotmail.com

The content of this communication is considered SumTotal Confidential,
and should not be shared with anyone outside of SumTotal, either
electronically or verbally, without the express permission of the
author(s).From: Baytalskiy, Sal [mailto:Sal.Baytalskiy@AIG.com]
Sent: Thursday, May 17, 2007 10:47 AM
To: Justin Brodley; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

The Oracle readme said that the DB needs to be prepared.

So i ran the schema.Oracle file via the SQLPlus and it inserted all the
tables and indexes.

So i now have the database setup, just empty. No data.

Then, while running the ‘make initialize-database’ there’s a step in
that script to insert the schema. Since i already did that - i commented
it out, just like the Wiki suggests.

So that step should be skipped and it should just try to insert the
required data into the DB.

And that’s where i’m stuck at this point.

After some googling i found that i might have a problem with the
DBD::Oracle. Apparently it tried installing that module as a 64-bit.

But my Perl is 32-bit. This seems to be a common occurence.

Here’s what i’m getting when trying to run ‘make initialize-database’ :

/usr/bin/perl //usr/local/rt3_ora/sbin/rt-setup-database --action init
–dba mwpoc --prompt-for-dba-password
Unquoted string “error” may clash with future reserved word at
/usr/local/rt3_ora/etc/RT_SiteConfig.pm line 286.
In order to create or update your RT database,this script needs to
connect to your Oracle instance on clorad1.aig.com as mwpoc.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:
DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627
DBI connect(‘CLORAD1;port=1521’,‘mwpoc’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME
SERVER SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line
103
Failed to connect to dbi:Oracle:CLORAD1;port=1521 as mwpoc: Can’t
connect using this syntax without specifying a HOST and one of SID
INSTANCE_NAME SERVER SERVICE_NAME at
//usr/local/rt3_ora/sbin/rt-setup-database line 103, line 1.
make: *** [initialize-database] Error 255

The hostname where oracle Db is running is clorad1.aig.com.
Instance/Service name is CLORAD1.

From: Justin Brodley [mailto:jbrodley@sumtotalsystems.com] 
Sent: Thursday, May 17, 2007 1:40 PM
To: Baytalskiy, Sal; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

I would make sure the variable is set everywhere, the initial

data is imported with the schema, that you commented out. Out of
curiosity why are you commenting out the “schema” the only reason you
would do this is if the database was already created with all the
appropriate tables. Our oracle guys just setup the RT user as per the
oracle readme and then we just ran initialize-database and it created
the rest.

Justin Brodley

 

From: Baytalskiy, Sal [mailto:Sal.Baytalskiy@AIG.com] 
Sent: Thursday, May 17, 2007 10:34 AM
To: Justin Brodley; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

 

Thanks a lot, Justin!!!

This is very valuable info!

 

However, i'm not at that step yet. I've just built RT with

Oracle support and was trying to run ‘make initialize-database’

I've commented out the 'insert_schema()' method call, cause

schema is already in place.

I was expecting the thing to insert the initial RT data into the

DB. But that’s where it was failing.

Do you think i should set the variable you mentioned in the

shell and try running it again?

	From: rt-users-bounces@lists.bestpractical.com

[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Justin
Brodley
Sent: Thursday, May 17, 2007 1:20 PM
To: Baytalskiy, Sal; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

	Sal- It has to do with Apache and your CGI handler not

knowing the oracle parameters. We use Fast CGI on Redhat connecting to a
remote Oracle servers. I had to add the following lines to my
httpd.conf file:

	# RT STUFF FOR APACHE

	SetEnv LD_LIBRARY_PATH

/u01/app/oracle/product/10.2.0/client_1/lib

	SetEnv ORACLE_HOME

/u01/app/oracle/product/10.2.0/client_1

	SetEnv ORACLE_SID rt

	SetEnv TWO_TASK rt

	(change above variables to your implementation)

	 

	In Httpd conf I also had to change the initialization

string for Fastcgi, this is the line in my config.

	FastCgiServer /opt/rt3/bin/mason_handler.fcgi

-idle-timeout 120 -processes 4 -initial-env
LD_LIBRARY_PATH=/u01/app/oracle/product/10.2.0/client_1/lib -initial-env
ORACLE_HOME=/u01/app/oracle/product/10.2.0/client1 -initial-env
ORACLE_SID=rt -initial-env TWO_TASK=rt

	Some of this might be a bit excessive but I was trying

everything and spent a ton of time on the fastcgi and apache websites
trying to figure this out. Once this was all completed I was successful
in getting DBI Searchbuilder working. This took about a 12 hours of
research and trial and error on my part, and I’ve meant to go back and
put this information in the wiki but haven’t had a chance.

	 Justin Brodley

	From: rt-users-bounces@lists.bestpractical.com

[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of
Baytalskiy, Sal
Sent: Wednesday, May 16, 2007 9:49 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Desperately ned Oracle help

	Hey everyone!

	As ive already mentioned - i'm being forced to use

Oracle for my RT 3.6.3 instance.

	Well, today i finally got an Oracle 10g instance up and

loaded the schema.Oracle file into it.

	Did the ./configure for RT(./configure

–prefix=/usr/local/rt3_ora --with-db-type=Oracle
–with-db-host=clorad1.example.com --with-db-port=1521
–with-db-rt-host=localhost --with-db-dba=rtusr
–with-db-database=clorad1 --with-db-rt-user=rtusr
–with-db-rt-pass=***** )

	Everything was ok.

	 

	While doing make initialize-database i got this error:

Unable to load DBIx::SearchBuilder database handle for ‘Oracle’.

	Realized that i don't have DBD::Oracle installed, so i

downloaded that from CPAN and installed that.

	There were errors during the install and i found a

workaround to delete -xarch=v9 from the Makefile. After that install
finished.

	Then i followed the Wiki and commented out the

insert_schema() method call.

	But i'm still getting errors trying to init the DB.

	 

	 

	Test suggested by the Wiki (TWO_TASK=FOO perl -MDBI -le

‘DBI->connect(“DBI:Oracle:”, “rt3”, “rt3”)’) seems to be successful. Or
at least it doesn’t give any errors.

	This is the error i get while doing make

initialize-database :

	DSN component 'CLORAD1' is not in 'name=value' format at

/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627
DBI connect(‘CLORAD1;port=1521’,‘rtusr’,…) failed:
Can’t connect using this syntax without specifying a HOST and one of SID
INSTANCE_NAME SERVER SERVICE_NAME at
//usr/local/rt3_ora/sbin/rt-setup-database line 103
Failed to connect to dbi:Oracle:CLORAD1;port=1521 as
rtusr: Can’t connect using this syntax without specifying a HOST and one
of SID INSTANCE_NAME SERVER SERVICE_NAME at
//usr/local/rt3_ora/sbin/rt-setup-database line 103, line 1.
make: *** [initialize-database] Error 255

	PLEASE HELP !!!

	 

	Thanks in advance,

	Sal.

The Oracle readme said that the DB needs to be prepared.
So i ran the schema.Oracle file via the SQLPlus and it inserted
all the tables and indexes.
So i now have the database setup, just empty. No data.
Then, while running the ‘make initialize-database’ there’s a
step in that script to insert the schema. Since i already did that - i
commented it out, just like the Wiki suggests.
So that step should be skipped and it should just try to insert
the required data into the DB.
And that’s where i’m stuck at this point.

After some googling i found that i might have a problem with the

DBD::Oracle. Apparently it tried installing that module as a 64-bit.
But my Perl is 32-bit. This seems to be a common occurence.

It may help to narrow the problem by testing DBD::Oracle first. Try
using the ‘dbish’ utility installed with DBI, or with a test script like
this (copied and pasted from one I used a while back-- I had to mess
with manually setting $ORACLE_HOME and $LIBPATH in some cases):

#!/usr/local/bin/perl -w

print “hello\n”;

use DBI;
#use DBD::Oracle;

#print “ENV:\n”, map {" $: $ENV{$}\n"} sort keys %ENV;

if ($^O =~ m/aix/i) {
$ENV{ORACLE_HOME} = ‘/usr/local/oracle/instantclient’;
$ENV{LIBPATH} = $ENV{ORACLE_HOME};
}

my $dbh = DBI->connect(‘dbi:Oracle:host=clorad1.aig.com;sid=clorad1’,
‘user’, ‘password’);

print join “\n”, $dbh->get_info(17),
$dbh->get_info(18);

print "\nname from v$database: ", $dbh->selectrow_array(“select name
from v$database”);

print “\n\n”;

I had trouble in the past with 64 / 32 bit perl and Oracle client libs,
so if you do this and still think that may be the issue I can send you
my notes on that, or you can probably google them up somewhere.

-n

Thanks for your responses !!!

Nathan, i ran the script you provided and here’s the output:
hello
Oracle
DBD::Oracle::db selectrow_array failed: ORA-00942: table or view does not
exist (DBD ERROR: error possibly near <> indicator at char 17 in 'select
name from <
>v$database’) [for Statement “select name from v$database”] at
testOracle.pl line 20.
10.02.0300
name from v$database:

It seems to be connecting to the DB just fine.

I also went through this post:
http://www.zorranlabs.com/articles/step-by-step-installation-dbd-oracle-1.16
-on-solaris-9-and-oracle-9-client.htm
<http://www.zorranlabs.com/articles/step-by-step-installation-dbd-oracle-1.1
6-on-solaris-9-and-oracle-9-client.htm>

And performed the modifications mentioned there. Rebuilt the DBD::Oracle
using only the 32 bit libraries.
And ran the test script at the end of that article. It worked fine. Here’s
the outpu:

Running testDBDOracle.pl
() Attempting Oracle Login …
OK
(
) Creating table TEST_DBI …
OK
() Insert into TEST_DBI …
1 rows inserted.
1 rows inserted.
1 rows inserted.
OK
(
) Select from TEST_DBI …
–> TEST_DBI_INTR_NO : 1000
–> TEST_DBI_NAME : Jeff Hunter
–> TEST_DBI_INTR_NO : 1001
–> TEST_DBI_NAME : Melody Hunter
–> TEST_DBI_INTR_NO : 1002
–> TEST_DBI_NAME : Alex Hunter
OK
() Delete from TEST_DBI …
3 rows deleted.
OK
(
) Drop table TEST_DBI …
OK
() Select USER and SYSTEM …
–> USER : MWPOC
–> SYSDATE : 17-MAY-2007 16:45:59
OK
(
) Attempting Oracle Logoff …
OK
Ending testDBDOracle.pl

Judging by that output i think my setup is working fine. But the problem
still persists: i’m still unable to run the ‘make initialize-database’ part
of the install.

Still getting the same old error:
DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627
DBI connect(‘CLORAD1;port=1521’,‘mwpoc’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME SERVER
SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 103
Failed to connect to dbi:Oracle:CLORAD1;port=1521 as mwpoc: Can’t connect
using this syntax without specifying a HOST and one of SID INSTANCE_NAME
SERVER SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 103,
line 1.
make: *** [initialize-database] Error 255

Something tells me that it may be an issue with the 'rt-setup-database’
script itself? Is that a possibility?From: Vonnahme, Nathan [mailto:nathan.vonnahme@bannerhealth.com]
Sent: Thursday, May 17, 2007 3:29 PM
To: Baytalskiy, Sal; Justin Brodley; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Baytalskiy,
Sal
Sent: Thursday, May 17, 2007 9:47 AM
To: Justin Brodley; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

The Oracle readme said that the DB needs to be prepared.
So i ran the schema.Oracle file via the SQLPlus and it inserted all the
tables and indexes.
So i now have the database setup, just empty. No data.
Then, while running the ‘make initialize-database’ there’s a step in that
script to insert the schema. Since i already did that - i commented it out,
just like the Wiki suggests.
So that step should be skipped and it should just try to insert the required
data into the DB.
And that’s where i’m stuck at this point.

After some googling i found that i might have a problem with the
DBD::Oracle. Apparently it tried installing that module as a 64-bit.
But my Perl is 32-bit. This seems to be a common occurence.

It may help to narrow the problem by testing DBD::Oracle first. Try using
the ‘dbish’ utility installed with DBI, or with a test script like this
(copied and pasted from one I used a while back-- I had to mess with
manually setting $ORACLE_HOME and $LIBPATH in some cases):

#!/usr/local/bin/perl -w

print “hello\n”;

use DBI;
#use DBD::Oracle;

#print “ENV:\n”, map {" $: $ENV{$}\n"} sort keys %ENV;

if ($^O =~ m/aix/i) {
$ENV{ORACLE_HOME} = ‘/usr/local/oracle/instantclient’;
$ENV{LIBPATH} = $ENV{ORACLE_HOME};
}

my $dbh = DBI->connect(‘dbi:Oracle:host=clorad1.aig.com;sid=clorad1’,
‘user’, ‘password’);

print join “\n”, $dbh->get_info(17),
$dbh->get_info(18);

print "\nname from v$database: ", $dbh->selectrow_array(“select name from
v$database”);

print “\n\n”;

I had trouble in the past with 64 / 32 bit perl and Oracle client libs, so
if you do this and still think that may be the issue I can send you my notes
on that, or you can probably google them up somewhere.

-n

Hey guys!
A little update:
i’ve been looking at the rt-setup-database script trying to figure out how
to get around the issues i’m having.
So the very first error mentioned this: at
//usr/local/rt3_ora/sbin/rt-setup-database line 103 which is this
$dbh = DBI->connect( get_system_dsn(), $args{‘dba’}, $args{‘dba-password’} )
So i replaced that with: $dbh = DBI->connect( “DBI:Oracle:”, $args{‘dba’},
$args{‘dba-password’} )

That seemed to get me a bit farther as i got this output:
Now creating a database for RT.
…skipped as mwpoc is not mwpoc or we’re working with Oracle.
DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627
DBI connect(‘CLORAD1;port=1521’,‘mwpoc’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME SERVER
SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 138
Can’t connect using this syntax without specifying a HOST and one of SID
INSTANCE_NAME SERVER SERVICE_NAME at
//usr/local/rt3_ora/sbin/rt-setup-database line 138, line 1.
make: *** [initialize-database] Error 255

So next, naturally, i looked at line 138 and replaced
$dbh = DBI->connect( $Handle->DSN, ${RT::DatabaseUser},
${RT::DatabasePassword} ) || die $DBI::errstr;
with
$dbh = DBI->connect( “DBI:Oracle:CLORAD1”, ${RT::DatabaseUser},
${RT::DatabasePassword} ) || die $DBI::errstr;

That got me a little farther again:
Now creating a database for RT.
…skipped as mwpoc is not mwpoc or we’re working with Oracle.
Now populating database schema.
Now inserting database ACLs
Now inserting RT core system objects
[Thu May 17 23:25:02 2007] [crit]: Connect Failed Can’t connect using this
syntax without specifying a HOST and one of SID INSTANCE_NAME SERVER
SERVICE_NAME
at //usr/local/rt3_ora/sbin/rt-setup-database line 390
(/usr/local/rt3_ora/lib/RT.pm:346)

Stack trace:
RT::ANON() called at /usr/perl5/5.8.4/lib/Carp.pm:191
Carp::croak() called at
/usr/perl5/site_perl/5.8.4/DBIx/SearchBuilder/Handle.pm:106
DBIx::SearchBuilder::Handle::Connect() called at
/usr/perl5/site_perl/5.8.4/DBIx/SearchBuilder/Handle/Oracle.pm:46
DBIx::SearchBuilder::Handle::Oracle::Connect() called at
/usr/local/rt3_ora/lib/RT/Handle.pm:98
RT::Handle::Connect() called at
//usr/local/rt3_ora/sbin/rt-setup-database:390
main::insert_initial_data() called at
//usr/local/rt3_ora/sbin/rt-setup-database:149
Connect Failed Can’t connect using this syntax without specifying a HOST and
one of SID INSTANCE_NAME SERVER SERVICE_NAME
at //usr/local/rt3_ora/sbin/rt-setup-database line 390
make: *** [initialize-database] Error 29

I am stuck again though as line 390 is this:
require RT::Handle;
$RT::Handle = RT::Handle->new();
$RT::Handle->Connect();

Since i no nothing about Perl - i have no idea what i have to hardcode here
to get past this.

Any ideas, anyone? I’m just trying to hack this script to populate the DB so
i can finally move on to trying to configure the web interface…From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Baytalskiy,
Sal
Sent: Thursday, May 17, 2007 5:02 PM
To: Vonnahme, Nathan; Justin Brodley; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

Thanks for your responses !!!

Nathan, i ran the script you provided and here’s the output:
hello
Oracle
DBD::Oracle::db selectrow_array failed: ORA-00942: table or view does not
exist (DBD ERROR: error possibly near <> indicator at char 17 in 'select
name from <
>v$database’) [for Statement “select name from v$database”] at
testOracle.pl line 20.
10.02.0300
name from v$database:

It seems to be connecting to the DB just fine.

I also went through this post:
http://www.zorranlabs.com/articles/step-by-step-installation-dbd-oracle-1.16
-on-solaris-9-and-oracle-9-client.htm
<http://www.zorranlabs.com/articles/step-by-step-installation-dbd-oracle-1.1
6-on-solaris-9-and-oracle-9-client.htm>

And performed the modifications mentioned there. Rebuilt the DBD::Oracle
using only the 32 bit libraries.
And ran the test script at the end of that article. It worked fine. Here’s
the outpu:

Running testDBDOracle.pl
() Attempting Oracle Login …
OK
(
) Creating table TEST_DBI …
OK
() Insert into TEST_DBI …
1 rows inserted.
1 rows inserted.
1 rows inserted.
OK
(
) Select from TEST_DBI …
–> TEST_DBI_INTR_NO : 1000
–> TEST_DBI_NAME : Jeff Hunter
–> TEST_DBI_INTR_NO : 1001
–> TEST_DBI_NAME : Melody Hunter
–> TEST_DBI_INTR_NO : 1002
–> TEST_DBI_NAME : Alex Hunter
OK
() Delete from TEST_DBI …
3 rows deleted.
OK
(
) Drop table TEST_DBI …
OK
() Select USER and SYSTEM …
–> USER : MWPOC
–> SYSDATE : 17-MAY-2007 16:45:59
OK
(
) Attempting Oracle Logoff …
OK
Ending testDBDOracle.pl

Judging by that output i think my setup is working fine. But the problem
still persists: i’m still unable to run the ‘make initialize-database’ part
of the install.

Still getting the same old error:
DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627
DBI connect(‘CLORAD1;port=1521’,‘mwpoc’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME SERVER
SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 103
Failed to connect to dbi:Oracle:CLORAD1;port=1521 as mwpoc: Can’t connect
using this syntax without specifying a HOST and one of SID INSTANCE_NAME
SERVER SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database line 103,
line 1.
make: *** [initialize-database] Error 255

Something tells me that it may be an issue with the 'rt-setup-database’
script itself? Is that a possibility?

From: Vonnahme, Nathan [mailto:nathan.vonnahme@bannerhealth.com]
Sent: Thursday, May 17, 2007 3:29 PM
To: Baytalskiy, Sal; Justin Brodley; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Baytalskiy,
Sal
Sent: Thursday, May 17, 2007 9:47 AM
To: Justin Brodley; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Desperately ned Oracle help

The Oracle readme said that the DB needs to be prepared.
So i ran the schema.Oracle file via the SQLPlus and it inserted all the
tables and indexes.
So i now have the database setup, just empty. No data.
Then, while running the ‘make initialize-database’ there’s a step in that
script to insert the schema. Since i already did that - i commented it out,
just like the Wiki suggests.
So that step should be skipped and it should just try to insert the required
data into the DB.
And that’s where i’m stuck at this point.

After some googling i found that i might have a problem with the
DBD::Oracle. Apparently it tried installing that module as a 64-bit.
But my Perl is 32-bit. This seems to be a common occurence.

It may help to narrow the problem by testing DBD::Oracle first. Try using
the ‘dbish’ utility installed with DBI, or with a test script like this
(copied and pasted from one I used a while back-- I had to mess with
manually setting $ORACLE_HOME and $LIBPATH in some cases):

#!/usr/local/bin/perl -w

print “hello\n”;

use DBI;
#use DBD::Oracle;

#print “ENV:\n”, map {" $: $ENV{$}\n"} sort keys %ENV;

if ($^O =~ m/aix/i) {
$ENV{ORACLE_HOME} = ‘/usr/local/oracle/instantclient’;
$ENV{LIBPATH} = $ENV{ORACLE_HOME};
}

my $dbh = DBI->connect(‘dbi:Oracle:host=clorad1.aig.com;sid=clorad1’,
‘user’, ‘password’);

print join “\n”, $dbh->get_info(17),
$dbh->get_info(18);

print "\nname from v$database: ", $dbh->selectrow_array(“select name from
v$database”);

print “\n\n”;

I had trouble in the past with 64 / 32 bit perl and Oracle client libs, so
if you do this and still think that may be the issue I can send you my notes
on that, or you can probably google them up somewhere.

-n

Baytalskiy, Sal wrote:

Hey guys!
A little update:
i’ve been looking at the rt-setup-database script trying to figure out
how to get around the issues i’m having.
So the very first error mentioned this: at
//usr/local/rt3_ora/sbin/rt-setup-database line 103 which is this
$dbh = DBI->connect( get_system_dsn(), $args{‘dba’},
$args{‘dba-password’} )

So i replaced that with: $dbh = DBI->connect( “DBI:Oracle:”,
$args{‘dba’}, $args{‘dba-password’} )

That seemed to get me a bit farther as i got this output:
Now creating a database for RT.
…skipped as mwpoc is not mwpoc or we’re working with Oracle.
DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627
DBI connect(‘CLORAD1;port=1521’,‘mwpoc’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME
SERVER SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database *line 138
*Can’t connect using this syntax without specifying a HOST and one of
SID INSTANCE_NAME SERVER SERVICE_NAME at
//usr/local/rt3_ora/sbin/rt-setup-database line 138, line 1.
make: *** [initialize-database] Error 255
I’m using Oracle too and it should not matter whether the database is on
the localhost or a remote one, so I would go back and do the following:

  • drop the schema of RT on the remote server

  • add the RT user or grant DBA role to it (temporarily)

  • configure RT again with the correct parameters these are mine adjust
    accordingly:
    – export ORACLE_HOME=/your/oracle/home
    – export ORACLE_SID=YOURSID
    – (else the following line will barf)
    – ./configure --with-db-type=Oracle --with-db-dba=rt_user
    –with-db-database=XE

    (if XE is in your tnsnames.ora then everything should work doesn’t
    matter where that db is)

  • make initialize-database

As to the 32/64bit problem that used to be an issue but since I haven’t
done a clean install in a while I don’t know if current DBD::Oracle
still has problems. The way I fixed this once, from memory, is that I
did edit the make file to use $ORACLE_HOME/lib32 instead of
$ORACLE_HOME/lib which is since 10g 64bit instead of 32 as is used to be
in pre 10g.
But you should get a error from making DBD::Oracle which should be
rather clear on this issue since it complains about elf64 problems.

Hope this helps, either contact me offlist, I might be able to help.

Joop

Update:

I tried getting DBA permissions temporarily but the DBAs won’t do it for me.
Too risky they say.
So they granted the CREATE USER permission to the existing user id they gave
me.
That got me a bit farther than yesterday.

Here’s the output:

Password:
Now creating a database for RT.
Creating Oracle database CLORAD1.
Done setting up database ACLs.
Now populating database schema.
Creating database schema.
Done setting up database schema.
Now inserting database ACLs
Now inserting RT core system objects
[Fri May 18 14:55:38 2007] [crit]: Connect Failed Can’t connect using this
syntax without specifying a HOST and one of SID INSTANCE_NAME SERVER
SERVICE_NAME
at //usr/local/rt3_ora/sbin/rt-setup-database line 390
(/usr/local/rt3_ora/lib/RT.pm:346)

Stack trace:
RT::ANON() called at /usr/perl5/5.8.4/lib/Carp.pm:191
Carp::croak() called at
/usr/perl5/site_perl/5.8.4/DBIx/SearchBuilder/Handle.pm:106
DBIx::SearchBuilder::Handle::Connect() called at
/usr/perl5/site_perl/5.8.4/DBIx/SearchBuilder/Handle/Oracle.pm:46
DBIx::SearchBuilder::Handle::Oracle::Connect() called at
/usr/local/rt3_ora/lib/RT/Handle.pm:98
RT::Handle::Connect() called at
//usr/local/rt3_ora/sbin/rt-setup-database:390
main::insert_initial_data() called at
//usr/local/rt3_ora/sbin/rt-setup-database:149
Connect Failed Can’t connect using this syntax without specifying a HOST and
one of SID INSTANCE_NAME SERVER SERVICE_NAME
at //usr/local/rt3_ora/sbin/rt-setup-database line 390
make: *** [initialize-database] Error 29

So at this point I really need your help on getting past the Line 390
problem (sub insert_initial_data)
What do I need to do to make it connect to my DB? I’ve been hardcoding the
DBI:Oracle:CLORAD1 everywhere else it was failing to connect.
But I don’t know how to do it in this sub. Here’s how its trying to connect
now:

    #connect to the db, for actual RT work
    require RT::Handle;
    $RT::Handle = RT::Handle->new();

Line 390) $RT::Handle->Connect();

Is there anything I can set to make it connect to my DB like this? I don’t
care if I hardcode it like I did before, just as long as its able to finally
finish initializing the DB.

I think I’m real close now…From: Joop van de Wege [mailto:JoopvandeWege@mococo.nl]
Sent: Friday, May 18, 2007 6:04 AM
To: Baytalskiy, Sal
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Desperately ned Oracle help

Baytalskiy, Sal wrote:

Hey guys!
A little update:
i’ve been looking at the rt-setup-database script trying to figure out
how to get around the issues i’m having.
So the very first error mentioned this: at
//usr/local/rt3_ora/sbin/rt-setup-database line 103 which is this
$dbh = DBI->connect( get_system_dsn(), $args{‘dba’},
$args{‘dba-password’} )
So i replaced that with: $dbh = DBI->connect(
“DBI:Oracle:”, $args{‘dba’}, $args{‘dba-password’} )

That seemed to get me a bit farther as i got this output:
Now creating a database for RT.
…skipped as mwpoc is not mwpoc or we’re working with Oracle.
DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627 DBI
connect(‘CLORAD1;port=1521’,‘mwpoc’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME
SERVER SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database
*line 138 *Can’t connect using this syntax without specifying a HOST
and one of SID INSTANCE_NAME SERVER SERVICE_NAME at
//usr/local/rt3_ora/sbin/rt-setup-database line 138, line 1.
make: *** [initialize-database] Error 255
I’m using Oracle too and it should not matter whether the database is on
the localhost or a remote one, so I would go back and do the following:

  • drop the schema of RT on the remote server

  • add the RT user or grant DBA role to it (temporarily)

  • configure RT again with the correct parameters these are mine adjust
    accordingly:
    – export ORACLE_HOME=/your/oracle/home
    – export ORACLE_SID=YOURSID
    – (else the following line will barf)
    – ./configure --with-db-type=Oracle --with-db-dba=rt_user
    –with-db-database=XE

    (if XE is in your tnsnames.ora then everything should work doesn’t matter
    where that db is)

  • make initialize-database

As to the 32/64bit problem that used to be an issue but since I haven’t done
a clean install in a while I don’t know if current DBD::Oracle still has
problems. The way I fixed this once, from memory, is that I did edit the
make file to use $ORACLE_HOME/lib32 instead of $ORACLE_HOME/lib which is
since 10g 64bit instead of 32 as is used to be in pre 10g.
But you should get a error from making DBD::Oracle which should be rather
clear on this issue since it complains about elf64 problems.

Hope this helps, either contact me offlist, I might be able to help.

Joop

I tried replacing

$RT::Handle->Connect(); (line 390)

with

$RT::Handle = DBI->connect(“dbi:Oracle:host=clorad1.aig.com;sid=CLORAD1”,
“mwpoc”, “mwpoc”);

Not sure if this is correct but that got me even farther:

Password:
Now creating a database for RT.
Creating Oracle database CLORAD1.
Done setting up database ACLs.
Now populating database schema.
Creating database schema.
Done setting up database schema.
Now inserting database ACLs
Now inserting RT core system objects
Checking for existing system user…Can’t locate object method "Rollback"
via package “DBI::db” at /usr/local/rt3_ora/lib/RT.pm line 345.
make: *** [initialize-database] Error 255

I can actually see that it created the user id that I specified as $RTUser
in my SiteConfig.pm file.

Please tell me what I’m doing wrong and how can I make this line 390 work.

Thanks in advance,
Sal.From: Joop van de Wege [mailto:JoopvandeWege@mococo.nl]
Sent: Friday, May 18, 2007 6:04 AM
To: Baytalskiy, Sal
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Desperately ned Oracle help

Baytalskiy, Sal wrote:

Hey guys!
A little update:
i’ve been looking at the rt-setup-database script trying to figure out
how to get around the issues i’m having.
So the very first error mentioned this: at
//usr/local/rt3_ora/sbin/rt-setup-database line 103 which is this
$dbh = DBI->connect( get_system_dsn(), $args{‘dba’},
$args{‘dba-password’} )
So i replaced that with: $dbh = DBI->connect(
“DBI:Oracle:”, $args{‘dba’}, $args{‘dba-password’} )

That seemed to get me a bit farther as i got this output:
Now creating a database for RT.
…skipped as mwpoc is not mwpoc or we’re working with Oracle.
DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627 DBI
connect(‘CLORAD1;port=1521’,‘mwpoc’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME
SERVER SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database
*line 138 *Can’t connect using this syntax without specifying a HOST
and one of SID INSTANCE_NAME SERVER SERVICE_NAME at
//usr/local/rt3_ora/sbin/rt-setup-database line 138, line 1.
make: *** [initialize-database] Error 255
I’m using Oracle too and it should not matter whether the database is on
the localhost or a remote one, so I would go back and do the following:

  • drop the schema of RT on the remote server

  • add the RT user or grant DBA role to it (temporarily)

  • configure RT again with the correct parameters these are mine adjust
    accordingly:
    – export ORACLE_HOME=/your/oracle/home
    – export ORACLE_SID=YOURSID
    – (else the following line will barf)
    – ./configure --with-db-type=Oracle --with-db-dba=rt_user
    –with-db-database=XE

    (if XE is in your tnsnames.ora then everything should work doesn’t matter
    where that db is)

  • make initialize-database

As to the 32/64bit problem that used to be an issue but since I haven’t done
a clean install in a while I don’t know if current DBD::Oracle still has
problems. The way I fixed this once, from memory, is that I did edit the
make file to use $ORACLE_HOME/lib32 instead of $ORACLE_HOME/lib which is
since 10g 64bit instead of 32 as is used to be in pre 10g.
But you should get a error from making DBD::Oracle which should be rather
clear on this issue since it complains about elf64 problems.

Hope this helps, either contact me offlist, I might be able to help.

Joop

Yep, I had to edit the Makefile as well. Not only did I change all /lib to
/lib32, but I also had to remove the -xarch=v9 from everywhere.
That fixed the make process for DBD::Oracle.

Now, the good news: I finally figured it out and made the ‘make
initialize-database’ work. It even inserted the schema all by itself.
Here’s what I had to do:

In the file /usr/perl5/site_perl/5.8.4/DBIx/SearchBuilder/Handle.pm

I replaced
my $handle = DBI->connect($self->DSN, $args{‘User’}, $args{‘Password’}) ||
croak “Connect Failed $DBI::errstr\n” ;
With
my $handle = DBI->connect(“DBI:Oracle:CLORAD1”, $args{‘User’},
$args{‘Password’}) || croak “Connect Failed $DBI::errstr\n” ;

Effectively hardcoding the connection info.

That seems to fix the errors I was getting and finally populated the DB.

I then used other suggestions that were made here and added some more
directives to my httpd.conf file and I can finally connect to the RT
instance with Oracle 10g backend.

I have to say that ticket creation takes much longer than with local MySQL
instance. I’m not sure if its my setup or its just that slow.

Now the new challenge is to install RTFM and AssetTracker. They both make
additions to the DB as well. We’ll see how that works out…

Thanks everyone!!!

Sal.From: Joop van de Wege [mailto:JoopvandeWege@mococo.nl]
Sent: Friday, May 18, 2007 6:04 AM
To: Baytalskiy, Sal
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Desperately ned Oracle help

Baytalskiy, Sal wrote:

Hey guys!
A little update:
i’ve been looking at the rt-setup-database script trying to figure out
how to get around the issues i’m having.
So the very first error mentioned this: at
//usr/local/rt3_ora/sbin/rt-setup-database line 103 which is this
$dbh = DBI->connect( get_system_dsn(), $args{‘dba’},
$args{‘dba-password’} )
So i replaced that with: $dbh = DBI->connect(
“DBI:Oracle:”, $args{‘dba’}, $args{‘dba-password’} )

That seemed to get me a bit farther as i got this output:
Now creating a database for RT.
…skipped as mwpoc is not mwpoc or we’re working with Oracle.
DSN component ‘CLORAD1’ is not in ‘name=value’ format at
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI.pm line 627 DBI
connect(‘CLORAD1;port=1521’,‘mwpoc’,…) failed: Can’t connect using
this syntax without specifying a HOST and one of SID INSTANCE_NAME
SERVER SERVICE_NAME at //usr/local/rt3_ora/sbin/rt-setup-database
*line 138 *Can’t connect using this syntax without specifying a HOST
and one of SID INSTANCE_NAME SERVER SERVICE_NAME at
//usr/local/rt3_ora/sbin/rt-setup-database line 138, line 1.
make: *** [initialize-database] Error 255
I’m using Oracle too and it should not matter whether the database is on
the localhost or a remote one, so I would go back and do the following:

  • drop the schema of RT on the remote server

  • add the RT user or grant DBA role to it (temporarily)

  • configure RT again with the correct parameters these are mine adjust
    accordingly:
    – export ORACLE_HOME=/your/oracle/home
    – export ORACLE_SID=YOURSID
    – (else the following line will barf)
    – ./configure --with-db-type=Oracle --with-db-dba=rt_user
    –with-db-database=XE

    (if XE is in your tnsnames.ora then everything should work doesn’t matter
    where that db is)

  • make initialize-database

As to the 32/64bit problem that used to be an issue but since I haven’t done
a clean install in a while I don’t know if current DBD::Oracle still has
problems. The way I fixed this once, from memory, is that I did edit the
make file to use $ORACLE_HOME/lib32 instead of $ORACLE_HOME/lib which is
since 10g 64bit instead of 32 as is used to be in pre 10g.
But you should get a error from making DBD::Oracle which should be rather
clear on this issue since it complains about elf64 problems.

Hope this helps, either contact me offlist, I might be able to help.

Joop