Default SLA with spec. chars in queue name


#1

Hi,

I would like to set the default SLA level per queue with the QueueDefault parameter, but i have a queue with our spec. hungarian characters in the name like őúóüöéáű :slight_smile:
RT cannot assign the default ‘notsoimportant’ SLA levele for that queue. Every time i tried, the new ticket had the default SLA. If i deleted the Default parameter form the SLA conf, then the SLA paramter of the new ticket was empty.
How can i specifiy these ‘weird’ Queue names in the SLA configuration pm?
My RT version: 4.4.1

Thanks for your help!

Cheers,
Zoltan


#2

I found the issue, but i dont know how to fix it in a good way.
I worte some debugging to the SLA.pm, so here is my string in the regular way: “beléptetés”.

I see that in the debug log:
[20719] [Fri Jan 12 19:15:45 2018] [debug]: compare: beléptetés beléptetés (/usr/share/request-tracker4/lib/RT/SLA.pm:248)

the code snip:
$mystrval = $args{‘Queue’}->Name;
$myconst = ‘beléptetés’;
$RT::Logger->debug( "compare: " . $mystrval . " " . $myconst );

Is there a config option to transform the string to latin1 returned from the db or something? I can handle it in the code with Encode(), but its not so cool.
As you see the DB returns an UTF8 string and your code looking for the Queue in the QueueDefault hash with that key, but its not working in that way.

Thanks!