Debian Upgrade Qmail problem

Hi

I installed RT on Debian Sarge before it was released.

It was all working fine.

The I did and “apt-get update” and an “apt-get upgrade”.

It is all working expect I get no emails going back to the requester to
say an incident has been created.

I am using Qmail.

Regards

Chris

Log entries would be helpful here (as would be setting your system clock).

Chris wrote:

Hi,

I just upgraded to RT 3.4.3 from 3.0.11 on Solaris. I keep getting the
following error on the screen:

error: no connection to syslog available at
/usr/local/lib/perl5/site_perl/5.8.5/Log/Dispatch/Syslog.pm line 77

and this error in the web log:

Tue Aug 23 11:42:17 2005] [error] [client xxx.xxx.xx.xxx] FastCGI: server
"/home/web/sites/rt/rt3/bin/mason_handler.fcgi" stderr: unix dgram connect:
Socket operation on non-socket at
/usr/local/lib/perl5/site_perl/5.8.5/Log/Dispatch/Syslog.pm line 77

I have the following in both RT_SiteConfig.pm and RT_Config.pm:

Mail loops will generate a critical log message.

Set($LogToSyslog , undef);
Set($LogToScreen , ‘error’);
Set($LogToFile , ‘debug’);
Set($LogDir, ‘/home/web/sites/rt/rt3/var/log’);
Set($LogToFileNamed , “rt.log”); #log to rt.log

On Solaris or UnixWare, set to ( socket => ‘inet’ ). Options here

override any other options RT passes to Log::Dispatch::Syslog.

Other interesting flags include facility and logopt. (See the

Log::Dispatch::Syslog documentation for more information.) (Maybe

ident too, if you have multiple RT installations.)

@LogToSyslogConf = ( socket => ‘inet’ ) unless (@LogToSyslogConf);

I’ve tried commenting out the last line above, but I’m still getting the
error.

Any help would be greatly appreciated. Thanks!

-Ed

Ed Santora, System Administrator
Harvard University, Academic Computing
Division of Continuing Education

Mail loops will generate a critical log message.

Set($LogToSyslog , undef);

If you don’t want it to use syslog, you need to use ‘’ instead of
undef.

Set($LogToSyslog , ‘’);

This is a side-effect of the magic configuration setting stuff that
allows us to have a RT_LocalConfig file.[1]

-R

Footnotes:
[1] Unless we fixed that… but I don’t think we did.

Hi all,
I am trying to run RT 3.4.1 with Apache 2.0.54 with mod_perl 2.01. Apache
2.0.54 fails to start up because of this error. Could someone give a
solution for this.

Thu Aug 25 15:06:37 2005] [error] Can’t load Perl module Apache2 for
server localhost.localdomain:0, exiting…
[Thu Aug 25 15:39:19 2005] [error] Can’t locate Apache2.pm in @INC (@INC
contains: /usr/local/lib/perl5/5.8.6/i686-linux /usr/local/lib/perl5/5.8.6
/usr/local/lib/perl5/site_perl/5.8.6/i686-linux
/usr/local/lib/perl5/site_perl/5.8.6 /usr/local/lib/perl5/site_perl .
/usr/local/rt_dev/apacheRT3) at (eval 2) line 3.

Regards,
Ahalya Nathan
Senior Programmer / Analyst
Information Technology, Metropolitan Utilities District
(402) 449-8218 phone
(402) 449-8131 fax
ahalya_nathan@mudnebr.com

Hi all,
I am trying to run RT 3.4.1 with Apache 2.0.54 with mod_perl 2.01. Apache
2.0.54 fails to start up because of this error. Could someone give a
solution for this.

You’re going to be trying for a long, long time unless you upgrade.
RT 3.4.4pre2 and newer support mod_perl 2. Anything older than that
will not work with mod_perl2.

Hi Jesse,

If i switch to FastCGI, do i have to reinstall RT all over again?

Regards,
Ahalya Nathan
Senior Programmer / Analyst
Information Technology, Metropolitan Utilities District
(402) 449-8218 phone
(402) 449-8131 fax
ahalya_nathan@mudnebr.com

Jesse Vincent jesse@bestpractical.com
08/25/2005 05:09 PM

To
Ahalya_Nathan@mudnebr.com
cc
rt-users@lists.bestpractical.com
Subject
Re: [rt-users] Can’t locate Apache2.pm in @INC ??

Hi all,
I am trying to run RT 3.4.1 with Apache 2.0.54 with mod_perl 2.01.
Apache
2.0.54 fails to start up because of this error. Could someone give a
solution for this.

You’re going to be trying for a long, long time unless you upgrade.
RT 3.4.4pre2 and newer support mod_perl 2. Anything older than that
will not work with mod_perl2.

Hi all,
I am trying to run RT 3.4.1 with Apache 2.0.54 with mod_perl 2.01. Apache
2.0.54 fails to start up because of this error. Could someone give a
solution for this.

You’re going to be trying for a long, long time unless you upgrade.
RT 3.4.4pre2 and newer support mod_perl 2. Anything older than that
will not work with mod_perl2.

Are you certain of that fencepoint? I’m reasonably certain I’m running
3.4.2, and it’s working for me.

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

"NPR has a lot in common with Nascar... we both turn to the left."
	- Peter Sagal, on Wait Wait, Don't Tell Me!

You’re going to be trying for a long, long time unless you upgrade.
RT 3.4.4pre2 and newer support mod_perl 2. Anything older than that
will not work with mod_perl2.

Are you certain of that fencepoint? I’m reasonably certain I’m running
3.4.2, and it’s working for me.

There is no way an unmodified RT 3.4.2 could work with the released
version of mod_perl2. I can believe that you have an old beta or release
candidate which predates the great renaming.

Hi,

We had installed RT with mod-perl 1 initially, now i am trying to install
it with mod-perl 2. The way i went about is I used the previosuly
configured RT, built mod_perl 2 and added the following to
the httpd.conf file of apache :
PerlModule Apache2
LoadModule perl_module modules/mod_perl.so

<VirtualHost *:80>
ServerName domain.example.com
ServerAlias domain
ErrorLog logs/dummy-host.example.com-error_log
CustomLog logs/dummy-host.example.com-access_log common
DocumentRoot /usr/local/rt/share/html
AddDefaultCharset UTF-8
PerlModule Apache2 Apache::compat
PerlModule Apache::DBI
PerlRequire /usr/local/rt/bin/webmux.pl
PerlSetVar MasonArgsMethod CGI

<Location >
    SetHandler perl-script
    PerlHandler RT::Mason
    PerlOptions +ParseHeaders
    Options +ExecCGI
Apache fails to run if i add the first line "PerlModule Apache2". Do i have to configure RT again - - with -mod-perl2 option?? Because i didn't do that.

Regards,
Ahalya Nathan
Senior Programmer / Analyst
Information Technology, Metropolitan Utilities District
(402) 449-8218 phone
(402) 449-8131 fax
ahalya_nathan@mudnebr.com

“Jay R. Ashworth” jra@baylink.com
Sent by: rt-users-bounces@lists.bestpractical.com
08/26/2005 09:32 AM

To
rt-users@lists.bestpractical.com
cc

Subject
Re: [rt-users] Can’t locate Apache2.pm in @INC ??

Hi all,
I am trying to run RT 3.4.1 with Apache 2.0.54 with mod_perl 2.01.
Apache

2.0.54 fails to start up because of this error. Could someone give a
solution for this.

You’re going to be trying for a long, long time unless you upgrade.
RT 3.4.4pre2 and newer support mod_perl 2. Anything older than that
will not work with mod_perl2.

Are you certain of that fencepoint? I’m reasonably certain I’m running
3.4.2, and it’s working for me.

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC
2100
Ashworth & Associates The Things I Think '87
e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647
1274

             "NPR has a lot in common with Nascar... we both turn to 

the left."
- Peter Sagal, on Wait Wait, Don’t Tell
Me!
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

You’re going to be trying for a long, long time unless you upgrade.
RT 3.4.4pre2 and newer support mod_perl 2. Anything older than that
will not work with mod_perl2.

Are you certain of that fencepoint? I’m reasonably certain I’m running
3.4.2, and it’s working for me.

There is no way an unmodified RT 3.4.2 could work with the released
version of mod_perl2. I can believe that you have an old beta or release
candidate which predates the great renaming.

Apologies: you’re right; I’m wrong. It’s 3.4.1.

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

"NPR has a lot in common with Nascar... we both turn to the left."
	- Peter Sagal, on Wait Wait, Don't Tell Me!