DBD:mysql>=2.1018 ...MISSING

I’m setting up an RT server with the following:

RT 4.2.9
postgres 9.4
apache 2.2.15

When I get to the part of the install where I’m trying to resolve the
perl dependencies and I run

make testdeps
make fixdeps

it always comes back with

MYSQL missing dependencies:
DBD::mysql >= 2.1018 …MISSING

Perl library path for /usr/bin/perl:
/usr/local/lib64/perl5
/usr/local/share/perl5
/usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl
/usr/lib64/perl5
/usr/share/perl5
.
make: *** [fixdeps] Error 1

We’re using postgres not mysql. It sounds like something we don’t need.
Is there a way to skip this or remove it as a dependency?
Any idea how to resolve this?

Thank you,

Jonathan Murray

I’m setting up an RT server with the following:

RT 4.2.9
postgres 9.4
apache 2.2.15

When I get to the part of the install where I’m trying to resolve the perl
dependencies and I run

make testdeps
make fixdeps

it always comes back with

MYSQL missing dependencies:
DBD::mysql >= 2.1018 …MISSING

Perl library path for /usr/bin/perl:
/usr/local/lib64/perl5
/usr/local/share/perl5
/usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl
/usr/lib64/perl5
/usr/share/perl5
.
make: *** [fixdeps] Error 1

We’re using postgres not mysql. It sounds like something we don’t need. Is
there a way to skip this or remove it as a dependency?
Any idea how to resolve this?

./configure --with-db-type=Pg --with-db-dba=postgres

There are other configure options you might want. FWIW, here is my
configure incantation:

./configure --enable-graphviz --enable-gd --enable-gpg
–with-rt-group=root --with-web-user=www-data
–with-web-group=www-data --with-web-handler=fastcgi
–with-libs-group=root --with-db-type=Pg --with-db-dba=postgres

You (generally) can see the configure options using:

./configure --help

-m

I’m setting up an RT server with the following:

RT 4.2.9
postgres 9.4
apache 2.2.15

When I get to the part of the install where I’m trying to resolve the perl
dependencies and I run

make testdeps
make fixdeps

it always comes back with

MYSQL missing dependencies:
DBD::mysql >= 2.1018 …MISSING

Perl library path for /usr/bin/perl:
/usr/local/lib64/perl5
/usr/local/share/perl5
/usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl
/usr/lib64/perl5
/usr/share/perl5
.
make: *** [fixdeps] Error 1

We’re using postgres not mysql. It sounds like something we don’t need. Is
there a way to skip this or remove it as a dependency?
Any idea how to resolve this?

./configure --with-db-type=Pg --with-db-dba=postgres

There are other configure options you might want. FWIW, here is my
configure incantation:

./configure --enable-graphviz --enable-gd --enable-gpg
–with-rt-group=root --with-web-user=www-data
–with-web-group=www-data --with-web-handler=fastcgi
–with-libs-group=root --with-db-type=Pg --with-db-dba=postgres

You (generally) can see the configure options using:

./configure --help

-m

It’s a different error now, but some progress as it’s not related to mysql.
I’m using this as my configure:

./configure --with-web-user=apache --with-web-group=apache
–enable-graphviz --enable-gd --with-db-type=Pg

I’m assuming that “Pg” means postgres. (configure --help doesn’t
actually specify postgres, just Pg)

then:

make testdeps
make fixdeps

Configuring DBD::Pg 3.5.1
Path to pg_config? /usr/pgsql-9.4/bin/pg_config

then I get this
SOME DEPENDENCIES WERE MISSING.
PG missing dependencies:
DBD::Pg >= 1.43 …MISSING

Is it looking for postgres in a special location? I can only find one
pg_config on my system:

/usr/pgsql-9.4/bin/pg_config

I got my postgres from here:

http://yum.postgresql.org/9.4/redhat/rhel-6-x86_64/pgdg-centos94-9.4-1.noarch.rpm

Is it possible I’m using the wrong version of Postgres (9.4.1) with this
version of RT (4.2.9)?

Thank you, Jonathan

I’m setting up an RT server with the following:

RT 4.2.9
postgres 9.4
apache 2.2.15

When I get to the part of the install where I’m trying to resolve the
perl
dependencies and I run

make testdeps
make fixdeps

it always comes back with

MYSQL missing dependencies:
DBD::mysql >= 2.1018 …MISSING

Perl library path for /usr/bin/perl:
/usr/local/lib64/perl5
/usr/local/share/perl5
/usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl
/usr/lib64/perl5
/usr/share/perl5
.
make: *** [fixdeps] Error 1

We’re using postgres not mysql. It sounds like something we don’t need.
Is
there a way to skip this or remove it as a dependency?
Any idea how to resolve this?

./configure --with-db-type=Pg --with-db-dba=postgres

There are other configure options you might want. FWIW, here is my
configure incantation:

./configure --enable-graphviz --enable-gd --enable-gpg
–with-rt-group=root --with-web-user=www-data
–with-web-group=www-data --with-web-handler=fastcgi
–with-libs-group=root --with-db-type=Pg --with-db-dba=postgres

You (generally) can see the configure options using:

./configure --help

-m

It’s a different error now, but some progress as it’s not related to mysql.
I’m using this as my configure:

./configure --with-web-user=apache --with-web-group=apache --enable-graphviz
–enable-gd --with-db-type=Pg

I’m assuming that “Pg” means postgres. (configure --help doesn’t actually
specify postgres, just Pg)

then:

make testdeps
make fixdeps

Configuring DBD::Pg 3.5.1
Path to pg_config? /usr/pgsql-9.4/bin/pg_config

I don’t use the “make fixdeps”. Perhaps someone else can chime in on this.

then I get this
SOME DEPENDENCIES WERE MISSING.
PG missing dependencies:
DBD::Pg >= 1.43 …MISSING

If you want to install perl modules separate from the install process
for RT, you could check your package repositories or metacpan.org for
the upstream source.

Is it looking for postgres in a special location? I can only find one
pg_config on my system:

/usr/pgsql-9.4/bin/pg_config

Perhaps try symlinking that to /usr/local/bin or /usr/bin. The Debian
package puts pg_config in /usr/bin.

I got my postgres from here:

http://yum.postgresql.org/9.4/redhat/rhel-6-x86_64/pgdg-centos94-9.4-1.noarch.rpm

Sure.

Is it possible I’m using the wrong version of Postgres (9.4.1) with this
version of RT (4.2.9)?

I would be shocked if 9.4 could not work with 4.2. I wouldn’t worry
about this detail.

-m

[…]

It’s a different error now, but some progress as it’s not related to
mysql.
I’m using this as my configure:

./configure --with-web-user=apache --with-web-group=apache
–enable-graphviz --enable-gd --with-db-type=Pg

I’m assuming that “Pg” means postgres. (configure --help doesn’t
actually specify postgres, just Pg)

then:

make testdeps
make fixdeps

Configuring DBD::Pg 3.5.1
Path to pg_config? /usr/pgsql-9.4/bin/pg_config

then I get this
SOME DEPENDENCIES WERE MISSING.
PG missing dependencies:
DBD::Pg >= 1.43 …MISSING

Is it looking for postgres in a special location?

No, as it says: it is failing to find the DBD::Pg perl module, version
1.43 or greater. Why it isn’t able to use the one that seems to have
been just configured (v3.5.1) is the key question. Perhaps something
about how you’re running fixdeps is installing that module in a place
that testdeps can’t find? Maybe you have SELinux enabled but the module
is being installed without a proper label?

You can see in the Makefile that testdeps and fixdeps both run
sbin/rt-test-dependencies, and all it does to check for dependencies to
to see if a “use” statement for each module fails.

I can only find one pg_config on my system:

/usr/pgsql-9.4/bin/pg_config

I got my postgres from here:

http://yum.postgresql.org/9.4/redhat/rhel-6-x86_64/pgdg-centos94-9.4-1.noarch.rpm

Is it possible I’m using the wrong version of Postgres (9.4.1) with
this version of RT (4.2.9)?

Very unlikely, and that certainly isn’t the cause of THIS error.

[…]

It’s a different error now, but some progress as it’s not related to
mysql.
I’m using this as my configure:

./configure --with-web-user=apache --with-web-group=apache
–enable-graphviz --enable-gd --with-db-type=Pg

I’m assuming that “Pg” means postgres. (configure --help doesn’t
actually specify postgres, just Pg)

then:

make testdeps
make fixdeps

Configuring DBD::Pg 3.5.1
Path to pg_config? /usr/pgsql-9.4/bin/pg_config

then I get this
SOME DEPENDENCIES WERE MISSING.
PG missing dependencies:
DBD::Pg >= 1.43 …MISSING

Is it looking for postgres in a special location?

No, as it says: it is failing to find the DBD::Pg perl module, version
1.43 or greater. Why it isn’t able to use the one that seems to have
been just configured (v3.5.1) is the key question. Perhaps something
about how you’re running fixdeps is installing that module in a place
that testdeps can’t find? Maybe you have SELinux enabled but the module
is being installed without a proper label?

You can see in the Makefile that testdeps and fixdeps both run
sbin/rt-test-dependencies, and all it does to check for dependencies to
to see if a “use” statement for each module fails.

If it¹s failing under the run of fixdeps - I¹ve had that error.

I did:

[root@rt4 rt-4.2.9]# cpanm DBD::Pg~1.43
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “iso_8859_1”,
LANG = "C"
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
–> Working on DBD::Pg
Fetching http://www.cpan.org/authors/id/T/TU/TURNSTEP/DBD-Pg-3.5.0.tar.gz
… OK
Configuring DBD-Pg-3.5.0 … N/A
! Configure failed for DBD-Pg-3.5.0. See
/root/.cpanm/work/1420992240.3990/build.log for details.
Expiring 91 work directories. This might take a while…

And in that build.log it said:
No POSTGRES_HOME defined, cannot find automatically
Configuring DBD::Pg 3.5.0
-> N/A
-> FAIL Configure failed for DBD-Pg-3.5.0. See
/root/.cpanm/work/1420992240.3990/build.log for details.
Expiring 91 work directories. This might take a while…

I solved it by installing the postgres-devel and postgres-contrib packages
and then manually installing DBD::Pg via cpanminus afterwards confirming
that the DBD::Pg perl package was properly installed and then running
fixdeps again.

also I put /usr/pgsql-9.3/bin in my path so it could find pg_config
properly - in your case that would be /usr/pgsql-9.4/bin

[root@rt4 ~]# which pg_config
/usr/bin/which: no pg_config in
(/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:
/usr/bin:/root/bin)
[root@rt4 ~]# locate pg_config

[root@rt4 bin]# PATH=$PATH:/usr/pgsql-9.3/bin/
[root@rt4 bin]# echo $PATH
/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/
usr/bin:/root/bin:/usr/pgsql-9.3/bin/
[root@rt4 bin]# which pg_config
/usr/pgsql-9.3/bin/pg_config
[root@rt4 bin]# cpanm DBD::Pg~1.43
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “iso_8859_1”,
LANG = "C"
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
–> Working on DBD::Pg
Fetching http://www.cpan.org/authors/id/T/TU/TURNSTEP/DBD-Pg-3.5.0.tar.gz
… OK
Configuring DBD-Pg-3.5.0 … OK
Building and testing DBD-Pg-3.5.0 … OK
Successfully installed DBD-Pg-3.5.0
1 distribution installed

Hope it helps

Best,
Sidsel

[…]

It’s a different error now, but some progress as it’s not related to
mysql.
I’m using this as my configure:

./configure --with-web-user=apache --with-web-group=apache
–enable-graphviz --enable-gd --with-db-type=Pg

I’m assuming that “Pg” means postgres. (configure --help doesn’t
actually specify postgres, just Pg)

then:

make testdeps
make fixdeps

Configuring DBD::Pg 3.5.1
Path to pg_config? /usr/pgsql-9.4/bin/pg_config

then I get this
SOME DEPENDENCIES WERE MISSING.
PG missing dependencies:
DBD::Pg >= 1.43 …MISSING

Is it looking for postgres in a special location?

No, as it says: it is failing to find the DBD::Pg perl module, version
1.43 or greater. Why it isn’t able to use the one that seems to have
been just configured (v3.5.1) is the key question. Perhaps something
about how you’re running fixdeps is installing that module in a place
that testdeps can’t find? Maybe you have SELinux enabled but the module
is being installed without a proper label?

You can see in the Makefile that testdeps and fixdeps both run
sbin/rt-test-dependencies, and all it does to check for dependencies to
to see if a “use” statement for each module fails.

If it�s failing under the run of fixdeps - I�ve had that error.

I did:

[root@rt4 rt-4.2.9]# cpanm DBD::Pg~1.43
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “iso_8859_1”,
LANG = "C"
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
–> Working on DBD::Pg
Fetching http://www.cpan.org/authors/id/T/TU/TURNSTEP/DBD-Pg-3.5.0.tar.gz
… OK
Configuring DBD-Pg-3.5.0 … N/A
! Configure failed for DBD-Pg-3.5.0. See
/root/.cpanm/work/1420992240.3990/build.log for details.
Expiring 91 work directories. This might take a while…

And in that build.log it said:
No POSTGRES_HOME defined, cannot find automatically
Configuring DBD::Pg 3.5.0
-> N/A
-> FAIL Configure failed for DBD-Pg-3.5.0. See
/root/.cpanm/work/1420992240.3990/build.log for details.
Expiring 91 work directories. This might take a while…

I solved it by installing the postgres-devel and postgres-contrib packages
and then manually installing DBD::Pg via cpanminus afterwards confirming
that the DBD::Pg perl package was properly installed and then running
fixdeps again.

also I put /usr/pgsql-9.3/bin in my path so it could find pg_config
properly - in your case that would be /usr/pgsql-9.4/bin

[root@rt4 ~]# which pg_config
/usr/bin/which: no pg_config in
(/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:
/usr/bin:/root/bin)
[root@rt4 ~]# locate pg_config

[root@rt4 bin]# PATH=$PATH:/usr/pgsql-9.3/bin/
[root@rt4 bin]# echo $PATH
/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/
usr/bin:/root/bin:/usr/pgsql-9.3/bin/
[root@rt4 bin]# which pg_config
/usr/pgsql-9.3/bin/pg_config
[root@rt4 bin]# cpanm DBD::Pg~1.43
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “iso_8859_1”,
LANG = "C"
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
–> Working on DBD::Pg
Fetching http://www.cpan.org/authors/id/T/TU/TURNSTEP/DBD-Pg-3.5.0.tar.gz
… OK
Configuring DBD-Pg-3.5.0 … OK
Building and testing DBD-Pg-3.5.0 … OK
Successfully installed DBD-Pg-3.5.0
1 distribution installed

Hope it helps

Best,
Sidsel

I can only find one pg_config on my system:

/usr/pgsql-9.4/bin/pg_config

I got my postgres from here:

http://yum.postgresql.org/9.4/redhat/rhel-6-x86_64/pgdg-centos94-9.4-1.no
arch.rpm

Is it possible I’m using the wrong version of Postgres (9.4.1) with
this version of RT (4.2.9)?

Very unlikely, and that certainly isn’t the cause of THIS error.

Thanks for all the tips, it allowed me to get it installed:

setenforce 0

[root@rtdev etc]# getenforce
Permissive

I installed
postgresql94-devel.x86_64

then ran

make testdeps
fix testdeps

“Congratulations. RT is now installed.” and it’s not even Friday yet.

Probably should set SELinux to Enforcing. Time for some additional tests.

Thank you,

Jonathan

[…]

It’s a different error now, but some progress as it’s not related to
mysql.
I’m using this as my configure:

./configure --with-web-user=apache --with-web-group=apache
–enable-graphviz --enable-gd --with-db-type=Pg

I’m assuming that “Pg” means postgres. (configure --help doesn’t
actually specify postgres, just Pg)

then:

make testdeps
make fixdeps

Configuring DBD::Pg 3.5.1
Path to pg_config? /usr/pgsql-9.4/bin/pg_config

then I get this
SOME DEPENDENCIES WERE MISSING.
PG missing dependencies:
DBD::Pg >= 1.43 …MISSING

Is it looking for postgres in a special location?

No, as it says: it is failing to find the DBD::Pg perl module, version
1.43 or greater. Why it isn’t able to use the one that seems to have
been just configured (v3.5.1) is the key question. Perhaps something
about how you’re running fixdeps is installing that module in a place
that testdeps can’t find? Maybe you have SELinux enabled but the module
is being installed without a proper label?

You can see in the Makefile that testdeps and fixdeps both run
sbin/rt-test-dependencies, and all it does to check for dependencies to
to see if a “use” statement for each module fails.

If it�s failing under the run of fixdeps - I�ve had that error.

I did:

[root@rt4 rt-4.2.9]# cpanm DBD::Pg~1.43
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “iso_8859_1”,
LANG = "C"
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
–> Working on DBD::Pg
Fetching http://www.cpan.org/authors/id/T/TU/TURNSTEP/DBD-Pg-3.5.0.tar.gz
… OK
Configuring DBD-Pg-3.5.0 … N/A
! Configure failed for DBD-Pg-3.5.0. See
/root/.cpanm/work/1420992240.3990/build.log for details.
Expiring 91 work directories. This might take a while…

And in that build.log it said:
No POSTGRES_HOME defined, cannot find automatically
Configuring DBD::Pg 3.5.0
-> N/A
-> FAIL Configure failed for DBD-Pg-3.5.0. See
/root/.cpanm/work/1420992240.3990/build.log for details.
Expiring 91 work directories. This might take a while…

I solved it by installing the postgres-devel and postgres-contrib packages
and then manually installing DBD::Pg via cpanminus afterwards confirming
that the DBD::Pg perl package was properly installed and then running
fixdeps again.

also I put /usr/pgsql-9.3/bin in my path so it could find pg_config
properly - in your case that would be /usr/pgsql-9.4/bin

[root@rt4 ~]# which pg_config
/usr/bin/which: no pg_config in
(/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:
/usr/bin:/root/bin)
[root@rt4 ~]# locate pg_config

[root@rt4 bin]# PATH=$PATH:/usr/pgsql-9.3/bin/
[root@rt4 bin]# echo $PATH
/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/
usr/bin:/root/bin:/usr/pgsql-9.3/bin/
[root@rt4 bin]# which pg_config
/usr/pgsql-9.3/bin/pg_config
[root@rt4 bin]# cpanm DBD::Pg~1.43
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “iso_8859_1”,
LANG = "C"
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
–> Working on DBD::Pg
Fetching http://www.cpan.org/authors/id/T/TU/TURNSTEP/DBD-Pg-3.5.0.tar.gz
… OK
Configuring DBD-Pg-3.5.0 … OK
Building and testing DBD-Pg-3.5.0 … OK
Successfully installed DBD-Pg-3.5.0
1 distribution installed

Hope it helps

Best,
Sidsel

I can only find one pg_config on my system:

/usr/pgsql-9.4/bin/pg_config

I got my postgres from here:

http://yum.postgresql.org/9.4/redhat/rhel-6-x86_64/pgdg-centos94-9.4-1.no
arch.rpm

Is it possible I’m using the wrong version of Postgres (9.4.1) with
this version of RT (4.2.9)?

Very unlikely, and that certainly isn’t the cause of THIS error.

Thanks for all the tips, it allowed me to get it installed:

setenforce 0

[root@rtdev etc]# getenforce
Permissive

I installed
postgresql94-devel.x86_64

then ran

make testdeps
fix testdeps

“Congratulations. RT is now installed.” and it’s not even Friday yet.

Probably should set SELinux to Enforcing. Time for some additional tests.

Thank you,

Jonathan

Actually, it was:

make testdeps
make fixdeps
make testdeps

make install