Dark theme modifications

RT 5.0.0 and dark theme - RT Users - Request Tracker Community Forum (bestpractical.com)

I added a summary of my issue with a previous post above that was a few months old. In the event that doesn’t get attention, I’ll repost here.

RT5 has this dreadful peach/pink background that is used in replies or comments to tickets and the contrast is terrible.

I’ve modified both the shared and local richtext contents-dark.css files with the following code:

/* main input color */
.cke_editable {
color: #ededed !important;
background-color: #020202;

Flushed mason cache with ‘rm -rf /opt/rt5/var/mason_data/obj/’
restarted apache with ‘systemctl restart httpd’

cleared web browser cache

regardless of any of these changes, the contrast issue remains. Ideas? Is there perhaps an environmental variable that is preventing these changes from working?

This is for dark theme right? You’re not trying to change the background color for the light theme as well?

Adding the local overlay of the contents-dark.css seems to work fine for me, adding black background to the reply page when I am using the dark theme

correct…using dark theme. I tried following the original solution which was to create the /local path directory and file layout. That didn’t meet with any success, so I tried directly modifying the /shared path file and still no change. Then I assumed I was perhaps missing a step, but followed the outline to a tee.

Hmm it seems to work fine for me, if you use your browsers dev tools can you confirm that the changes you made to the css file are loaded?

Doesn’t appear to reflect the changes. Again, not sure why. I’ve tried multiple browsers with cleared cache and cookies, gone over my mason flush command…nothing seems to work

Ah re-reading your post from the original thread, I am testing with GreenJims solution:

Not the solution mentioned by ALone ( not that there is anything wrong with that one ), is that the one that you are trying? Since that one seems to have different steps for FF vs Chrome and it looks like you’re using IE you most likely need to make some other change for IE that wasn’t mentioned.

I tried the steps outlined by ALone as well with no success.
I’ve at at this point tried with Edge (main browser), and Chrome.

Oddly enough tried Firefox and it worked which got me thinking about my other browsers and whether they were still retaining cached views. My calls to clear cached and cookies with both edge and chrome were not working so I had to reset the browsers completely…now the view is working as intended. Thx for the assist