CustomFieldGroupings defined in RT_SiteConfig.pm but not working

Hello,
I need to use groupings in Tickets-related CustomFields. By following the documentation, I have left unchanged the etc/RT_Config.pm and added the following lines to etc/RT_SiteConfig.pm:

Set(%CustomFieldGroupings,
‘RT::Ticket’ => [
‘Group1’ => [‘Sorgente’, ‘Destinazione’],
‘Group2’ => [‘Classe’, ‘Sottoclasse’],
‘Basics’ => [‘Operational CatT1’, ‘Operational CatT2’, ‘Operational CatT3’],
],
);

Of course the listed CustomFields (Sorgente, Destinazione, …) are defined and assigned to tickets.

I have then restarted the RT-web services, but when I click on Incident->Create I see no Group1 or Group2 groupings; also the Basics grouping does not show any of the listed CustomFields.
All the listed CustomFields are under the standard Custom Fields grouping; and no error is shown in the rt.log file.

Any idea?

Thanks in advance,
Michele

P.S. I am using RT 4.4.1

I’m not a perl programmer (more of use what works kinda guy), but shouldn’t that be a curly brace ‘{’ instead? Similarly, the closing bracket. At least it is in my instance of custom fields for assets.

Cheers,
Keith

Thanks Ginger,
I tried with the curly brace, but nothing has changed :frowning:

RTIR uses its own CustomFieldGroupings setting, so you want to replace ‘RT::Ticket’ with ‘RTIR::Ticket’.

See https://docs.bestpractical.com/rtir/4.0.0/RTIR_Config.html#Custom-Fields

1 Like

Great shawn :+1:
It worked with RTIR::Ticket!
Thank you very much!