Custom field Value <blah> cannot be found for custom field <foo>

I am running into a strange problem hopefully someone has seen or knows
how to fix.

I am getting this error:
"Custom field value <fairly long field which has at least 250
characters> could not be found for custom field "

The error I’m getting happens when attempting to edit a Custom Value
field which accepts multiple values. I am able to add/remove/delete
shorter values, but whenever I try to edit a longer one(250+ chars), RT
seems unable to find the value in the database to update or delete.

I poked around the database to see how things are being stored, and it
seems like the issue applies only to things stored in the 'LargeContent’
field of the ObjectCustomFieldValues table. What I’m guessing is
happening is that an attempt is being made to match the full text
content with what is stored in the database, and is simply not finding
it. The only way I can remove one of the values, is to set it manually
to disabled, and cannot do any editing of the value. Has anyone seen
this issue and have a solution or idea where to look?

I searched around previous threads and found one with a similar problem:
http://lists.bestpractical.com/pipermail/rt-devel/2005-June/007349.html
However no solutions seemed to come from it.

Running RT using innodb, fastcgi on a RHEL4 box.

Thanks in Advance,

Sean

At Wednesday 1/4/2006 02:12 PM, Sean Haselden wrote:

I am running into a strange problem hopefully someone has seen or knows
how to fix.

I am getting this error:
"Custom field value <fairly long field which has at least 250
characters> could not be found for custom field "

Sean,

What’s your RT version?

Steve

Sorry I forgot to put that… it’s 3.4.4

Stephen Turner wrote: