Critical bug with german letter'ß' (Intern)

Me too.

I posted a couple of times in October about this issue:
http://lists.fsck.com/pipermail/rt-users/2003-October/018019.html
http://lists.fsck.com/pipermail/rt-users/2003-October/018075.html

Norwegian characters Æ (HTML &ARIG;), Ø (Ø) and Å (Å) are
stored wrong.
Subject is always fine, except what I see stored in WebUI history.
3.0.7 seem to have made this “worse” (than 3.0.6).
ie: I add a comment “test æøå” (test &arig;øå), becomes:
3.0.6: test æøå
3.0.7: test �¦�¸�¥
(ekstra characters added)

I changed lib/RT/I18N.pm:
204c204
< Encode::from_to( $lines[$_], $charset => $enc ) for ( 0 … $#lines );

      Encode::from_to( $lines[$_], $enc => $charset ) for ( 0 .. $#lines );

I’m sure this isn’t the right thing to do, but with this it displays the characters correct.
Maybe this will give somone an idea of what could be wrong?

RT-3.0.7, FastCGI, Perl 5.8.0, Encode 1.98, Locale-Maketext 1.06.

Regards,
Ronny Pettersen-----Original Message-----
From: rt-users-bounces@lists.fsck.com
[mailto:rt-users-bounces@lists.fsck.com]On Behalf Of Hanno Mueller
Sent: 18. november 2003 13:24
To: rt-users@lists.fsck.com
Subject: [rt-users] Re: critical bug with german letter’ß’

Hi,

http://lists.fsck.com/pipermail/rt-users/2003-October/017631.html

I’m seing the same problem here: I can receive German Umlaut characters
by E-Mail, but I cannot store Umlaut characters in comments or replies
when I enter them via the web form. Any suggestions?

Thanks,

Hanno Müller

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Here’s one ticket that have this problem:
http://rt3.fsck.com/Ticket/Display.html?id=4365From: rt-users-bounces@lists.fsck.com
[mailto:rt-users-bounces@lists.fsck.com]On Behalf Of Pettersen Ronny
(Networks)
Sent: 18. november 2003 14:10
To: rt-users@lists.fsck.com
Subject: RE: [rt-users] Re: critical bug with german letter’ß’ (Intern)

Me too.

I posted a couple of times in October about this issue:
http://lists.fsck.com/pipermail/rt-users/2003-October/018019.html
http://lists.fsck.com/pipermail/rt-users/2003-October/018075.html

Norwegian characters Æ (HTML &ARIG;), Ø (&OSLASH;) and Å (&ARING;) are
stored wrong.
Subject is always fine, except what I see stored in WebUI history.
3.0.7 seem to have made this “worse” (than 3.0.6).
ie: I add a comment “test æøå” (test &arig;øå), becomes:
3.0.6: test æøå
3.0.7: test �¦�¸�¥
(ekstra characters added)

I changed lib/RT/I18N.pm:
204c204
< Encode::from_to( $lines[$_], $charset => $enc ) for ( 0 … $#lines );

      Encode::from_to( $lines[$_], $enc => $charset ) for ( 0 .. $#lines );

I’m sure this isn’t the right thing to do, but with this it displays the characters correct.
Maybe this will give somone an idea of what could be wrong?

RT-3.0.7, FastCGI, Perl 5.8.0, Encode 1.98, Locale-Maketext 1.06.

Regards,
Ronny Pettersen

We have the same problem with the swedish åäö ÅÄÖ.

-----Ursprungligt meddelande-----
Från: rt-users-bounces@lists.fsck.com
[mailto:rt-users-bounces@lists.fsck.com] För ronny.pettersen@telenor.com
Skickat: den 18 november 2003 15:54
Till: rt-users@lists.fsck.com
Ämne: [rt-users] Re: critical bug with german letter’ß’ (Intern)

Here’s one ticket that have this problem:
http://rt3.fsck.com/Ticket/Display.html?id=4365From: rt-users-bounces@lists.fsck.com
[mailto:rt-users-bounces@lists.fsck.com]On Behalf Of Pettersen Ronny
(Networks)
Sent: 18. november 2003 14:10
To: rt-users@lists.fsck.com
Subject: RE: [rt-users] Re: critical bug with german letter’ß’ (Intern)

Me too.

I posted a couple of times in October about this issue:
http://lists.fsck.com/pipermail/rt-users/2003-October/018019.html
http://lists.fsck.com/pipermail/rt-users/2003-October/018075.html

Norwegian characters Æ (HTML &ARIG;), Ø (&OSLASH;) and Å (&ARING;) are
stored wrong. Subject is always fine, except what I see stored in WebUI
history. 3.0.7 seem to have made this “worse” (than 3.0.6).
ie: I add a comment “test æøå” (test &arig;øå), becomes:
3.0.6: test æøå
3.0.7: test �¦�¸�¥
(ekstra characters added)

I changed lib/RT/I18N.pm:
204c204
< Encode::from_to( $lines[$_], $charset => $enc ) for ( 0 …
$#lines );

      Encode::from_to( $lines[$_], $enc => $charset ) for ( 0 .. 

$#lines );

I’m sure this isn’t the right thing to do, but with this it displays the
characters correct. Maybe this will give somone an idea of what could be
wrong?

RT-3.0.7, FastCGI, Perl 5.8.0, Encode 1.98, Locale-Maketext 1.06.

Regards,
Ronny Pettersen
rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

We have the same problem with the swedish ��� ���.

Here’s one ticket that have this problem:
http://rt3.fsck.com/Ticket/Display.html?id=4365

So. The reason rt3.fsck.com exhibits this bug is because it’s running on
perl 5.6.1. Perl 5.6.1 is non-supported for RT and known to break on
non-ascii characters. We haven’t been able to reproduce this problem
on perl 5.8.x. If you can do so, the way to get RT fixed is to extend
the test suite to show off the problem. If you can send us a patch for
the test suite that fails due to this bug, then we’ve got something to
work from to fix.

Best,
Jesse

Request Tracker — Best Practical Solutions – Trouble Ticketing. Free.

Jesse Vincent schrieb:

So. The reason rt3.fsck.com exhibits this bug is because it’s running on
perl 5.6.1. Perl 5.6.1 is non-supported for RT and known to break on
non-ascii characters. We haven’t been able to reproduce this problem
on perl 5.8.x.

I’m running Perl 5.8.2 with all the newest versions of the Perl modules
and have the problem here.

If you can do so, the way to get RT fixed is to extend
the test suite to show off the problem. If you can send us a patch for
the test suite that fails due to this bug, then we’ve got something to
work from to fix.

Oh well - how do I write a test for the test suite?

I’ll see what I can do about that. In the meantime, it’d be nice to know
your I18N configuration for Apache and for RT.

Thanks,

Hanno

Oh well - how do I write a test for the test suite?

If you can reproduce this bug by sending mail, clone one of the current
changes in lib/t/04_web.pl.in with your new message.

If it’s only via the web ui, have a look at the various tests in
lib/t/0?_web.pl.in. Add in logic to perform an update using
WWW::Mechanize and inspect the database and compare to your known-good
text.

I’ll see what I can do about that. In the meantime, it’d be nice to know
your I18N configuration for Apache and for RT.

Perl 5.8.0, with mod_perl1 or fastcgi. Apache 1.3.27. Mysql 4.0.9 or
4.0.16 or Postgres 7.3.3 or 7.3.4. RT 3.0.7

Thanks,

Hanno


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Request Tracker — Best Practical Solutions – Trouble Ticketing. Free.

Hi,

as described, the bug happens with the web gui.

I can send an email with Umlauts to a queue. Umlaut characters in that
message will be displayed correctly by the web gui.

If I try to write a comment or a reply to the same message using the web
gui, the Umlauts I enter there will be broken.

Jesse Vincent schrieb:

I’ll see what I can do about that. In the meantime, it’d be nice to know
your I18N configuration for Apache and for RT.

Perl 5.8.0, with mod_perl1 or fastcgi. Apache 1.3.27. Mysql 4.0.9 or
4.0.16 or Postgres 7.3.3 or 7.3.4. RT 3.0.7

But what are your I18N settings for Apache, RT and Mysql?

Btw, I’m running

RT 3.0.7_01
Apache 1.3.26 (with Debian backports)
Mysql 3.23.49 (with Debian backports)

I did not change the I18N settings of RT.

I tried Apache with “AddDefaultCharset on” and with “AddDefaultCharset
utf-8” - this didn’t fix the problem.

Thanks,

Hanno

Hi,

as described, the bug happens with the web gui.

If I try to write a comment or a reply to the same message using the web
gui, the Umlauts I enter there will be broken.

What browser? Does it happen with all browsers?

Jesse Vincent schrieb:

I’ll see what I can do about that. In the meantime, it’d be nice to know
your I18N configuration for Apache and for RT.

Perl 5.8.0, with mod_perl1 or fastcgi. Apache 1.3.27. Mysql 4.0.9 or
4.0.16 or Postgres 7.3.3 or 7.3.4. RT 3.0.7

But what are your I18N settings for Apache, RT and Mysql?

Unchanged from the defaults. No special config at all

Btw, I’m running
Mysql 3.23.49 (with Debian backports)

Oh. RT is very strictly not supported on Mysql 3.23. This is the first
thing I’d fix.

Request Tracker — Best Practical Solutions – Trouble Ticketing. Free.