Create tickets with multiline text field using the cli!

RT: 3.0.12

Hello!

I try to write an script to make an ticket, utilizing the rt
command line client:

The cli call is:

/usr/bin/rt create -t ticket set subject='test test test’
Requestor="you.know.me@site.org" queue=testq Text=“line1
line2
line3”

so the problem is how can i specify a multiline textfield
I think I tried everything (quoting,htmltags,singlequote)
but bad look nothing works!

regards!

I try to write an script to make an ticket, utilizing the rt
command line client:

The cli call is:

/usr/bin/rt create -t ticket set subject='test test test’
Requestor="you.know.me@site.org" queue=testq Text=“line1
line2
line3”

so the problem is how can i specify a multiline textfield
I think I tried everything (quoting,htmltags,singlequote)
but bad look nothing works!

Well, you neglect to say how it fails, but I would ask two questions:

  1. did you try backslashes?
  2. what happens if you pipe the text into rt as it’s stdin?

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

  If you can read this... thank a system administrator.  Or two.  --me

Hello!

I still don’t get any newline in my textfield usindg the cli.
As I posted before the normal stuff like using a “\n” or here-documents
or html-tags don’t show any effect.

Well, you neglect to say how it fails, but I would ask two questions:

So all special chars seems to be quoted, and also double “\” don’t
help.

I think the only way to do it is to modify the command line client, or
the the REST stuff on the server side. but I don’t have the time
to look in the code.

any help will appreciate!

regards

sven

I still don’t get any newline in my textfield usindg the cli.
As I posted before the normal stuff like using a “\n” or here-documents
or html-tags don’t show any effect.

Well, you neglect to say how it fails, but I would ask two questions:

So all special chars seems to be quoted, and also double “\” don’t
help.

I think the only way to do it is to modify the command line client, or
the the REST stuff on the server side. but I don’t have the time
to look in the code.

any help will appreciate!

You don’t appear to appreciate it too much: you quote me without
naming me, and you fail to answer the 2 questions which you do quote
me as asking.

Why don’t you try actually answering said questions, and we’ll see if
we can help you.

1/2 :slight_smile:

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

  If you can read this... thank a system administrator.  Or two.  --me

Hello!

Jay R. Ashworth wrote:

naming me, and you fail to answer the 2 questions which you do quote
me as asking.
sorry for forget to qoute in the right way.

but I answered the questions in the first mail :wink: In my my original
posting I wrote:

I think I tried everything (quoting,htmltags,singlequote)

so when I write quote I mean all quoting include
and \ and ‘’ and “” and stuff like � or just

(I think I wrote this in the second mail, too)

Why don’t you try actually answering said questions, and we’ll see if
we can help you.
ah yes, STDIN, that don’t work in the CLI there are fields where
you have to enter values like >> TEXT=“huhu” <<, and there is no "-"
mechanism.

regards!

but I answered the questions in the first mail :wink: In my my original
posting I wrote:

I think I tried everything (quoting,htmltags,singlequote)

so when I write quote I mean all quoting include
and \ and ‘’ and “” and stuff like � or just

(I think I wrote this in the second mail, too)

And yet, what you did not answer was…

Why don’t you try actually answering said questions, and we’ll see if
we can help you.
ah yes, STDIN, that don’t work in the CLI there are fields where
you have to enter values like >> TEXT=“huhu” <<, and there is no "-"
mechanism.

Is there no “-” mechanism?

[ checks online help ]

I think you might want to look at the -i option, before giving up.

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

  If you can read this... thank a system administrator.  Or two.  --me

Okay the cli don’t work. I have no more idea. I tried
the -i option but it don’t change anything. I tried base64 encoding.
I tried to add the line.

Sorry! but I think it is impossible to create a text field with more
then one line, when you create a ticket. I also looked at the source
of the client and the REST stuff but I don’t see the lines where
the stuff is actually parsed.

regards

sven

Jay R. Ashworth wrote:> On Mon, Apr 04, 2005 at 06:26:28PM +0200, Sven Sternberger wrote:

but I answered the questions in the first mail :wink: In my my original
posting I wrote:

I think I tried everything (quoting,htmltags,singlequote)

so when I write quote I mean all quoting include
and \ and ‘’ and “” and stuff like � or just

(I think I wrote this in the second mail, too)

And yet, what you did not answer was…

Why don’t you try actually answering said questions, and we’ll see if
we can help you.

ah yes, STDIN, that don’t work in the CLI there are fields where
you have to enter values like >> TEXT=“huhu” <<, and there is no "-"
mechanism.

Is there no “-” mechanism?

[ checks online help ]

I think you might want to look at the -i option, before giving up.

Cheers,
– jra