Create ticket slow

We’re running RT2 very hapilly on a dual PPro 200. Everything performs well
except creating tickets from the WebUI. That takes 30-45 seconds. I’ve
watched the cpu load on the server during the ticket creation process, and
it just seems to sit there. Is there anything in particular that I should
look at to see what’s going on? We seem to have plenty of free ram and
we’re not even touching the swap partition.

Any suggestions welcome.

Thanks,
David

David Fletcher
Micro-Prince Computers
(904)721-0867
(904)721-1253 fax
http://www.micro-prince.com (business)
http://www.mahonri.org (personal)

How much ram do you have?
Which database is RT talking to?
Are you using mod_perl or fastcgi?
What OS are you running on?
CPU seems to sit there high or low?

-jOn Thu, Dec 13, 2001 at 03:35:21PM -0500, David Fletcher wrote:

We’re running RT2 very hapilly on a dual PPro 200. Everything performs well
except creating tickets from the WebUI. That takes 30-45 seconds. I’ve
watched the cpu load on the server during the ticket creation process, and
it just seems to sit there. Is there anything in particular that I should
look at to see what’s going on? We seem to have plenty of free ram and
we’re not even touching the swap partition.

Any suggestions welcome.

Thanks,
David


David Fletcher
Micro-Prince Computers
(904)721-0867
(904)721-1253 fax
http://www.micro-prince.com (business)
http://www.mahonri.org (personal)



rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

How much ram do you have?
384 MB
(Just upgraded from 128MB with no appreciable difference. Currently free
ram is running at about 250MB.)

Which database is RT talking to?
MySQL

Are you using mod_perl or fastcgi?
mod_perl

What OS are you running on?
Debian Linux

CPU seems to sit there high or low?
CPU bumps up to about 20-30% usage (mostly Apache) for one or two seconds,
then settles back down to almost nothing for 25-30 seconds (97-99% idle)
then apache bumps it back up to about 20% as it feeds the results to the
browser.

More info: This seems to be queue specific. The queue we’re talking about
currently has about 225 tickets. A new queue with only 3 or 4 tickets
allows ticket creation in 3 seconds. (Our highest ticket # is 433)

-j

We’re running RT2 very hapilly on a dual PPro 200. Everything performs
well

except creating tickets from the WebUI. That takes 30-45 seconds. I’ve
watched the cpu load on the server during the ticket creation process,
and

it just seems to sit there. Is there anything in particular that I
should

Next question. what MTA are you using? What are your MTA options
set in the RT config file?On Fri, Dec 14, 2001 at 09:38:04AM -0500, David Fletcher wrote:

----- Original Message -----
From: “Jesse Vincent” jesse@bestpractical.com

How much ram do you have?
384 MB
(Just upgraded from 128MB with no appreciable difference. Currently free
ram is running at about 250MB.)

Which database is RT talking to?
MySQL

Are you using mod_perl or fastcgi?
mod_perl

What OS are you running on?
Debian Linux

CPU seems to sit there high or low?
CPU bumps up to about 20-30% usage (mostly Apache) for one or two seconds,
then settles back down to almost nothing for 25-30 seconds (97-99% idle)
then apache bumps it back up to about 20% as it feeds the results to the
browser.

More info: This seems to be queue specific. The queue we’re talking about
currently has about 225 tickets. A new queue with only 3 or 4 tickets
allows ticket creation in 3 seconds. (Our highest ticket # is 433)

-j
On Thu, Dec 13, 2001 at 03:35:21PM -0500, David Fletcher wrote:

We’re running RT2 very hapilly on a dual PPro 200. Everything performs
well

except creating tickets from the WebUI. That takes 30-45 seconds. I’ve
watched the cpu load on the server during the ticket creation process,
and

it just seems to sit there. Is there anything in particular that I
should

look at to see what’s going on? We seem to have plenty of free ram and
we’re not even touching the swap partition.

Any suggestions welcome.

Thanks,
David


David Fletcher
Micro-Prince Computers
(904)721-0867
(904)721-1253 fax
http://www.micro-prince.com (business)
http://www.mahonri.org (personal)


http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

Next question. what MTA are you using? What are your MTA options
set in the RT config file?

Exim.

{{{ Outgoing mail configuration

#$MailAlias is a generic alias to send mail to for any request
#already in a queue.

#RT is designed such that any mail which already has a ticket-id associated
#with it will get to the right place automatically.

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden
#by a queue specific address

$CorrespondAddress=‘RT::CorrespondAddress.not.set’;

$CommentAddress=‘RT::CommentAddress.not.set’;

#Sendmail Configuration

$MailCommand defines which method RT will use to try to send mail

We know that ‘sendmail’ works fairly well.

If ‘sendmail’ doesn’t work well for you, try ‘sendmailpipe’

But note that you have to configure $SendmailPath and add a -t

to $SendmailArguments

$MailCommand = ‘sendmail’;

$SendmailArguments defines what flags to pass to $Sendmail

assuming you picked ‘sendmail’ or ‘sendmailpipe’ as the $MailCommand

above.

If you picked ‘sendmailpipe’, you MUST add a -t flag to $SendmailArguments

These options are good for most sendmail wrappers and workalikes

$SendmailArguments="-oi";

These arguments are good for sendmail brand sendmail 8 and newer

#$SendmailArguments="-oi -ODeliveryMode=b -OErrorMode=m";

If you selected ‘sendmailpipe’ above, you MUST specify the path

to your sendmail binary in $SendmailPath.

!! If you did not # select ‘sendmailpipe’ above, this has no effect!!

$SendmailPath = “/usr/sbin/sendmail”;

RT can optionally set a “Friendly” ‘To:’ header when sending messages to

Ccs or AdminCcs (rather than having a blank ‘To:’ header.

This feature DOES NOT WORK WITH SENDMAIL[tm] BRAND SENDMAIL

If you are using sendmail, rather than postfix, qmail, exim or some other

MTA,

you must disable this option.

$UseFriendlyToLine = 1;

----- Original Message -----
From: “Jesse Vincent” jesse@bestpractical.com

How much ram do you have?
384 MB
(Just upgraded from 128MB with no appreciable difference. Currently
free

ram is running at about 250MB.)

Which database is RT talking to?
MySQL

Are you using mod_perl or fastcgi?
mod_perl

What OS are you running on?
Debian Linux

CPU seems to sit there high or low?
CPU bumps up to about 20-30% usage (mostly Apache) for one or two
seconds,

then settles back down to almost nothing for 25-30 seconds (97-99% idle)
then apache bumps it back up to about 20% as it feeds the results to the
browser.

More info: This seems to be queue specific. The queue we’re talking
about

$CorrespondAddress=‘RT::CorrespondAddress.not.set’;

$CommentAddress=‘RT::CommentAddress.not.set’;

Would these not being your correspondence and comment addresses be your

problem?

Jay
(you need to set those to whatever you use as your email addresses, such as
rt@mydomain.com and rt-comment@mydomain.com, instead of RT::blahblah…)

The comment in the config file says that that only takes effect if this is
not set for a particular queue. If changing it will fix the problem, I’ll
be happy to give it a shot.From: “Jay Kramer” jay@mojomole.com
To: “David Fletcher” david@micro-prince.com; rt-users@lists.fsck.com
Sent: Friday, December 14, 2001 11:41 AM
Subject: Re: [rt-users] Create ticket slow

$CorrespondAddress=‘RT::CorrespondAddress.not.set’;

$CommentAddress=‘RT::CommentAddress.not.set’;

Would these not being your correspondence and comment addresses be

your

problem?

Jay
(you need to set those to whatever you use as your email addresses, such
as
rt@mydomain.com and rt-comment@mydomain.com, instead of RT::blahblah…)

Its just a shot… I’ve “never” left it at the default, better to be safe
than sorry :wink: hehe

Jay
(ps, if it doesn’t fix it, heh)