Couldn't get SMIME keys information - please help

I am asking for your support in starting the encryption of messages.
My RT version: 5.0.5

use utf8;
Set($rtname, ‘rt.mydomain_com’);
Set($Organization, ‘rt.mydomain_com’);
Set($WebDomain, ‘rt.mydomain_com’);
Set($WebPort, ‘443’);

Set($DatabaseUser, ‘rt_user’);
Set($DatabasePassword, ‘password’);
Set($DatabaseHost, ‘localhost’);
Set($DatabasePort, undef);
Set($DatabaseName, ‘rt5’);
Set($DatabaseAdmin, ‘rt_admin’);
Set($LogToSyslog, ‘warning’);
Set($LogToSTDERR, ‘warning’);

Set( $LogToFile, ‘debug’);
Set( $LogToFileNamed, ‘’);
Set( $LogDir, ‘/var/log/rt5’);
Set( $RTAddressRegexp, ‘’);
Set( @ReferrerWhitelist, qw(rt.mydomain_com:443));
Set( $SendmailPath, ‘/opt/rt5/etc/msmtp_wrapper’ );

Set( %SMIME,
Enable => 1,
OpenSSL => ‘/bin/openssl’,
Keyring => ‘/opt/rt5/var/data/smime’,
CAPath => ‘/opt/rt5/var/data/smime/signing-ca.pem’,
Passphrase => {
‘’ => {
Encryption => ‘’,
Signing => ‘’,
‘’ => ‘fallback’,
CheckCRL => 0,
CheckOCSP => 0,
CheckRevocationDownloadTimeout => 30,

Private and public key rights:

]# ll /opt/rt5/var/data/smime
total 8
-rw------- 1 apache apache 1675 Dec 11 11:45
-rw------- 1 apache apache 2232 Dec 11 11:44 signing-ca.pem

When I create a queue, he can’t see my key

If I want to write back to the ticket and select the encryption options, he gets such a message:
You are going to encrypt outgoing email messages, but there is a problem with a recipient’s public key/certificate. You have to fix the problem with the key/certificate, disable sending a message to that recipient, or disable encryption.

  • User [<[>]) has a problem. There is no key suitable for encryption.
    Select a key/certificate you want to use for encryption: No usable keys.

I solved the problem: The correct CA certificate was missing. The rest of the configuration was correct