Could not load valid user

Hi

I granted globally to ‘Everyone’ the right ‘ReplyToTicket’ but I still
get this message:

RT could not load a valid user, and RT’s configuration does not allow
for the creation of a new user for this email (example@example.com).

You might need to grant ‘Everyone’ the right ‘ReplyToTicket’ for the
queue Example.

Regards

Monzoon Networks AG
Ruben Lehmann
Network Engineer

Riedthofstrasse 124, CH-8105 Regensdorf
tel: +41 43 500 04 76 mobile: +41 78 656 47 72

Nomadic Workers - hotspot.monzoon.net
Wireless Internet - home.monzoon.net
Surf the safer way - www.swissvpn.net

Hi

I granted globally to ‘Everyone’ the right ‘ReplyToTicket’ but I still
get this message:


RT could not load a valid user, and RT’s configuration does not allow
for the creation of a new user for this email (example@example.com).

You might need to grant ‘Everyone’ the right ‘ReplyToTicket’ for the
queue Example.

Regards

Monzoon Networks AG
Ruben Lehmann
Network Engineer

Riedthofstrasse 124, CH-8105 Regensdorf
tel: +41 43 500 04 76 mobile: +41 78 656 47 72

Try adding ‘Everyone’ the right ‘Create Ticket’ as well.

Yogesh

IT Guy,

Maybe someone already mentioned this, but it sounds like you have 

conflicting configurations between looking for someone in the user DB
and adding someone who isn’t there. Hope this helps.

Kenn
LBNLOn 6/4/2008 9:46 AM, IT GUY wrote:

On Mon, Jun 2, 2008 at 1:10 PM, Ruben Lehmann <rlehmann@monzoon.net mailto:rlehmann@monzoon.net> wrote:

Hi

I granted globally to 'Everyone' the right 'ReplyToTicket' but I still
get this message:

-----------
RT could not load a valid user, and RT's configuration does not allow
for the creation of a new user for this email (example@example.com
<mailto:example@example.com>).

You might need to grant 'Everyone' the right 'ReplyToTicket' for the
queue Example.
-----------

Regards


Monzoon Networks AG
Ruben Lehmann
Network Engineer

Riedthofstrasse 124, CH-8105 Regensdorf
tel: +41 43 500 04 76 mobile: +41 78 656 47 72

Try adding ‘Everyone’ the right ‘Create Ticket’ as well.

Yogesh

----------------------------------------------------------
Nomadic Workers - hotspot.monzoon.net <http://hotspot.monzoon.net/>
Wireless Internet - home.monzoon.net <http://home.monzoon.net/>
Surf the safer way - www.swissvpn.net <http://www.swissvpn.net/>
----------------------------------------------------------

_______________________________________________
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
<http://wiki.bestpractical.com/>
Commercial support: sales@bestpractical.com
<mailto:sales@bestpractical.com>


Discover RT's hidden secrets with RT Essentials from O'Reilly Media.
Buy a copy at http://rtbook.bestpractical.com
<http://rtbook.bestpractical.com/>


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Greetings everyone,

I’ve been strugging with this weeoe for a few days and frankly I am stumped.
Here is the situation. I need to users who are not in the RT users table to
have the ability to reply to a ticket via email. I’ve gone though the mail
list and tried several of the suggestions I found there but none have solved
my isssue.

This is internal auth only no external auth in place.

I’ve tried granting ‘everyone’ the ‘ReplyToTicket’ right and it fails.

Config options I have enabled
Set($WebFallbackToInternalAuth, 1);
Set($WebExternalAuto, 1);
Set($AutoCreateNonExternalUsers, 1);
Set($AutoCreate, Privileged => 0);

System Info
OS: RHEL 4
DB: MySql
RT ver: 3.8.2 (I know the version is old, but I am stuck with it for now)
Perl: 5.10.0

Any pointers would be wonderful

Thanks
Eric

signature.asc (490 Bytes)

Greetings everyone,

I’ve been strugging with this weeoe for a few days and frankly I am stumped.
Here is the situation. I need to users who are not in the RT users table to
have the ability to reply to a ticket via email. I’ve gone though the mail
list and tried several of the suggestions I found there but none have solved
my isssue.

Please post a complete log message

This is internal auth only no external auth in place.

I’ve tried granting ‘everyone’ the ‘ReplyToTicket’ right and it fails.

Config options I have enabled
Set($WebFallbackToInternalAuth, 1);
Set($WebExternalAuto, 1);

These two only apply to external auth, if you’re not using it, they
won’t affect the system

Set($AutoCreateNonExternalUsers, 1);

This only applies to RT-Authen-ExternalAuth and is unused in a vanilla RT

Set($AutoCreate, Privileged => 0);

This syntax is invalid, fixing it might help

-kevin

Kevin,
I fixed the syntax of that entry.
It is still failing

Here is the revelent log section

[Thu Jun 9 17:41:44 2011] [crit]: HasRight called with no valid object
(/opt/rt3/bin/…/lib/RT/Principal_Overlay.pm:322)
[Thu Jun 9 17:41:44 2011] [crit]: HasRight called with no valid object
(/opt/rt3/bin/…/lib/RT/Principal_Overlay.pm:322)
[Thu Jun 9 17:41:44 2011] [error]: RT could not load a valid user, and RT’s
configuration does not allow
for the creation of a new user for this email
(xxxx.x.xxxxxxx@xxxxxxxxxxxxx.xxx).

You might need to grant ‘Everyone’ the right ‘ReplyToTicket’ for the
queue Scrip. (/opt/rt3/bin/…/lib/RT/Interface/Email.pm:244)
[Thu Jun 9 17:41:49 2011] [crit]: : Could not send mail.
(/opt/rt3/bin/…/lib/RT/Interface/Email.pm:478)
[Thu Jun 9 17:41:49 2011] [error]: Could not record email: Could not load a
valid user (/opt/rt3/share/html/REST/1.0/NoAuth/mail-gateway:75)On Thursday, June 09, 2011 12:51:57 PM Kevin Falcone wrote:

On Thu, Jun 09, 2011 at 12:44:35PM -0400, Eric Stoycon wrote:

Greetings everyone,

I’ve been strugging with this weeoe for a few days and frankly I am
stumped. Here is the situation. I need to users who are not in the RT
users table to have the ability to reply to a ticket via email. I’ve
gone though the mail list and tried several of the suggestions I found
there but none have solved my isssue.

Please post a complete log message

This is internal auth only no external auth in place.

I’ve tried granting ‘everyone’ the ‘ReplyToTicket’ right and it fails.

Config options I have enabled

Set($WebFallbackToInternalAuth, 1);
Set($WebExternalAuto, 1);

These two only apply to external auth, if you’re not using it, they
won’t affect the system

Set($AutoCreateNonExternalUsers, 1);

This only applies to RT-Authen-ExternalAuth and is unused in a vanilla RT

Set($AutoCreate, Privileged => 0);

This syntax is invalid, fixing it might help

-kevin

System Info

OS: 	RHEL 4
DB: 	MySql
RT ver:	3.8.2 (I know the version is old, but I am stuck with it for
now) Perl:	5.10.0

Any pointers would be wonderful

Thanks
Eric

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQEcBAABAgAGBQJN8PhzAAoJEPxXSAAVYnY8XRwH/349Kr79jJyc4yS4j6nnih05
w4+Nli7c9DdUZnUMczwANzRRiR6+Nud1XsJ7zSKvlDwDnV3vHPYkgNLmzpmOiKvY
va0C9DPfpayLBRd3UIfBElIOGBy9p+tc7+6ltPxdzByOy3o6xtt3FY8A9T2h1r92
UKyRgKCwuTcaEiri8uiQgzV8SsIilmg6z4MNOQkkgGDtdVxq8l+cNGEyoAUqMqyV
sUQwOOr/+DEl5bSzp3K/BsNMHSY0TAaNb7nAMbjVrMXxx0zF7egzuMDIAQLo5/Av
WhqQj4z2mq+znu0uBYpK599ZVzlDNcupAnMUyOMCmgKM3JJnNFucWwJxiklwmB8=
=TogE
-----END PGP SIGNATURE-----

Eric,

This is what we do and it works:

Set($SenderMustExistInExternalDatabase, 1);

Set($ValidateUserEmailAddresses, 1);

Set($AutoCreate, [Privileged , 0]);
and for our LDAP confiuration:

*Set($AutoCreateNonExternalUsers, 1);

Now, for all this to work, you have to make sure that you aren’t granting a
"world of rights" to the “Unprivileged”. We’re very conservative about the
control we grant to our users and ALWAYS use Groups. We do NOT grant *
ANY
privileges to individual users. That way, only the “Privileged” get
any real rights because they have to be in a group and only "Privileged"
users can be in a group.

Hope this helps.

Kenn
LBNLOn Thu, Jun 9, 2011 at 10:48 AM, Eric Stoycon estoycon@gmail.com wrote:

Kevin,
I fixed the syntax of that entry.
It is still failing

Here is the revelent log section

[Thu Jun 9 17:41:44 2011] [crit]: HasRight called with no valid object
(/opt/rt3/bin/…/lib/RT/Principal_Overlay.pm:322)
[Thu Jun 9 17:41:44 2011] [crit]: HasRight called with no valid object
(/opt/rt3/bin/…/lib/RT/Principal_Overlay.pm:322)
[Thu Jun 9 17:41:44 2011] [error]: RT could not load a valid user, and
RT’s
configuration does not allow
for the creation of a new user for this email
(xxxx.x.xxxxxxx@xxxxxxxxxxxxx.xxx).

You might need to grant ‘Everyone’ the right ‘ReplyToTicket’ for the
queue Scrip. (/opt/rt3/bin/…/lib/RT/Interface/Email.pm:244)
[Thu Jun 9 17:41:49 2011] [crit]: : Could not send mail.
(/opt/rt3/bin/…/lib/RT/Interface/Email.pm:478)
[Thu Jun 9 17:41:49 2011] [error]: Could not record email: Could not load
a
valid user (/opt/rt3/share/html/REST/1.0/NoAuth/mail-gateway:75)

On Thursday, June 09, 2011 12:51:57 PM Kevin Falcone wrote:

On Thu, Jun 09, 2011 at 12:44:35PM -0400, Eric Stoycon wrote:

Greetings everyone,

I’ve been strugging with this weeoe for a few days and frankly I am
stumped. Here is the situation. I need to users who are not in the RT
users table to have the ability to reply to a ticket via email. I’ve
gone though the mail list and tried several of the suggestions I found
there but none have solved my isssue.

Please post a complete log message

This is internal auth only no external auth in place.

I’ve tried granting ‘everyone’ the ‘ReplyToTicket’ right and it fails.

Config options I have enabled

Set($WebFallbackToInternalAuth, 1);
Set($WebExternalAuto, 1);

These two only apply to external auth, if you’re not using it, they
won’t affect the system

Set($AutoCreateNonExternalUsers, 1);

This only applies to RT-Authen-ExternalAuth and is unused in a vanilla RT

Set($AutoCreate, Privileged => 0);

This syntax is invalid, fixing it might help

-kevin

System Info

OS:     RHEL 4
DB:     MySql
RT ver: 3.8.2 (I know the version is old, but I am stuck with it

for

now) Perl:      5.10.0

Any pointers would be wonderful

Thanks
Eric

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQEcBAABAgAGBQJN8PhzAAoJEPxXSAAVYnY8XRwH/349Kr79jJyc4yS4j6nnih05
w4+Nli7c9DdUZnUMczwANzRRiR6+Nud1XsJ7zSKvlDwDnV3vHPYkgNLmzpmOiKvY
va0C9DPfpayLBRd3UIfBElIOGBy9p+tc7+6ltPxdzByOy3o6xtt3FY8A9T2h1r92
UKyRgKCwuTcaEiri8uiQgzV8SsIilmg6z4MNOQkkgGDtdVxq8l+cNGEyoAUqMqyV
sUQwOOr/+DEl5bSzp3K/BsNMHSY0TAaNb7nAMbjVrMXxx0zF7egzuMDIAQLo5/Av
WhqQj4z2mq+znu0uBYpK599ZVzlDNcupAnMUyOMCmgKM3JJnNFucWwJxiklwmB8=
=TogE
-----END PGP SIGNATURE-----

Set($SenderMustExistInExternalDatabase, 1);

This config options doesn’t exist in the 3.8 codebase.

Set($ValidateUserEmailAddresses, 1);

Set($AutoCreate, [Privileged , 0]);

I think you’re getting lucky there, that’s supposed to be a hashref
not an arrayref

and for our LDAP confiuration:

Set($AutoCreateNonExternalUsers, 1);

That’s specific to RT::Authen::ExternalAuth

-kevin

[Thu Jun 9 17:41:44 2011] [crit]: HasRight called with no valid object
(/opt/rt3/bin/…/lib/RT/Principal_Overlay.pm:322)
[Thu Jun 9 17:41:44 2011] [crit]: HasRight called with no valid object
(/opt/rt3/bin/…/lib/RT/Principal_Overlay.pm:322)
[Thu Jun 9 17:41:44 2011] [error]: RT could not load a valid user, and RT’s
configuration does not allow
for the creation of a new user for this email
(xxxx.x.xxxxxxx@xxxxxxxxxxxxx.xxx).

You might need to grant ‘Everyone’ the right ‘ReplyToTicket’ for the
queue Scrip. (/opt/rt3/bin/…/lib/RT/Interface/Email.pm:244)

This line

[Thu Jun 9 17:41:49 2011] [crit]: : Could not send mail.
(/opt/rt3/bin/…/lib/RT/Interface/Email.pm:478)

is actually indicative of a bad misconfiguration in your
RT_SiteConfig.pm that you should look into around SendmailPath

Once you get that cleared up, turning on LogStackTrace to ‘error’ will
tell you a lot more about what is causing your crits and errors.
Turning on debug logging may help also.

-kevin

Kevin,

Yep. Wrong syntax. Now that I look at it, I don’t really need to set it at
all because I believe RT defaults to “UnPrivileged” when adding a new user
automatically.

Kenn
LBNLOn Thu, Jun 9, 2011 at 12:15 PM, Kevin Falcone falcone@bestpractical.comwrote:

On Thu, Jun 09, 2011 at 12:01:42PM -0700, Kenneth Crocker wrote:

Set($SenderMustExistInExternalDatabase, 1);

This config options doesn’t exist in the 3.8 codebase.

Set($ValidateUserEmailAddresses, 1);

Set($AutoCreate, [Privileged , 0]);

I think you’re getting lucky there, that’s supposed to be a hashref
not an arrayref

and for our LDAP confiuration:

Set($AutoCreateNonExternalUsers, 1);

That’s specific to RT::Authen::ExternalAuth

-kevin

Now, for all this to work, you have to make sure that you aren’t
granting a “world of rights"
to the “Unprivileged”. We’re very conservative about the control we
grant to our users and
ALWAYS use Groups. We do NOT grant ANY privileges to individual users.
That way, only the
"Privileged” get any real rights because they have to be in a group
and only "Privileged"
users can be in a group.

Hope this helps.

Kenn
LBNL

On Thu, Jun 9, 2011 at 10:48 AM, Eric Stoycon <[1]estoycon@gmail.com> wrote:

 Kevin,
 I fixed the syntax of that entry.
 It is still failing

 Here is the revelent log section

 [Thu Jun 9 17:41:44 2011] [crit]: HasRight called with no valid

object

 (/opt/rt3/bin/../lib/RT/Principal_Overlay.pm:322)
 [Thu Jun 9 17:41:44 2011] [crit]: HasRight called with no valid

object

 (/opt/rt3/bin/../lib/RT/Principal_Overlay.pm:322)
 [Thu Jun 9 17:41:44 2011] [error]: RT could not load a valid user,

and RT’s

 configuration does not allow
 for the creation of a new user for this email
 (xxxx.x.xxxxxxx@xxxxxxxxxxxxx.xxx).

 You might need to grant 'Everyone' the right 'ReplyToTicket' for the
 queue Scrip. (/opt/rt3/bin/../lib/RT/Interface/Email.pm:244)
 [Thu Jun 9 17:41:49 2011] [crit]: : Could not send mail.
 (/opt/rt3/bin/../lib/RT/Interface/Email.pm:478)
 [Thu Jun 9 17:41:49 2011] [error]: Could not record email: Could not

load a

 valid user (/opt/rt3/share/html/REST/1.0/NoAuth/mail-gateway:75)
 On Thursday, June 09, 2011 12:51:57 PM Kevin Falcone wrote:
 > On Thu, Jun 09, 2011 at 12:44:35PM -0400, Eric Stoycon wrote:
 > > Greetings everyone,
 > >
 > >
 > > I've been strugging with this weeoe for a few days and frankly I

am

 > > stumped. Here is the situation. I need to users who are not in

the RT

 > > users table to have the ability to reply to a ticket via email.

I’ve

 > > gone though the mail list and tried several of the suggestions I

found

 > > there but none have solved my isssue.
 >
 > Please post a complete log message
 >
 > > This is internal auth only no external auth in place.
 > >
 > > I've tried granting 'everyone' the 'ReplyToTicket' right and it

fails.

 > >
 > > Config options I have enabled
 > >
 > > Set($WebFallbackToInternalAuth, 1);
 > > Set($WebExternalAuto, 1);
 >
 > These two only apply to external auth, if you're not using it,

they

 > won't affect the system
 >
 > > Set($AutoCreateNonExternalUsers, 1);
 >
 > This only applies to RT-Authen-ExternalAuth and is unused in a

vanilla RT

 >
 > > Set($AutoCreate, Privileged => 0);
 >
 > This syntax is invalid, fixing it might help
 >
 > -kevin
 >
 > > System Info
 > >
 > > OS: RHEL 4
 > > DB: MySql
 > > RT ver: 3.8.2 (I know the version is old, but I am stuck with it

for

 > > now) Perl: 5.10.0
 > >
 > > Any pointers would be wonderful
 > >
 > > Thanks
 > > Eric
 > >
 > > -----BEGIN PGP SIGNATURE-----
 > > Version: GnuPG v1.4.11 (GNU/Linux)
 > >
 > > iQEcBAABAgAGBQJN8PhzAAoJEPxXSAAVYnY8XRwH/349Kr79jJyc4yS4j6nnih05
 > > w4+Nli7c9DdUZnUMczwANzRRiR6+Nud1XsJ7zSKvlDwDnV3vHPYkgNLmzpmOiKvY
 > > va0C9DPfpayLBRd3UIfBElIOGBy9p+tc7+6ltPxdzByOy3o6xtt3FY8A9T2h1r92
 > > UKyRgKCwuTcaEiri8uiQgzV8SsIilmg6z4MNOQkkgGDtdVxq8l+cNGEyoAUqMqyV
 > > sUQwOOr/+DEl5bSzp3K/BsNMHSY0TAaNb7nAMbjVrMXxx0zF7egzuMDIAQLo5/Av
 > > WhqQj4z2mq+znu0uBYpK599ZVzlDNcupAnMUyOMCmgKM3JJnNFucWwJxiklwmB8=
 > > =TogE
 > > -----END PGP SIGNATURE-----

References

Visible links

  1. mailto:estoycon@gmail.com