CORE dependencies missing for RT 5

I’m trying to setup RT 5.0.0 on Ubuntu Linux for evaluation.
I have installed
MySQL Ver 8.0.22 for Linux
Perl v5.30.3

Now I’m getting the below results when I run make testdeps

SOME DEPENDENCIES WERE MISSING:

CORE dependencies:
CGI >= 4.00 … MISSING
CGI::Cookie >= 1.20 … MISSING
CGI::Emulate::PSGI … MISSING
CGI::PSGI >= 0.12 … MISSING
CSS::Minifier::XS … MISSING
Clone … MISSING
Crypt::Eksblowfish … MISSING
DBI >= 1.37 … MISSING
DBIx::SearchBuilder >= 1.68 … MISSING
Data::GUID … MISSING
Date::Extract >= 0.02 … MISSING
DateTime >= 0.44 … MISSING
DateTime::Format::Natural >= 0.67 … MISSING
DateTime::Locale >= 0.40, != 1.00, != 1.01 … MISSING
Encode::Detect::Detector … MISSING
Encode::HanExtra … MISSING
File::ShareDir … MISSING
HTML::Entities … MISSING
HTML::FormatText::WithLinks >= 0.14 … MISSING
HTML::FormatText::WithLinks::AndTables >= 0.06 … MISSING
HTML::Gumbo … MISSING
HTML::Mason >= 1.43 … MISSING
HTML::Mason::PSGIHandler >= 0.52 … MISSING
HTML::Quoted … MISSING
HTML::RewriteAttributes >= 0.05 … MISSING
HTML::Scrubber >= 0.08 … MISSING
JavaScript::Minifier::XS … MISSING
LWP >= 6.02 … MISSING
LWP::Protocol::https … MISSING
LWP::Simple … MISSING
LWP::UserAgent >= 6.02 … MISSING
List::MoreUtils … MISSING
Locale::Maketext::Lexicon >= 0.32 … MISSING
Log::Dispatch >= 2.30 … MISSING
Moose … MISSING
MooseX::NonMoose … MISSING
MooseX::Role::Parameterized … MISSING
Plack >= 1.0002 … MISSING
Plack::Handler::Starlet … MISSING
Scope::Upper … MISSING
Sub::Exporter … MISSING
Term::ReadKey … MISSING
Web::Machine >= 0.12 … MISSING
XML::RSS >= 1.05 … MISSING
namespace::autoclean … MISSING

GPG dependencies:
GnuPG::Interface >= 1.00 … MISSING
PerlIO::eol … MISSING

GRAPHVIZ dependencies:
GraphViz … MISSING

SQLITE dependencies:
DBD::SQLite >= 1.00 … MISSING

Perl library path for /usr/bin/perl:
/etc/perl
/usr/local/lib/x86_64-linux-gnu/perl/5.30.3
/usr/local/share/perl/5.30.3
/usr/lib/x86_64-linux-gnu/perl5/5.30
/usr/share/perl5
/usr/lib/x86_64-linux-gnu/perl-base
/usr/lib/x86_64-linux-gnu/perl/5.30
/usr/share/perl/5.30
/usr/local/lib/site_perl
make: *** [Makefile:273: testdeps] Error 1

Can someone please assist me on how to proceed from this point ?

Hey there,

Have you tried running ‘make fixdeps’ ?

 3) Make sure that RT has the Perl and system libraries it needs to run.
    Check for missing dependencies by running:

        make testdeps

 4) If the script reports any missing dependencies, install them by
    hand, or run the following command as a user who has permission to
    install perl modules on your system:

        make fixdeps

    Some modules require user input or environment variables to install
    correctly, so it may be necessary to install them manually. Some modules
    also require external source libraries, so you may need to install
    additional packages.

    If you are having trouble installing GD, refer to "Installing GD libraries"
    in docs/charts.pod.  Ticket relationship graphing requires the graphviz
    library which you should install using your distribution's package manager.

    See docs/rt_perl.pod for additional information about installing perl and
    RT's dependencies.

cgb, thanks for the response.

I did run ‘make fixdeps’ multiple times and I see number of failed activities when it’s running.
But number of missing dependencies didn’t reduce when it’s completed.

Just install them with apt, then

Is cpanm available in your install? If not, install it and try using that?

e.g.

apt-get install -y cpanminus
export RT_FIX_DEPS_CMD=/usr/bin/cpanm
make testdeps
make fixdeps
make testdeps

Some of the Perl modules require apt modules to be installed in order to successfully install themselves. Some main ones that I needed were:

sudo apt-get install  libgraphviz-dev graphviz autoconf apache2 libapache2-mod-fcgid slapd ldap-utils expat openssl libssl-dev

Also per the README:

    Currently supported:  MySQL 5.7 with InnoDB support

MySQL version 8 isn’t supported, I believe this is because they made “Groups” a reserved word in that version.

1 Like

Thanks knation for your support !

I installed the Perl modules as per your guide.
Also, I uninstalled MySQL 8 and installed MySQL 5.7.

Still having below missing dependencies:

SOME DEPENDENCIES WERE MISSING:

CORE dependencies:
CGI >= 4.00 … MISSING
CGI::Cookie >= 1.20 … MISSING
CGI::Emulate::PSGI … MISSING
CGI::PSGI >= 0.12 … MISSING
CSS::Minifier::XS … MISSING
Clone … MISSING
Crypt::Eksblowfish … MISSING
DBI >= 1.37 … MISSING
DBIx::SearchBuilder >= 1.68 … MISSING
Data::GUID … MISSING
Date::Extract >= 0.02 … MISSING
DateTime >= 0.44 … MISSING
DateTime::Format::Natural >= 0.67 … MISSING
DateTime::Locale >= 0.40, != 1.00, != 1.01 … MISSING
Encode::Detect::Detector … MISSING
Encode::HanExtra … MISSING
File::ShareDir … MISSING
HTML::Entities … MISSING
HTML::FormatText::WithLinks >= 0.14 … MISSING
HTML::FormatText::WithLinks::AndTables >= 0.06 … MISSING
HTML::Gumbo … MISSING
HTML::Mason >= 1.43 … MISSING
HTML::Mason::PSGIHandler >= 0.52 … MISSING
HTML::Quoted … MISSING
HTML::RewriteAttributes >= 0.05 … MISSING
HTML::Scrubber >= 0.08 … MISSING
JavaScript::Minifier::XS … MISSING
LWP >= 6.02 … MISSING
LWP::Protocol::https … MISSING
LWP::Simple … MISSING
LWP::UserAgent >= 6.02 … MISSING
List::MoreUtils … MISSING
Locale::Maketext::Lexicon >= 0.32 … MISSING
Log::Dispatch >= 2.30 … MISSING
Moose … MISSING
MooseX::NonMoose … MISSING
MooseX::Role::Parameterized … MISSING
Plack >= 1.0002 … MISSING
Plack::Handler::Starlet … MISSING
Scope::Upper … MISSING
Sub::Exporter … MISSING
Term::ReadKey … MISSING
Web::Machine >= 0.12 … MISSING
XML::RSS >= 1.05 … MISSING
namespace::autoclean … MISSING

GPG dependencies:
GnuPG::Interface >= 1.00 … MISSING
PerlIO::eol … MISSING

GRAPHVIZ dependencies:
GraphViz … MISSING

SQLITE dependencies:
DBD::SQLite >= 1.00 … MISSING

Perl library path for /usr/bin/perl:
/etc/perl
/usr/local/lib/x86_64-linux-gnu/perl/5.30.3
/usr/local/share/perl/5.30.3
/usr/lib/x86_64-linux-gnu/perl5/5.30
/usr/share/perl5
/usr/lib/x86_64-linux-gnu/perl-base
/usr/lib/x86_64-linux-gnu/perl/5.30
/usr/share/perl/5.30
/usr/local/lib/site_perl
make: *** [Makefile:278: fixdeps] Error 1

My suggestion wasn’t Perl module but OS packages, do you see an error when running make fixdeps?

You can try manually installing one of the missing Perl modules to get a better idea of what is going wrong:

cpanm install CGI
1 Like

@knation, thanks for the guidance !!
I could install individual modules and now all dependencies are completed.

1 Like

My hacky way installing the perl packages from the OS repo

$ make testdeps | grep MISSING | sed 's/::/-/g' | awk '{print "lib"tolower($0)"-perl"}' \
    | grep -v -e libencode-detect-detector-perl -e libmime-entity-perl -e libmail-header-perl -e libmail-mailer-perl -e libpath-dispatcher-perl -e libplack-handler-starlet-perl -e libsome-perl -e libmail-mailer-perl -e libpath-dispatcher-perl -e libplack-handler-starlet-perl \
    | xargs apt install -y

But some packages require a newer version then the one provided by the OS repo, for them I use cpan.