Continuous Login (RT 3.8.8)

Hi rt-users

I’ve recently installed RT 3.8.8 via ports on our server (FreeBSD 8.1,
Apache 2.2, PostgreSQL 9.0, Mod_Perl2, Perl 5.12, Exim 4.72).
I’m facing the issue that I have to enter the username and password
information every time I click on a link in RT.
Is there something missing in my installation? Or is it a
configuration issue?
The dependencies do look ok and the hints in the TroubleShooting-page
(deleting the html/autohandler) did not work out for me.

Regards
-luca.

The /var/log/messages contains the following warnings after each
click:
Oct 7 13:02:10 thor RT: Use of uninitialized value in lc at
/usr/local/lib/perl5/site_perl/5.12.2/HTML/Mason/ApacheHandler.pm line
914.
(/usr/local/lib/perl5/site_perl/5.12.2/HTML/Mason/ApacheHandler.pm:914)
Oct 7 13:02:12 thor RT: Use of uninitialized value in lc at
/usr/local/lib/perl5/site_perl/5.12.2/HTML/Mason/ApacheHandler.pm line
914.
(/usr/local/lib/perl5/site_perl/5.12.2/HTML/Mason/ApacheHandler.pm:914)
Oct 7 13:02:13 thor RT: Use of uninitialized value in lc at
/usr/local/lib/perl5/site_perl/5.12.2/HTML/Mason/ApacheHandler.pm line
914.
(/usr/local/lib/perl5/site_perl/5.12.2/HTML/Mason/ApacheHandler.pm:914)

These are the lines I’ve added to my httpd.conf inside the
directive:
Alias /services/rt /usr/local/share/rt38/html
<Directory /usr/local/share/rt38/html/>
Order allow,deny
Allow from all

PerlRequire /usr/local/bin/webmux.pl
<Location /services/rt/>
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Here is the output of the rt-test-dependencies command:
thor# rt-test-dependencies --with-postgresql --with-modperl2
perl:
>=5.8.3(5.12.2) …found
users:
rt group (www) …found
bin owner (root) …found
libs owner (root) …found
libs group (wheel) …found
web owner (www) …found
web group (www) …found
CLI dependencies:
CORE dependencies:
defined(%hash) is deprecated at
/usr/local/lib/perl5/site_perl/5.12.2/Locale/Maketext.pm line 404.
(Maybe you should just omit the defined()?)
DASHBOARDS dependencies:
GD dependencies:
GPG dependencies:
ICAL dependencies:
MAILGATE dependencies:
MASON dependencies:
MODPERL2 dependencies:
POSTGRESQL dependencies:
SMTP dependencies:
STANDALONE dependencies:

All dependencies have been found.

Hi.

Make sure web* options in RT config match URL you are using.

Regards, Ruslan. From phone.

написал:

Hi

Thank you for the quick response.

Make sure web* options in RT config match URL you are using.

They seem to be correct:

thor# grep Web RT_SiteConfig.pm
Set($WebPath , ‘/services/rt’);
Set($WebBaseURL , ‘https://thor.asgard.ch:443’);

If I make changes in RT_SiteConfig.pm, do I have to re-initialize the
database with rt-setup-database?

Regards, Ruslan. From phone.

Regards
-Luca.

Hi.

WebPath is correct. Drop WenBaseURL. Set properly WebDomain and WebPort.

Regards, Ruslan. From phone.

написал:

Your problem is with PostgreSQL not RT.
In version 9.0 default behaviour for bytea fields
changed and now they’re returned as hex
(as described in
http://www.postgresql.org/docs/9.0/static/release-9-0.html#AEN99024).

To change this add:

bytea_output = escape

to postgresql.conf and restart it.

Regards,
Sebastian

Sebastian Podjasek
morenet.pl