Content broken on latest RTFM

Hi all

I’m trying to migrate from an old server to a fresh installation on a
new server.

Old server:
Debian etch
Package request-tracker3.4 Version 3.4.5
Package rtfm Version 2.0.3
MySQL 5.0

New Server:
Debian etch
Package request-tracker3.6 Version 3.6.1
RTFM installed from source Version 2.4.1
MySQL 5.0

The articles have no content, and when I try to create a new article I
cannot enter any content because I just see the title “Content” without
any input fields (?!?). It all works fine on the old installation.

I have read the mailing list archives, where I found several posts
regarding a similar problem (database not properly migrated). However, I
think I did it correctly…

What I did:

  • Run migration tool (sbin/migrate-2.0-to-2.1) on old (!) server, which
    seemed to work fine and did a bunch of stuff.
  • Dump the RT database, import it on new server
  • Install RT 3.6, run RT 3.6 database migration script
    (/usr/sbin/rt-setup-database-3.6 |–action init --dba root
  • Now RT 3.6 itself seems to work fine
  • Download RTFM 2.4.1, install it over the debian package
  • Migrate the RTFM database as described in the RTFM manual
    (rt-setup-database --action schema/acl/insert for version 2.1.0, 2.1.30,

Now I have the following tables:
| Tables_in_rtdb |
| ACL |
| Attachments |
| Attributes |
| CachedGroupMembers |
| CustomFieldValues |
| CustomFields |
| FM_ArticleCFValues |
| FM_Articles |
| FM_ClassCustomFields |
| FM_Classes |
| FM_CustomFieldValues |
| FM_CustomFields |
| FM_ObjectTopics |
| FM_Topics |
| FM_Transactions |
| GroupMembers |
| Groups |
| Links |
| ObjectCustomFieldValues |
| ObjectCustomFields |
| Principals |
| Queues |
| ScripActions |
| ScripConditions |
| Scrips |
| Templates |
| Tickets |
| Transactions |
| Users |
| sessions |

which is two more FM_-tables than before the migration, so I guess it
has worked.

I also tried:
installing request-tracker 3.6.7 from source instead of the debian package

All with the same result: No “Content” for articles and no "Content"
input fields for new articles.

Any ideas?

Can I fix this, manually if necessary?

Thanks & best regards,

David Gubler

Hi Simon

Thanks for your response, it got me on the right path:

We have an RTFM class “FAQ” which has two custom fields. For some reason
these got disabled during the migration, all I had to do is to
reactivate them using the RT GUI and the root account.

Thanks again and best regards,

David Gubler

Simon Dray schrieb: