Configuring MSMTP to send Mails RT 4.4.4

I have configure RT to create tickets using fetchmail and its working fine. I have installed and configured msmtp for sending mails from RT but it is not working. From logs this is what I get…

Mar 9 08:32:25 helpdesk RT[2320]: [2320] sent To:
Mar 9 08:33:29 helpdesk RT[2252]: [2252] #34/519 - Scrip 3 On Correspond Notify Owner and AdminCcs
Mar 9 08:33:29 helpdesk RT[2252]: [2252] No recipients found. Not sending.
Mar 9 08:33:29 helpdesk RT[2252]: [2252] #34/519 - Scrip 4 On Correspond Notify Other Recipients
Mar 9 08:33:29 helpdesk RTmailer[2348]: CALL /usr/local/bin/msmtp -nt -oi -t RETURNED 78
Mar 9 08:33:29 helpdesk RT[2252]: [2252] sent Cc:

The logs show sent but the mail is not being recieved by the recipient. Any insights??

I believe the 78 means configuration issues, here I see a user said rights was the problem

Solved. mstmp_wrapper.conf should be owned by exact user that RT runs as. Also access rights should be 600.

@knation Hello
changed the file permissions on msmtp_wrapper.conf, sent a mail reply from RT the “CALL /usr/local/bin/msmtp -nt -oi -t RETURNED 78” changed to “CALL /usr/local/bin/msmtp -nt -oi -t RETURNED 74” but still am not getting any mail on the sent inbox. What do code 74 mean?

I have not used msmtp so I am not too familiar with it, I use sendmail/Postfix are you relaying your email to another email server?

Hey guys
On top of the configurations highlighted above, I solved the issue by changing the ownership of msmtp_wrapper (the script) and msmtp_wrapper.conf to “apache” webserver user.