Configuring fetchmail to poll emails to respective queues

Dear All,
I have configured new queue with ‘IT Support’ and configured want that any emails coming to ithelpdesk@syncoms.co.ukmailto:ithelpdesk@syncoms.co.uk should be fetched into this new queue. The snapshot of the new queue:

[cid:image001.png@01D09D57.3BF06430]
So far, everything is running fine and emails are been received in the ‘general’ queue. Now what do I need to do in order to configure rt such that any emails coming to ithelpdesk@syncoms.co.ukmailto:ithelpdesk@syncoms.co.uk comes in IT Support queue. As per few blogs they are saying to add in /etc/aliases . can you please suggest as what do I need to do - if I have to enter into the /etc/aliases then how my configuration will look like?
At the moment, /etc/aliases is:
[cid:image002.png@01D09D57.3BF06430]
And /etc/fetchmailrc:
[cid:image003.png@01D09D57.3BF06430]
Also, I have tried changing the -queue general to -queue ‘it support’ but it didn’t work. Infact this time the requestor is receiving a mailer demon error message.
Please suggest. Thanks

Kind Regards,

Rohit Gupta
IT Infrastructure Manager
Synchronized Communications Ltd
[New-RGB-logo-invoice]

Unit 5, Stonefield Way,
South Ruislip Middlesex
London UK- HA4 0JS

DDI: +44(0)208 185 6163
Fax: +44(0)208 845 3657
Email: rohit.gupta@syncoms.co.ukmailto:rohit.gupta@syncoms.co.uk
Web: www.syncoms.co.ukhttp://www.syncoms.co.uk/
P please don’t print this e-mail unless you really need to
Confidentiality Noticehttp://www.syncoms.co.uk/Legal.html | Legalhttp://www.syncoms.co.uk/Legal.html | Disclaimerhttp://www.syncoms.co.uk/Disclaimer.html

[image005][Kite-Mark-Blue-2010]

I’m not 100% sure, but I think your ‘Reply Address’ and 'Comment Address’
need to be different.

To get mail into the “IT Support” queue, you will need to modify
fetchmailrc to call rt-mailgate --queue “IT Support” and it should
hopefully work.

-AOn Tue, Jun 2, 2015 at 9:12 AM, Rohit Gupta rohit.gupta@syncoms.co.uk wrote:

Dear All,

I have configured new queue with ‘IT Support’ and configured want that any
emails coming to ithelpdesk@syncoms.co.uk should be fetched into this new
queue. The snapshot of the new queue:

So far, everything is running fine and emails are been received in the
‘general’ queue. Now what do I need to do in order to configure rt such
that any emails coming to ithelpdesk@syncoms.co.uk comes in IT Support
queue. As per few blogs they are saying to add in /etc/aliases . can you
please suggest as what do I need to do – if I have to enter into the
/etc/aliases then how my configuration will look like?

At the moment, /etc/aliases is:

And /etc/fetchmailrc:

Also, I have tried changing the –queue general to –queue ‘it support’ but
it didn’t work. Infact this time the requestor is receiving a mailer demon
error message.

Please suggest. Thanks

Kind Regards,

Rohit Gupta

IT Infrastructure Manager

Synchronized Communications Ltd

[image: New-RGB-logo-invoice]

Unit 5, Stonefield Way,

South Ruislip Middlesex

London UK– HA4 0JS

DDI: +44(0)208 185 6163

Fax: +44(0)208 845 3657

Email: rohit.gupta@syncoms.co.uk

Web: www.syncoms.co.uk

P please don’t print this e-mail unless you really need to

Confidentiality Notice http://www.syncoms.co.uk/Legal.html | Legal
http://www.syncoms.co.uk/Legal.html | Disclaimer
http://www.syncoms.co.uk/Disclaimer.html

[image: image005][image: Kite-Mark-Blue-2010]

Dear All,
I have configured new queue with ‘IT Support’ and configured want that any emails coming to ithelpdesk@syncoms.co.uk mailto:ithelpdesk@syncoms.co.uk should be fetched into this new queue. The snapshot of the new queue:

<image001.png>
So far, everything is running fine and emails are been received in the ‘general’ queue. Now what do I need to do in order to configure rt such that any emails coming to ithelpdesk@syncoms.co.uk mailto:ithelpdesk@syncoms.co.uk comes in IT Support queue. As per few blogs they are saying to add in /etc/aliases . can you please suggest as what do I need to do – if I have to enter into the /etc/aliases then how my configuration will look like?
At the moment, /etc/aliases is:
<image002.png>
And /etc/fetchmailrc:
<image003.png>
Also, I have tried changing the –queue general to –queue ‘it support’ but it didn’t work. Infact this time the requestor is receiving a mailer demon error message.
Please suggest. Thanks

Hi Rohit,

Since you are using fetchmail to get the mail and deliver it you do not need to modify your aliases.

Your —queue option is incorrect in your fetchmail configuration. Use the name of the queue here. Since it has spaces you’ll have to use quotation marks.

…./rt-mailgate —queue “IT Support” —action correspond …etc…

Also -
Set your comment address to something else like (ithelpdesk-comments@syncoms.co.uk mailto:ithelpdesk-comments@syncoms.co.uk). Setup another POP3 mailbox for that address. Add that configuration to fetchmailrc but instead of using “correspond” for the action use “comment”.

If the sender gets an email back instead of the email being created in the queue make sure you find out what it’s saying back to them. Also make sure you check:

  • the fetchmail output (try running fetchmail manually in the foreground with verbose output)
  • the RT log (usually /opt/rt4/var/log/rt.log)

Since this is a newly created queue it could be that everyone simply doesn’t have permission to create tickets in the new queue. Hard to say without more information.

Landon Stewart : lstewart@iweb.com
Lead Specialist, Abuse and Security Management
Spécialiste principal, gestion des abus et sécurité
http://iweb.com : +1 (888) 909-4932

signature.asc (909 Bytes)

Your —queue option is incorrect in your fetchmail configuration. Use the name of the queue here. Since it has spaces you’ll have to use quotation marks.

Oops, I should have mentioned you’ll need to use single quotes instead of double quotes for the queue name since you are enclosing the whole command in double quotes.

Landon Stewart : lstewart@iweb.com
Lead Specialist, Abuse and Security Management
Spécialiste principal, gestion des abus et sécurité
http://iweb.com : +1 (888) 909-4932

signature.asc (909 Bytes)

Hi Landon,

Thanks for your information –but as per my original post I have already mentioned that I tried –option ‘it support’ with single quotes but it didn’t work too. Though I will check the rt logs in case I can find out something.

Also, please clarify as why we require 2 separate email accounts for correspond & comment. As per my understanding the following should happen:

Requestor --> sending issue email to --> ithelpdesk@domain.co.ukmailto:ithelpdesk@domain.co.uk --> get logged into --> RT System as new ticket

Now what will be the role of the second email that is being asked for the comment i.e. ithelpdesk-comment@domain.co.ukmailto:ithelpdesk-comment@domain.co.uk in it. Please clarify.

Kind Regards,

Rohit Gupta
IT Infrastructure Manager
Synchronized Communications Ltd
[New-RGB-logo-invoice]

Unit 5, Stonefield Way,
South Ruislip Middlesex
London UK– HA4 0JS

DDI: +44(0)208 185 6163
Fax: +44(0)208 845 3657
Email: rohit.gupta@syncoms.co.ukmailto:rohit.gupta@syncoms.co.uk
Web: www.syncoms.co.ukhttp://www.syncoms.co.uk/
P please don’t print this e-mail unless you really need to
Confidentiality Noticehttp://www.syncoms.co.uk/Legal.html | Legalhttp://www.syncoms.co.uk/Legal.html | Disclaimerhttp://www.syncoms.co.uk/Disclaimer.html

[image005][Kite-Mark-Blue-2010]From: Landon Stewart [mailto:lstewart@iweb.com]
Sent: 02 June 2015 21:04
To: Rohit Gupta
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Configuring fetchmail to poll emails to respective queues.

Your —queue option is incorrect in your fetchmail configuration. Use the name of the queue here. Since it has spaces you’ll have to use quotation marks.

Oops, I should have mentioned you’ll need to use single quotes instead of double quotes for the queue name since you are enclosing the whole command in double quotes.

Landon Stewart : lstewart@iweb.commailto:lstewart@iweb.com
Lead Specialist, Abuse and Security Management
Spécialiste principal, gestion des abus et sécurité
http://iweb.com : +1 (888) 909-4932

Dear All \ Landon,

Problem solved – the issue was I haven’t granted the new queue the everyone rights to create a ticket, hence it was sending a bounce mailer daemon to the requestor.

But, I would still appreciate any one can clarify the reason to create 2 separate emails for correspond and comment.

Kind Regards,

Rohit Gupta

You don’t need 2 separate emails for those fields. Our instance works fine with the same email in both fields.From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Rohit Gupta
Sent: Thursday, June 4, 2015 6:17 AM
To: Rohit Gupta; Landon Stewart
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Configuring fetchmail to poll emails to respective queues.

Dear All \ Landon,

Problem solved – the issue was I haven’t granted the new queue the everyone rights to create a ticket, hence it was sending a bounce mailer daemon to the requestor.

But, I would still appreciate any one can clarify the reason to create 2 separate emails for correspond and comment.

Kind Regards,

Rohit Gupta

ARDEN
A Global Company
Celebrating over 50 years of making your life more comfortable!

This message may contain confidential and/or privileged information. If you are not the addressee or authorized to receive this for the addressee, you must not use, copy, disclose, or take any action based on this message or any information herein. If you have received this message in error, please advise the sender immediately by reply e-mail and delete this message.

This OUTBOUND E-mail and Document(s) has been scanned by an Antivirus Server.

Hi,

Two sperate emails are usefull two clarify the two roles (Correspond and
Comment a ticket). When you select correspond, an email will be sent two
the requestor and Ccs of the ticket whilst nothing will be sent to the
requestor when using comments. It is usefull if you use a queue to
correspond whith customers for instance and if you want to adds messages
that not concerns your customer. I think that two addresses are needed
if you are not using the RT WebUI but only emails.

Hope it helps

Loic Cadoret
IT Technician
KeyyoLe 04/06/2015 14:31, Bob Shaker a écrit :

You don’t need 2 separate emails for those fields. Our instance works
fine with the same email in both fields.

*From:*rt-users [mailto:rt-users-bounces@lists.bestpractical.com] *On
Behalf Of *Rohit Gupta
Sent: Thursday, June 4, 2015 6:17 AM
To: Rohit Gupta; Landon Stewart
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Configuring fetchmail to poll emails to
respective queues.

Dear All \ Landon,

Problem solved – the issue was I haven’t granted the new queue the
everyone rights to create a ticket, hence it was sending a bounce
mailer daemon to the requestor.

But, I would still appreciate any one can clarify the reason to create
2 separate emails for correspond and comment.

Kind Regards,

Rohit Gupta


ARDEN
A Global Company
Celebrating over 50 years of making your life more comfortable!

This message may contain confidential and/or privileged information.
If you are not the addressee or authorized to receive this for the
addressee, you must not use, copy, disclose, or take any action based
on this message or any information herein. If you have received this
message in error, please advise the sender immediately by reply e-mail
and delete this message.

This OUTBOUND E-mail and Document(s) has been scanned by an Antivirus
Server.

Hi Aaron,

Quick question – if the email id’s need to be separate then why everything is working fine in General queue?

Kind Regards,

Rohit Gupta
IT Infrastructure Manager
Synchronized Communications Ltd
[New-RGB-logo-invoice]

Unit 5, Stonefield Way,
South Ruislip Middlesex
London UK– HA4 0JS

DDI: +44(0)208 185 6163
Fax: +44(0)208 845 3657
Email: rohit.gupta@syncoms.co.ukmailto:rohit.gupta@syncoms.co.uk
Web: www.syncoms.co.ukhttp://www.syncoms.co.uk/
P please don’t print this e-mail unless you really need to
Confidentiality Noticehttp://www.syncoms.co.uk/Legal.html | Legalhttp://www.syncoms.co.uk/Legal.html | Disclaimerhttp://www.syncoms.co.uk/Disclaimer.html

[image005][Kite-Mark-Blue-2010]From: Aaron C. de Bruyn [mailto:aaron@heyaaron.com]
Sent: 02 June 2015 19:27
To: Rohit Gupta
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Configuring fetchmail to poll emails to respective queues.

I’m not 100% sure, but I think your ‘Reply Address’ and ‘Comment Address’ need to be different.

To get mail into the “IT Support” queue, you will need to modify fetchmailrc to call rt-mailgate --queue “IT Support” and it should hopefully work.

-A

Please ignore the last email as I have posted it a long time back . now everything has been sorted. :slight_smile:

Kind Regards,

Rohit GuptaFrom: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Rohit Gupta
Sent: 04 June 2015 09:46
To: Aaron C. de Bruyn
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Configuring fetchmail to poll emails to respective queues.

Hi Aaron,

Quick question – if the email id’s need to be separate then why everything is working fine in General queue?

Kind Regards,

From: Aaron C. de Bruyn [mailto:aaron@heyaaron.com]
Sent: 02 June 2015 19:27
To: Rohit Gupta
Cc: rt-users@lists.bestpractical.commailto:rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Configuring fetchmail to poll emails to respective queues.

I’m not 100% sure, but I think your ‘Reply Address’ and ‘Comment Address’ need to be different.

To get mail into the “IT Support” queue, you will need to modify fetchmailrc to call rt-mailgate --queue “IT Support” and it should hopefully work.

-A

You don’t need 2 separate emails for those fields. Our instance works
fine with the same email in both fields.

This isn’t a good idea, though it does work. The problem is when
someone records a comment, and it gets sent out just to your company –
but “From” the one address you have set. When some well-meaning person
replies to that mail, it will come into the address RT uses for
correspondence – and then the end-user will get the information that
you intended to be a comment. This is at best confusing, and at worst
horribly embarrassing.

  • Alex