Configuring Apache for RT

Hello all,

I am trying to configure Apache for RT with the following VirtualHost
entry:

<VirtualHost *:5000>
ServerName 192.168.2.60
DocumentRoot /opt/rt3/share/html
ErrorLog logs/rt-error.log
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>

Further I also have, DirectoryIndex index.html enabled. But yet, I am
not able to access RT front end without specifying index.html in the
URL.

I am using Apache 2.0.8. Any help on DirectoryIndex would be of great
help.

Regards,
Ritu

Ritu Khetan wrote:

Hello all,

I am trying to configure Apache for RT with the following VirtualHost
entry:

<VirtualHost *:5000>
ServerName 192.168.2.60
DocumentRoot /opt/rt3/share/html
ErrorLog logs/rt-error.log
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>

Further I also have, DirectoryIndex index.html enabled. But yet, I am
not able to access RT front end without specifying index.html in the
URL.

I am using Apache 2.0.8. Any help on DirectoryIndex would be of great
help.

DirectoryIndex doesn’t seem to function in SetHandler perl-script
directories.
I don’t know enough about Apache internals to know if there is a more
elegant solution, but this is what I am using:

<Directory /opt/rt3/share/html>
<Files *.html>
SetHandler perl-script
PerlHandler RT::Mason


<Directory /opt/rt3/share/html/Ticket/Attachment>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/SelfService/Attachment>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/REST>
SetHandler perl-script
PerlHandler RT::Mason

Max.

Hello Max,

I have tried the config you gave below but in vain. The problem

persists. This is what Apache’s error log shows:

Directory index forbidden by rule: /opt/rt3/share/html/

I need to resolve this quickly and am not able to find any solution. Pls
help.

Regards,
RituOn Tue, 2003-12-09 at 16:47, Max Bowsher wrote:

Ritu Khetan wrote:

Hello all,

I am trying to configure Apache for RT with the following VirtualHost
entry:

<VirtualHost *:5000>
ServerName 192.168.2.60
DocumentRoot /opt/rt3/share/html
ErrorLog logs/rt-error.log
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>

Further I also have, DirectoryIndex index.html enabled. But yet, I am
not able to access RT front end without specifying index.html in the
URL.

I am using Apache 2.0.8. Any help on DirectoryIndex would be of great
help.

DirectoryIndex doesn’t seem to function in SetHandler perl-script
directories.
I don’t know enough about Apache internals to know if there is a more
elegant solution, but this is what I am using:

<Directory /opt/rt3/share/html>
<Files *.html>
SetHandler perl-script
PerlHandler RT::Mason


<Directory /opt/rt3/share/html/Ticket/Attachment>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/SelfService/Attachment>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/REST>
SetHandler perl-script
PerlHandler RT::Mason

Max.

NETCORE SOLUTIONS *** Ph: +91 22 5662 8000 Fax: +91 22 5662 8134

MailServ and FlexiMail: Messaging Solutions: http://netcore.co.in

Pragatee: Integrated Server-Software Suite: http://www.pragatee.com

Emergic Freedom: Server-centric Computing: http://www.emergic.com

BlogStreet: Blog Profiles and RSS Ecosystem: http://blogstreet.com

Deeshaa: Rural Development: http://www.deeshaa.com

Rajesh Jain’s Weblog on Technology: http://www.emergic.org

Ritu Khetan wrote:

Hello Max,

I have tried the config you gave below but in vain. The problem

persists. This is what Apache’s error log shows:

Directory index forbidden by rule: /opt/rt3/share/html/

Add:

Order allow,deny
Allow from all
Options Indexes

to your <Directory /opt/rt3/share/html>… block.

Max.

I need to resolve this quickly and am not able to find any solution. Pls
help.

Regards,
Ritu

Ritu Khetan wrote:

Hello all,

I am trying to configure Apache for RT with the following
VirtualHost

I tried adding this, however, configtest complains that “order is not
allowed here”.

JohnOn Wed, 2003-12-10 at 09:06, Max Bowsher wrote:

Ritu Khetan wrote:

Hello Max,

I have tried the config you gave below but in vain. The problem

persists. This is what Apache’s error log shows:

Directory index forbidden by rule: /opt/rt3/share/html/

Add:

Order allow,deny
Allow from all
Options Indexes

to your <Directory /opt/rt3/share/html>… block.

Max.

I need to resolve this quickly and am not able to find any solution. Pls
help.

Regards,
Ritu
On Tue, 2003-12-09 at 16:47, Max Bowsher wrote:

Ritu Khetan wrote:

Hello all,

I am trying to configure Apache for RT with the following
VirtualHost
entry:

<VirtualHost *:5000>
ServerName 192.168.2.60
DocumentRoot /opt/rt3/share/html
ErrorLog logs/rt-error.log
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>

Further I also have, DirectoryIndex index.html enabled. But yet, I am
not able to access RT front end without specifying index.html in the
URL.

I am using Apache 2.0.8. Any help on DirectoryIndex would be of great
help.

DirectoryIndex doesn’t seem to function in SetHandler perl-script
directories.
I don’t know enough about Apache internals to know if there is a more
elegant solution, but this is what I am using:

<Directory /opt/rt3/share/html>
<Files *.html>
SetHandler perl-script
PerlHandler RT::Mason


<Directory /opt/rt3/share/html/Ticket/Attachment>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/SelfService/Attachment>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/REST>
SetHandler perl-script
PerlHandler RT::Mason

Max.


NETCORE SOLUTIONS *** Ph: +91 22 5662 8000 Fax: +91 22 5662 8134

MailServ and FlexiMail: Messaging Solutions: http://netcore.co.in

Pragatee: Integrated Server-Software Suite: http://www.pragatee.com

Emergic Freedom: Server-centric Computing: http://www.emergic.com

BlogStreet: Blog Profiles and RSS Ecosystem: http://blogstreet.com

Deeshaa: Rural Development: http://www.deeshaa.com

Rajesh Jain’s Weblog on Technology: http://www.emergic.org


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Sorry Max, yet no luck. Any other guesses ???

I do have DirectoryIndex index.html defined in my httpd.conf too.

This is how the complete thing looks like currently:

<LocationMatch “^/$”>
Options -Indexes
ErrorDocument 403 /error/noindex.html

DirectoryIndex index.html index.html.var

<Directory /opt/rt3/share/html>
<Files *.html>
SetHandler perl-script
PerlHandler RT::Mason

    Order allow,deny
    Allow from all
    Options Indexes

<Directory /opt/rt3/share/html/Ticket/Attachment>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/SelfService/Attachment>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/REST>
SetHandler perl-script
PerlHandler RT::Mason

<VirtualHost *:5000>
ServerName 192.168.2.60
DocumentRoot /opt/rt3/share/html
ErrorLog logs/rt-error.log
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>

Regards,
RituOn Wed, 2003-12-10 at 14:36, Max Bowsher wrote:

Ritu Khetan wrote:

Hello Max,

I have tried the config you gave below but in vain. The problem

persists. This is what Apache’s error log shows:

Directory index forbidden by rule: /opt/rt3/share/html/

Add:

Order allow,deny
Allow from all
Options Indexes

to your <Directory /opt/rt3/share/html>… block.

Max.

I need to resolve this quickly and am not able to find any solution. Pls
help.

Regards,
Ritu
On Tue, 2003-12-09 at 16:47, Max Bowsher wrote:

Ritu Khetan wrote:

Hello all,

I am trying to configure Apache for RT with the following
VirtualHost
entry:

<VirtualHost *:5000>
ServerName 192.168.2.60
DocumentRoot /opt/rt3/share/html
ErrorLog logs/rt-error.log
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>

Further I also have, DirectoryIndex index.html enabled. But yet, I am
not able to access RT front end without specifying index.html in the
URL.

I am using Apache 2.0.8. Any help on DirectoryIndex would be of great
help.

DirectoryIndex doesn’t seem to function in SetHandler perl-script
directories.
I don’t know enough about Apache internals to know if there is a more
elegant solution, but this is what I am using:

<Directory /opt/rt3/share/html>
<Files *.html>
SetHandler perl-script
PerlHandler RT::Mason


<Directory /opt/rt3/share/html/Ticket/Attachment>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/SelfService/Attachment>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/REST>
SetHandler perl-script
PerlHandler RT::Mason

Max.


NETCORE SOLUTIONS *** Ph: +91 22 5662 8000 Fax: +91 22 5662 8134

MailServ and FlexiMail: Messaging Solutions: http://netcore.co.in

Pragatee: Integrated Server-Software Suite: http://www.pragatee.com

Emergic Freedom: Server-centric Computing: http://www.emergic.com

BlogStreet: Blog Profiles and RSS Ecosystem: http://blogstreet.com

Deeshaa: Rural Development: http://www.deeshaa.com

Rajesh Jain’s Weblog on Technology: http://www.emergic.org

NETCORE SOLUTIONS *** Ph: +91 22 5662 8000 Fax: +91 22 5662 8134

MailServ and FlexiMail: Messaging Solutions: http://netcore.co.in

Pragatee: Integrated Server-Software Suite: http://www.pragatee.com

Emergic Freedom: Server-centric Computing: http://www.emergic.com

BlogStreet: Blog Profiles and RSS Ecosystem: http://blogstreet.com

Deeshaa: Rural Development: http://www.deeshaa.com

Rajesh Jain’s Weblog on Technology: http://www.emergic.org

John Schubert wrote:

I tried adding this, however, configtest complains that “order is not
allowed here”.

Well, Order definitely is allowed in a Directory block.

Perhaps you should post the relevant bits of your Apache config.

Max.> On Wed, 2003-12-10 at 09:06, Max Bowsher wrote:

Ritu Khetan wrote:

Hello Max,

I have tried the config you gave below but in vain. The problem

persists. This is what Apache’s error log shows:

Directory index forbidden by rule: /opt/rt3/share/html/

Add:

Order allow,deny
Allow from all
Options Indexes

to your <Directory /opt/rt3/share/html>… block.

Ritu Khetan wrote:

Sorry Max, yet no luck. Any other guesses ???

I do have DirectoryIndex index.html defined in my httpd.conf too.

This is how the complete thing looks like currently:

<VirtualHost *:5000>


SetHandler perl-script
PerlHandler RT::Mason

Remove the … block.

Max.

John Schubert wrote:

I tried adding this, however, configtest complains that “order is not
allowed here”.

Well, Order definitely is allowed in a Directory block.

Perhaps you should post the relevant bits of your Apache config.

<VirtualHost 192.168.1.199>
ServerName tech.linearcorp.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# this line applies to Apache2+mod_perl2 only
# PerlModule Apache2 Apache::compat

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>
I placed the lines within the Virtual Host. So maybe that was my mistake. I've been trying to get back my Apache for other internal sites, however any time I try to change it, the added area goes into a weird refreshing loop for a Forbidden Page (when I say refreshing loop, I mean the page displays and then reloads repeatedly). My http.conf is the "stock" installation, other than the above.

For example, I added
DocumentRoot /home/tech
and other tricks but it always kicks into the unauth or forbid page.
Sym linking is normally the approach I use ( e.g. ln -s /home/tech
/etc/rt3/share/html/tech ) but the same loop occurs. I thought maybe
permissions were an issue, but chmod 777 had no effect.

I’ve spent about 3 or 4 hours on this one issue, so I’ve spent a little
time but not much. After spending a month wrestling with RedHat 8,
Mod_perl2 and Apache2 issues with RT, I now have to limit the amount of
time I spend troubleshooting.

John

John Schubert wrote:

John Schubert wrote:

I tried adding this, however, configtest complains that “order is not
allowed here”.

Well, Order definitely is allowed in a Directory block.

Perhaps you should post the relevant bits of your Apache config.


<VirtualHost 192.168.1.199>
ServerName tech.linearcorp.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# this line applies to Apache2+mod_perl2 only
# PerlModule Apache2 Apache::compat

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>
_________________________________________ I placed the lines within the Virtual Host. So maybe that was my mistake.

Well, yes. That is what the docs say:
http://httpd.apache.org/docs/mod/mod_access.html#order

I’ve been trying to get back my Apache for other internal
sites, however any time I try to change it, the added area goes into a
weird refreshing loop for a Forbidden Page (when I say refreshing loop,
I mean the page displays and then reloads repeatedly). My http.conf is
the “stock” installation, other than the above.

For example, I added
DocumentRoot /home/tech

That is NOT valid syntax for a block. See the apache
documentation for how to correctly use .

Max.

Thanks a lot Max…this worked!!!

Regards,
RituOn Thu, 2003-12-11 at 20:26, Max Bowsher wrote:

Ritu Khetan wrote:

Sorry Max, yet no luck. Any other guesses ???

I do have DirectoryIndex index.html defined in my httpd.conf too.

This is how the complete thing looks like currently:

<VirtualHost *:5000>


SetHandler perl-script
PerlHandler RT::Mason

Remove the … block.

Max.

NETCORE SOLUTIONS *** Ph: +91 22 5662 8000 Fax: +91 22 5662 8134

MailServ and FlexiMail: Messaging Solutions: http://netcore.co.in

Pragatee: Integrated Server-Software Suite: http://www.pragatee.com

Emergic Freedom: Server-centric Computing: http://www.emergic.com

BlogStreet: Blog Profiles and RSS Ecosystem: http://blogstreet.com

Deeshaa: Rural Development: http://www.deeshaa.com

Rajesh Jain’s Weblog on Technology: http://www.emergic.org

System is Fedora Core 7

[root@rt3 ~]# rpm -q httpd
httpd-2.2.4-4.1.fc7
[root@rt3 ~]# rpm -q rt3
rt3-3.6.3-1.fc7

I’m getting the message about needing to configure the web server for
mod_perl, FastCGI, or SpeedyCGI The Fedora wiki skips right over this
part. In the source wiki,
FastCGIConfiguration - Request Tracker Wiki talks about it a
bit, but I just cannot figure out what I need to do to translate those
instructions… they obviously assume that you’re using source and some
defaults that uses, but with Fedora, things are just different. I tried
working with:

Tell FastCGI to put its temporary files somewhere sane.

FastCgiIpcDir /tmp

Number of processes is tunable, but you need at least 3 or 4

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
-processes 4

ServerName rt.example.com
DocumentRoot /opt/rt3/share/html
ErrorLog /var/logs/apache2/logs/rt.example.com_error
CustomLog /var/logs/apache2/logs/rt.example.com-access_log common
AddHandler fastcgi-script fcgi
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

But that makes httpd fail to start with nothing echoed to
/var/log/httpd/error_log so I’m stuck.

What needs to be done to get RT working under FC7?

First, you probably didn’t install mod_perl or any flavor of FastCGI. To
install FastCGI in Fedora:

yum install mod_fcgid

Next, you can’t just include that virtual host config verbatim - it isn’t
going to work - you have to modify it for your system. That code assumes
you are using Apache’s FastCGI module, for one… Instead, create an
rt.conf file in /etc/httpd/conf.d. Put the following in it:

LoadModule fcgid_module modules/mod_fcgid.so

Use FastCGI to process .fcg .fcgi & .fpl scripts

Don’t do this if mod_fastcgi is present, as it will try to do the same

thing
<IfModule !mod_fastcgi.c>
AddHandler fcgid-script fcg fcgi fpl

Sane place to put sockets and shared memory file

SocketPath run/mod_fcgid
SharememPath run/fcgid_shm

Main instance

Alias /rt/NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi/

This assumes the Fedora RT RPM was installed in /opt/rt3

And if you are going to use a database backend to store all your tickets
(which you should be doing), you are going to have to install a database
server (mysql, for example), create an RT database called rt3, assign a
username/password to it (use rt_user for the user), etc. Then follow the
documentation to create the RT tables and schema in said database.

Once that’s done, you need to customize your /opt/rt3/etc/RT_SiteConfig.pm.
It should look something like:

Set($DatabasePassword , ‘<dbpassword’);
Set($DatabaseHost , ‘’);
Set($DatabasePort , ‘3306’);
Set($Organization , “”);
Set($rtname, ‘’);
Set($Timezone , ‘US/Central’);
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://”);
Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

1;

This would give an RT URL of: http:///rt/

The above config assumes the ‘rt3’ is the database name and ‘rt_user’ is
the user with permissions to the database. /opt/rt3/etc/RT_Config.pm
contains all the default settings. Settings in
/opt/rt3/etc/RT_Siteconfig.pm override the default settings.

That should get you going. There is a lot more to RT than this - including
setting up the mailgate as well as adding queues, users, scripts, etc, via
the web-based RT interface.

BTW, it’s possible the Fedora RT RPM installs mysql, creates a database,
etc - but I would seriously doubt it. I have never installed RT via RPM -
only from source.

James Moseley

         John Oliver                                                   
         <joliver@john-oli                                             
         ver.net>                                                   To 
         Sent by:                  rt-users@lists.bestpractical.com    
         rt-users-bounces@                                          cc 
         lists.bestpractic                                             
         al.com                                                Subject 
                                   [rt-users] Configuring Apache for   
                                   RT                                  
         07/16/2007 07:14                                              
         PM                                                            

System is Fedora Core 7

[root@rt3 ~]# rpm -q httpd
httpd-2.2.4-4.1.fc7
[root@rt3 ~]# rpm -q rt3
rt3-3.6.3-1.fc7

I’m getting the message about needing to configure the web server for
mod_perl, FastCGI, or SpeedyCGI The Fedora wiki skips right over this
part. In the source wiki,
FastCGIConfiguration - Request Tracker Wiki talks about it a
bit, but I just cannot figure out what I need to do to translate those
instructions… they obviously assume that you’re using source and some
defaults that uses, but with Fedora, things are just different. I tried
working with:

Tell FastCGI to put its temporary files somewhere sane.

FastCgiIpcDir /tmp

Number of processes is tunable, but you need at least 3 or 4

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
-processes 4

ServerName rt.example.com
DocumentRoot /opt/rt3/share/html
ErrorLog /var/logs/apache2/logs/rt.example.com_error
CustomLog /var/logs/apache2/logs/rt.example.com-access_log common
AddHandler fastcgi-script fcgi
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

But that makes httpd fail to start with nothing echoed to
/var/log/httpd/error_log so I’m stuck.

What needs to be done to get RT working under FC7?

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

John Oliver wrote:

System is Fedora Core 7

[root@rt3 ~]# rpm -q httpd
httpd-2.2.4-4.1.fc7
[root@rt3 ~]# rpm -q rt3
rt3-3.6.3-1.fc7

I’m getting the message about needing to configure the web server for
mod_perl, FastCGI, or SpeedyCGI The Fedora wiki skips right over this
part. In the source wiki,
FastCGIConfiguration - Request Tracker Wiki talks about it a
bit, but I just cannot figure out what I need to do to translate those
instructions… they obviously assume that you’re using source and some
defaults that uses, but with Fedora, things are just different. I tried
working with:

Tell FastCGI to put its temporary files somewhere sane.

FastCgiIpcDir /tmp

Number of processes is tunable, but you need at least 3 or 4

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
-processes 4

ServerName rt.example.com
DocumentRoot /opt/rt3/share/html
ErrorLog /var/logs/apache2/logs/rt.example.com_error
CustomLog /var/logs/apache2/logs/rt.example.com-access_log common
AddHandler fastcgi-script fcgi
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

But that makes httpd fail to start with nothing echoed to
/var/log/httpd/error_log so I’m stuck.

What needs to be done to get RT working under FC7?

Have you looked at the README for RT. I think the config requirements
are in there.

Mathew
Keep up with my goings on at http://theillien.blogspot.com

Although not probably directly relevant to John’s question, and not
specifically an RT issue, if you are using SSL you should also set
the following in apache (at least 1.3.x versions, but I think applies
to 2.x versions as well)

SetEnvIf User-Agent “.MSIE.
nokeepalive ssl-unclean-shutdown
downgrade-1.0 force-response-1.0

in the section for SSL enabled virtual host or similar location.

(see mod_ssl: F.A.Q.)

Apparently IE (up to at least version 6) has bugs (who’d imagine:)
related to SSL and HTTP keep-alive. Had an RT setup all ready for some
final beta testing before roll-out and my Windows beta testers found it
essentially unusable. Users would try to access pages and/or submit
forms and sometimes would work, but frequently would get “Page could not
be loaded” errors in IE.

Was several months (and only after seeing similar
behavior in another web app) before I stumbled across the above page.
(And unfortunately lost our “migration window” and still do not have RT
set up. Maybe in the next six months:)

Tom Payerle
Dept of Physics payerle@physics.umd.edu
University of Maryland (301) 405-6973
College Park, MD 20742-4111 Fax: (301) 314-9525

First, you probably didn’t install mod_perl or any flavor of FastCGI. To
install FastCGI in Fedora:

yum install mod_fcgid

True. I was trying to follow the wiki. Since the FC6 wiki is neaarly
completely unusable for FC7, I’ve started an FC7 InstallGuide and am
endeavoring to make it far more useful to folks in my position, who
don’t know these secrets :slight_smile:

Next, you can’t just include that virtual host config verbatim - it isn’t
going to work - you have to modify it for your system. That code assumes
you are using Apache’s FastCGI module, for one…

That’s exactly what I’m talking about :slight_smile: As far as I can see, there
should be one “right” way to make this work under FC7, the way that
presupposes all of the ways FC7 will have RT and its’ dependencies
installed.

Instead, create an
rt.conf file in /etc/httpd/conf.d. Put the following in it:

LoadModule fcgid_module modules/mod_fcgid.so

Use FastCGI to process .fcg .fcgi & .fpl scripts

Don’t do this if mod_fastcgi is present, as it will try to do the same

thing
<IfModule !mod_fastcgi.c>
AddHandler fcgid-script fcg fcgi fpl

Sane place to put sockets and shared memory file

SocketPath run/mod_fcgid
SharememPath run/fcgid_shm

Main instance

Alias /rt/NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi/

This assumes the Fedora RT RPM was installed in /opt/rt3

Which it isn’t… /usr/share/rt3/html/ is where rt3 lives under FC7

Anyway… the RPM installs /etc/httpd/conf.d/rt3.conf:

Alias /rt3 “/usr/share/rt3/html”

PerlRequire /usr/sbin/webmux.pl

<Directory “/usr/share/rt3/html”>
AllowOverride All
Options ExecCGI FollowSymLinks

RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Out of the box, that doesn’t work. httpd will start, but I get the
message about the web server not being configured. I pasted in the
example you gave above and modified it to the FC7 defaults:

LoadModule mod_fcgid.so

Use FastCGI to process .fcg .fcgi & .fpl scripts

Don’t do this if mod_fastcgi is present, as it will try to do the same

thing
<IfModule !mod_fastcgi.c>
AddHandler fcgid-script fcg fcgi fpl

Sane place to put sockets and shared memory file

SocketPath run/mod_fcgid
SharememPath run/fcgid_shm

Main instance

Alias /rt/NoAuth/images/ /usr/share/rt3/html/NoAuth/images/
#ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi/
ScriptAlias /rt /usr/sbin/mason_handler.fcgi

However, the “LoadModule mod_fcgid.so” makes httpd fail to start without
any error logged to error_log, so I’m dead in the water again :frowning:

You state starting apache still fails… I assume you did do the
following:

yum install mod_fcgid

Honestly, I would uninstall the RT3 RPM and install RT from source.
Documentation is fairly straightforward.

James Moseley

         John Oliver                                                   
         <joliver@john-oli                                             
         ver.net>                                                   To 
         Sent by:                  rt-users@lists.bestpractical.com    
         rt-users-bounces@                                          cc 
         lists.bestpractic                                             
         al.com                                                Subject 
                                   Re: [rt-users] Configuring Apache   
                                   for RT                              
         07/17/2007 02:00                                              
         PM                                                            

First, you probably didn’t install mod_perl or any flavor of FastCGI. To
install FastCGI in Fedora:

yum install mod_fcgid

True. I was trying to follow the wiki. Since the FC6 wiki is neaarly
completely unusable for FC7, I’ve started an FC7 InstallGuide and am
endeavoring to make it far more useful to folks in my position, who
don’t know these secrets :slight_smile:

Next, you can’t just include that virtual host config verbatim - it isn’t
going to work - you have to modify it for your system. That code assumes
you are using Apache’s FastCGI module, for one…

That’s exactly what I’m talking about :slight_smile: As far as I can see, there
should be one “right” way to make this work under FC7, the way that
presupposes all of the ways FC7 will have RT and its’ dependencies
installed.

Instead, create an
rt.conf file in /etc/httpd/conf.d. Put the following in it:

LoadModule fcgid_module modules/mod_fcgid.so

Use FastCGI to process .fcg .fcgi & .fpl scripts

Don’t do this if mod_fastcgi is present, as it will try to do the same

thing
<IfModule !mod_fastcgi.c>
AddHandler fcgid-script fcg fcgi fpl

Sane place to put sockets and shared memory file

SocketPath run/mod_fcgid
SharememPath run/fcgid_shm

Main instance

Alias /rt/NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi/

This assumes the Fedora RT RPM was installed in /opt/rt3

Which it isn’t… /usr/share/rt3/html/ is where rt3 lives under FC7

Anyway… the RPM installs /etc/httpd/conf.d/rt3.conf:

Alias /rt3 “/usr/share/rt3/html”

PerlRequire /usr/sbin/webmux.pl

<Directory “/usr/share/rt3/html”>
AllowOverride All
Options ExecCGI FollowSymLinks

RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Out of the box, that doesn’t work. httpd will start, but I get the
message about the web server not being configured. I pasted in the
example you gave above and modified it to the FC7 defaults:

LoadModule mod_fcgid.so

Use FastCGI to process .fcg .fcgi & .fpl scripts

Don’t do this if mod_fastcgi is present, as it will try to do the same

thing
<IfModule !mod_fastcgi.c>
AddHandler fcgid-script fcg fcgi fpl

Sane place to put sockets and shared memory file

SocketPath run/mod_fcgid
SharememPath run/fcgid_shm

Main instance

Alias /rt/NoAuth/images/ /usr/share/rt3/html/NoAuth/images/
#ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi/
ScriptAlias /rt /usr/sbin/mason_handler.fcgi

However, the “LoadModule mod_fcgid.so” makes httpd fail to start without
any error logged to error_log, so I’m dead in the water again :frowning:

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

You state starting apache still fails… I assume you did do the
following:

yum install mod_fcgid

Yes.

Honestly, I would uninstall the RT3 RPM and install RT from source.
Documentation is fairly straightforward.

Not an option. I wasted a week trying to resolve an endless string of
dependencies and was never able to get anywhere close to where I am now.

The fact that there are RPMs available in the yum repositories is more
likely to mean that someone has been able to make them work, rather than
someone is just a sadistic bastard. I just wish they had bothered to
document the process.

Choose the method you prefer, but I would at least try. Other than Apache
and either mod_perl or some flavor of a FastCGI module, your only
dependencies are Perl modules. Install the CPAN installer and use the
‘make fixdeps’ option within the RT source code to install what it can.
Then install the rest of the rest of the modules via yum. Finally, the few
that possibly don’t install, get the source from CPAN and manually install
those last few Perl modules. At this point, you’re basically done.

You at least need to read the documentation on RT’s website to know how to
configure Apache as well as the RT_SiteConfig.pm file. Almost nothing you
install (Apache, Postfix, etc) via yum is going to work with the default
config files - you must read and understand the documentation and make the
changes necessary - this goes for RT as well.

Lastly, you should download the RT source, gunzip, untar, etc, read the
docs, do a ‘./configure’ and then do ‘make testdeps’ to see if you are
missing any dependencies that should have been installed during the yum
install of RT. At least that will tell you if you are missing anything.

If you are unwilling to do this, that’s fine, but the help you receive on
this site is going to be limited.

James Moseley

         John Oliver                                                   
         <joliver@john-oli                                             
         ver.net>                                                   To 
         Sent by:                  rt-users@lists.bestpractical.com    
         rt-users-bounces@                                          cc 
         lists.bestpractic                                             
         al.com                                                Subject 
                                   Re: [rt-users] Configuring Apache   
                                   for RT                              
         07/17/2007 06:07                                              
         PM                                                            

You state starting apache still fails… I assume you did do the
following:

yum install mod_fcgid

Yes.

Honestly, I would uninstall the RT3 RPM and install RT from source.
Documentation is fairly straightforward.

Not an option. I wasted a week trying to resolve an endless string of
dependencies and was never able to get anywhere close to where I am now.

The fact that there are RPMs available in the yum repositories is more
likely to mean that someone has been able to make them work, rather than
someone is just a sadistic bastard. I just wish they had bothered to
document the process.

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

First I had a lot of trouble installing RT from source too. (On
OpenSuSE10.2). It worked for me like the Gobnat’s “diary” at
http://wiki.bestpractical.com/view/OpenSuSE101InstallGuide. That
happened to me as I tried to evaluate RT on my working computer. Later
I installed it again on a server in our LAN without any possibility for
internet and the usage of yast or cpan or whatever. Was a little bit
annoying with all those perl dependencies, I bet I downloaded at least
50 and installed them seperately. I needed a whole morning until I was
done with perl. On the other hand I just took mandatory packages and
absolutely no optional. Seems this saved me a lot of trouble which
happened like in the above mentioned “diary”.

So my recommendation is to try to install RT from source and do not
install any optional packages from perl.

btw: Like Gobnat I didn’t get FCGI to work on OpenSuSE10.2 but mod_perl
works just fine.

To come back to topic: I didn’t change much in the default apache
configuration. Just added mod_perl and mod_php5 and set up some
variables and my vhosts.conf and it worked well since then.

I’ve spent much more time on configuring RT with all its rights etc and
I bet I’m not done yet :wink:

jmoseley@corp.xanadoo.com schrieb:

Choose the method you prefer, but I would at least try.  Other than Apache
and either mod_perl or some flavor of a FastCGI module, your only
dependencies are Perl modules.  Install the CPAN installer and use the
'make fixdeps' option within the RT source code to install what it can.
Then install the rest of the rest of the modules via yum.  Finally, the few
that possibly don't install, get the source from CPAN and manually install
those last few Perl modules.  At this point, you're basically done.

You at least need to read the documentation on RT’s website to know how to
configure Apache as well as the RT_SiteConfig.pm file. Almost nothing you
install (Apache, Postfix, etc) via yum is going to work with the default
config files - you must read and understand the documentation and make the
changes necessary - this goes for RT as well.

Lastly, you should download the RT source, gunzip, untar, etc, read the
docs, do a ‘./configure’ and then do ‘make testdeps’ to see if you are
missing any dependencies that should have been installed during the yum
install of RT. At least that will tell you if you are missing anything.

If you are unwilling to do this, that’s fine, but the help you receive on
this site is going to be limited.

James Moseley

         John Oliver                                                   
         <a class="moz-txt-link-rfc2396E" href="mailto:joliver@john-oliver.net">&lt;joliver@john-oli                                             
         ver.net&gt;</a>                                                   To 
         Sent by:                  <a class="moz-txt-link-abbreviated" href="mailto:rt-users@lists.bestpractical.com">rt-users@lists.bestpractical.com</a>    
         rt-users-bounces@                                          cc 
         lists.bestpractic                                             
         al.com                                                Subject 
                                   Re: [rt-users] Configuring Apache   
                                   for RT                              
         07/17/2007 06:07                                              
         PMOn Tue, Jul 17, 2007 at 04:36:26PM -0500, <a class="moz-txt-link-abbreviated" href="mailto:jmoseley@corp.xanadoo.com">jmoseley@corp.xanadoo.com</a> wrote:
You state starting apache still fails...  I assume you did do the
following:

yum install mod_fcgid

Yes.

  
Honestly, I would uninstall the RT3 RPM and install RT from source.
Documentation is fairly straightforward.
    
Not an option.  I wasted a week trying to resolve an endless string of
dependencies and was never able to get anywhere close to where I am now.

The fact that there are RPMs available in the yum repositories is more
likely to mean that someone has been able to make them work, rather than
someone is just a sadistic bastard. I just wish they had bothered to
document the process.

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

-- 
OSP Dresden
Benjamin Weser
+49 351 49723 102
weser@osp-dd.de