Compressed (Zipped) Folder Is Invalid

Came across an issue this week that I can’t solve.

A 4MB zip file containing TRC, TRM and TXT files was uploaded to an open ticket. It uploaded successfully but when anyone attempts to open or save it, they receive the following error message:

“The Compressed (Zipped) Folder Is Invalid”

I have tried the following:

  • Had the creator of the original zip file send it to me via email. I was able to open it without issue.
  • Created a test ticket and uploaded the zip file as is. Received error message when I tried to open it.
  • Separated the documents into two folders (2.4MB and 1.4MB), zipped them and uploaded them to the ticket. Received error message when I tried to open it.
  • Created a zip folder with several Word docs and uploaded it. Was able to upload and open it without issue.

Has anyone come across this before? Would appreciate any advice you might have!

UPDATE: Spoke to the original creator of the zip file. He said he zips in linux box. No idea if that could be making a difference.

UPDATE 2.0: It appears that it might be the file types causing the issue. I tried uploading individual files (TRC, TRM and TXT). I was able to open the originals on my computer with no problem. When I uploaded them and then opened from RT, they were unreadable. Just gobbledygook. It appears that RT must be corrupting these files for some reason.