Client denied by server configuration

Hello!

I’ve just installed rt 3.4 ( on gentoo ), and as far as I can tell, everything
went just fine… however when I try to access rt ( set up as a virtual host,
using fastcgi and apach2 ), I get a permision denied…

“client denied by server
configuration: /var/www/rt.server.org/rt-3.4.3/bin/mason_handler.fcgi”

Any ideas what’s going on here? Many thanks.

here’s my vhosts.conf

# Tell FastCGI to put its temporary files somewhere sane. FastCgiIpcDir /tmp

Tell FastCGI that it should use apache’s “suexec” binary to call any FastCGI

script.

This is a GLOBAL setting

FastCgiWrapper /usr/sbin/suexec2

Apache 1.3 discards the user and group parameters on the FastCgiServer line.

Apache 2.0 requires them.

FastCgiServer /var/www/rt.server.org/rt-3.4.3/bin/mason_handler.fcgi
-idle-timeout 120 -user rt -group rt -processes 4

ServerName rt.server.org DocumentRoot /var/www/rt.server.org/htdocs/rt ServerAdmin admin@server.org AddDefaultCharset UTF-8 UserDir disabled # Set the rt user and group as the executing user for this virtual host SuexecUserGroup rt rt AddHandler fastcgi-script fcgi ScriptAlias / /var/www/rt.server.org/rt-3.4.3/bin/mason_handler.fcgi/ Options Indexes FollowSymLinks AllowOverride None Order allow,deny Allow from all

Well - after some further google’ing, I happened upon this:
http://groups.google.com/group/linux.gentoo.user/browse_thread/thread/c3fc72f59874af26/24690932b4194db8%2324690932b4194db8?sa=X&oi=groupsr&start=0&num=3

I had to specify a Directory directive for the location of
’mason_handler.fcgi’ - which, in my case was in
’/var/www/rt.server.org/rt-3.4.3/bin/’ .

I added the following to my VirtHost:

<Directory /var/www/rt.server.org/rt-3.4.3/bin>
Options FollowSymLinks
Order allow,deny
allow from all

That did the trick!

Hope this helps the others on the list who have experienced this same issue.

Beers!

CoreyOn Sunday 18 September 2005 03:13 am, Corey wrote:

Hello!

I’ve just installed rt 3.4 ( on gentoo ), and as far as I can tell,
everything went just fine… however when I try to access rt ( set up as a
virtual host, using fastcgi and apach2 ), I get a permision denied…

“client denied by server
configuration: /var/www/rt.server.org/rt-3.4.3/bin/mason_handler.fcgi”

Any ideas what’s going on here? Many thanks.

here’s my vhosts.conf

# Tell FastCGI to put its temporary files somewhere sane. FastCgiIpcDir /tmp

Tell FastCGI that it should use apache’s “suexec” binary to call any

FastCGI # script.

This is a GLOBAL setting

FastCgiWrapper /usr/sbin/suexec2

Apache 1.3 discards the user and group parameters on the FastCgiServer

line. # Apache 2.0 requires them.
FastCgiServer /var/www/rt.server.org/rt-3.4.3/bin/mason_handler.fcgi
-idle-timeout 120 -user rt -group rt -processes 4

ServerName rt.server.org DocumentRoot /var/www/rt.server.org/htdocs/rt ServerAdmin admin@server.org AddDefaultCharset UTF-8 UserDir disabled # Set the rt user and group as the executing user for this virtual host SuexecUserGroup rt rt AddHandler fastcgi-script fcgi ScriptAlias / /var/www/rt.server.org/rt-3.4.3/bin/mason_handler.fcgi/ Options Indexes FollowSymLinks AllowOverride None Order allow,deny Allow from all _______________________________________________ http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com