Clearing RT3 and restoring

I have RT 3.6.0 configured and running on a test
server. In trying to restore my live RT 3.4.3
database backup into 3.6.0, I get the following
error:

ERROR 1153 (08S01) at line 80: Got a packet bigger
than ‘max_allowed_packet’ bytes

I changed my my.cnf to include:
[mysqld]
max_allowed_packet=16M

I have much less available disk space now that the
first attempt at restoring aborted. How do I clear
the rt3 database to free up some space so that I can
restart the restore? Also is 16M the recommended size
for max_allowed_packet?

Thanks,
Shannon

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Shannon Adams wrote:

I have RT 3.6.0 configured and running on a test
server. In trying to restore my live RT 3.4.3
database backup into 3.6.0, I get the following
error:

ERROR 1153 (08S01) at line 80: Got a packet bigger
than ‘max_allowed_packet’ bytes

I changed my my.cnf to include:
[mysqld]
max_allowed_packet=16M

I have much less available disk space now that the
first attempt at restoring aborted. How do I clear
the rt3 database to free up some space so that I can
restart the restore? Also is 16M the recommended size
for max_allowed_packet?

Thanks,
Shannon


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Just drop the database, create it again as a blank database and import
again. I ran into this problem as well when trying to import our live
database onto a test server. Not only did I adjust the max_allow_packet
option in my.cnf but also used the --max_allowed_packet option for the
actual mysql interface. I ended up setting both to 32M and didn’t have
any problems.

Mathew Snyder