Characterset/umlauts

Hi list,

I started to build a small intranet around our RT-system and have a
problem with special characters. In fact my RT displays stuff like umlauts
corret, but my intranet (running on the same virtual-host, it’s even
located in the same document root, so I don’t get it…) displays those
characters in weird sequences like

ü => ü

The content comes from the database and even if I display stuff from RT-
tables with umlauts (like ticket subject) on my intranet it’s not shown
correctly. I know that this is not a RT-specific question, but I’d like to
know how this is done in RT, 'cause I couldn’t find anything related to
that myself.

Thanks a lot in advance
-fe

Maillinglisten wrote:

Hi list,

I started to build a small intranet around our RT-system and have a
problem with special characters. In fact my RT displays stuff like umlauts
corret, but my intranet (running on the same virtual-host, it’s even
located in the same document root, so I don’t get it…) displays those
characters in weird sequences like

� => ü

It’s not very clear to me what “build an intranet around RT” means, but
what you are seeing is the UTF-8 encoding of umlaut characters rendered
as Latin-1/ISO-8859-1. Make sure the procedure generating HTML is
specifing UTF-8 as Content-Encoding, or otherwise convert the text
accordingly.

Angelo Turetta

ü => ü

Looks like your system stores UTF8 and your browser displays something
else.

Try setting character set on your intranet. You can test first by
picking the character set manually in your browser (View -> Character
Coding in Firefox). I suspect you should try UTF8.

If this works, you can change the default character set by tweaking the
Content-Type http header in your intranet script or adding a meta tag in
the html code (the head part)

I hope this helps.

Mikko Lipasti
Polarcom Consulting Oy
040 - 5590 988

signature.asc (189 Bytes)

My test-file’s source looks like this

Tüüäüst

which gets displayed

Tü���st

Which character set does your editor use when saving the file? You see,
the problem might be that your editor stores Latin-1 and SQL stores and
returns UTF8.

Try telling the editor to write UTF8. At least kwrite lets you pick the
character set to use in the save dialog.

emacs is set to utf8, works fine

which is not the same as before, but still not the correct. I still
think my problem could be solved somewhere on the
server/scripts/components
but I’m to mixed up of that charset-stuff -.-

Out of curiosity, which operating system are you using? I’m having
character set prolems on my SuSE Linux Enterprise 9 box but I’m not
going to look into it as it is merely a test platform and will be
decommisioned shortly.

gentoo linux

Best of luck. Character set problems are nasty. Can’t really trust
anything but a hex editor if things get really hairy…

I found my problem, which was the quote-function of dbd::mysql which killed the stuff getting to the database and in return I got 2 characters for 1… My problem is fixed but I agree that this is no fun :slight_smile:

thx!
-fe