Change default behaviour of "On Correspond Notify Requestors and Ccs"


A customer have asked us for not receiving notifications of his own ticket replies. I’m agree with him because I think he doesn’t need to be notified on a message sended by himself.

I have been doing some tests. When I disable the “On Correspond Notify Requestors and Ccs” scrip for the corresponding queue, the Requestor doesn’t receive his own replies anymore, but neither mine.

How can I change this behaviour? Can RT send mails to Requestor only when is not himself who replies?

Thanks for your help.

There is a configuration variable for this $NotifyActor, see here:


Thanks for your reply.

Setting $NotifyActor to 0 works but not as I expected.

Two drawbacks:

  1. It’s OK regarding Requestors side because they don’t receive their own replies anymore as I wanted. But considering that I’m AdminCC of the queue, I would like to receive my own replies allways.

  2. The setting is not by queue.

I feel like what I’m asking is not possible.

Thanks again for your help.

No out of stock RT. You have to write a custom condition.