Change Auto-Submitted: in template


#1

Hello all
Using the templates is there a way to change the Auto-Submitted: field from “auto-replied” to “No”

I added
Auto-Submitted: No
to the template with no success.

Thanks


#2

Hi

What are you trying to achieve?

regards
Garry


#3

Gary

I have an automated ticketing system that is sending emails to RT which RT creates tickets from(Working great). Their system requires an email response email with the word “Accept” at the beginning of the email. If I do a reply from outlook or from the ticket that was created it RT their system is updated that we accepted the email. I setup a script and a template to have RT auto-reply to these emails however their system does not accepted and update their system. I can not reach anyone in there it department that understands that RT email address needs to be white listed (Whatever the term maybe.) so their system will accept the automated update.

Some of these email are auto processed by RT and no human needs to look at the email. In these cases the system needed to respond with a “Close” to close the ticket on the other end.

I have read online that some ticketing system will ignore the email when it is machine generated. I understand that this is to eliminated auto-reply loops. It is my understanding that the Auto-Submitted field is used for this delineation. I have also looked at the different email headers and this field is different when the process is done in different ways.

Hope this helps explain what I am trying to accomplish.

Thanks
Bryon Baker

By the way Gray I got this message when I sent this message from my outlook client.

We’re sorry, but your email message to [“forum+0a7ef2ef2d4a895205adda13968a6257@bestpractical.com”] (titled RE: [Request Tracker Community Forum] [RT Users] Change Auto-Submitted: in template) didn’t work.

Your email was marked as “auto generated”, which means it was automatically created by a computer instead of being typed by a human; we can’t accept those kinds of emails. If you believe this is an error, contact a staff member.


#4

You may wish to also remove the precedence header as well:
https://docs.bestpractical.com/rt/4.4.4/RT_Config.html#DefaultMailPrecedence


#5

Craig

I don’t understand. RT is not sending email to it’s self it is interacting with some other unknown ticketing system out of my control.

Can you give some examples of what I would add to the template?

Thanks
Bryon


#6

Garry

Sorry for the misspelling of your name.

Thanks
Bryon


#7

By default RT’s automatic outgoing mail adds a Precedence: bulk header which some systems may flag as spam or auto generated.

Note that you can set the precedence of individual templates by including an explicit Precedence header.

You can manually set the precedence value in your template that is currently auto replying to the emails.


#8

Craig

Can’t seem to get the flag to change.

Template is

Content-Type: text/html

Subject: RE: {$Ticket->Subject}
Precedence: undef

accept

{$Transaction->Content()}

Header is
Date: Thu, 09 May 2019 16:55:19 -0500
X-Managed-BY: RT 4.2.3 (http://www.bestpractical.com/rt/)
Auto-Submitted: auto-replied
References: <RT-Ticket-1489039@Copsean_Service_Inc>
Precedence: bulk

Temple is
Content-Type: text/html

Subject: RE: {$Ticket->Subject}
Set($DefaultMailPrecedence, undef)

accept

{$Transaction->Content()}

Header is
Same as above.

Thanks
Bryon


#9

All your headers go before the first line break, does it work if you put it directly below Content-Type: text/html?