CentOS 5.4 Fresh Install - Perl issues following guide

I’ve got a freshly installed CentOS box, and I’ve updated everything via
yum. Rebooted to ensure everything is working as expected, and again did
a yum update.

I believe this is the version of RT rt3-3.6.5-1.el5.noarch.rpm that I am
trying to install. I am using the guide found at

http://wiki.bestpractical.com/view/CentOS5InstallGuide

I followed the guide, and I got the message below.

Sys::Syslog version 0.16 required–this is only version 0.13

This is only one, earlier in the day I had to deal with a perl module
dependency to do with MySQL.

If the method has changed for CentOS 5.4, or anyone with a bit more
expertise in perl and rt - could take a look, and see if the link in the
wiki needs to be updated. I would update it myself, but I am yet to find
a solution.

I’ve got a freshly installed CentOS box, and I’ve updated everything via
yum. Rebooted to ensure everything is working as expected, and again did
a yum update.

I believe this is the version of RT rt3-3.6.5-1.el5.noarch.rpm that I am
trying to install. I am using the guide found at

http://wiki.bestpractical.com/view/CentOS5InstallGuide

I followed the guide, and I got the message below.

Sys::Syslog version 0.16 required–this is only version 0.13

You mention an RPM with an out of date version (3.6.5) but an error
message that would only occur on a modern 3.8 version.

Is there a reason you don’t just run cpan Sys::Syslog to satisfy the
dep? CentOS apparently doesn’t package a modern Sys::Syslog

-kevin

I installed many RT systems on CentOS/RHEL and now my prefered method
is installing everything with CPAN. Managing perl dependencies RPMs is
really a mess, you don’t have all of them in the same repository, and
you need some updated modules bundled with the default perl RPM
package.

I recommend just installing a default centos/redhat (with a default
perl package, updated to the last available version with yum update),
and then install the perl dependencies with CPAN and make fixdeps.

If I remember well, this syslog module is part of the default perl
package so even if you find a recent rpm, you’ll get a dependency
problem.

Get the tarball
uncompress it
./configure with your options,
install the RPMs dependencies you need for this (not perl packages.
For example, httpd, mod_perl, graphviz etc…)
export PERL_MM_USE_DEFAULT=1
make fixdeps
make testdeps
make install

L.B.

I installed many RT systems on CentOS/RHEL and now my prefered method
is installing everything with CPAN. Managing perl dependencies RPMs is
really a mess, you don’t have all of them in the same repository, and
you need some updated modules bundled with the default perl RPM
package.

I recommend just installing a default centos/redhat (with a default
perl package, updated to the last available version with yum update),
and then install the perl dependencies with CPAN and make fixdeps.

If I remember well, this syslog module is part of the default perl
package so even if you find a recent rpm, you’ll get a dependency
problem.

Get the tarball
uncompress it
./configure with your options,
install the RPMs dependencies you need for this (not perl packages.
For example, httpd, mod_perl, graphviz etc…)
export PERL_MM_USE_DEFAULT=1
make fixdeps
make testdeps
make install

This is the approach I was going for originally, to compile from source,
I don’t know why I changed my mind to go with the RPM’s, but I guess
CPAN and SOURCE should be the way to go. Oh, and umm, if your installing
a bare bones system, please remember to install gcc as well!!!

just noticed this was causing problems!

I’ve got a freshly installed CentOS box, and I’ve updated everything via
yum. Rebooted to ensure everything is working as expected, and again did
a yum update.

I believe this is the version of RT rt3-3.6.5-1.el5.noarch.rpm that I am
trying to install. I am using the guide found at

http://wiki.bestpractical.com/view/CentOS5InstallGuide

I followed the guide, and I got the message below.

Sys::Syslog version 0.16 required–this is only version 0.13

Okay, I noticed that in my hast to create a streamlined superfast VM, I
umm, forgot to install gcc, which seems to be making a slight difference!