CC emails not always being sent

We’re having a small issue with our RT 4.0.18. Email seems to be flowing fine to Requestors and the Owners. However on two occasions, a manager wanted to include two other managers (neither of which have an account on this RT server). So he added their email addresses as CC’s. Neither manager got the email. He did say when he made a Comment and not a Reply, that the managers could see it.

Did I miss a permission setting somewhere, or what could be causing this. I will be upgraded to 4.2.0 (hopefully) by next month. I’ve done an upgrade with a test system & saw some errors/warnings I didn’t like.

Thanks!

Stephen Cena
QVII
MIS/IT Dept
850 Hudson Ave.
Rochester, NY. 14620
585-544-0450 x300
sjc@qvii.commailto:sjc@qvii.com
"Thank you for helping us help you help us all."
–For email related issues, please contact postmaster@qvii.commailto:postmaster@qvii.com

Stephen,

Did your notify scrip include “others”. Adding cc’s requires that if they
are not listed in the ticket or queue as “cc”.

KennFrom: Cena, Stephen (ext. 300) SJC@qvii.com
Sent: 10/23/2013 9:49 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] CC emails not always being sent

We’re having a small issue with our RT 4.0.18. Email seems to be flowing
fine to Requestors and the Owners. However on two occasions, a manager
wanted to include two other managers (neither of which have an account on
this RT server). So he added their email addresses as CC’s. Neither manager
got the email. He did say when he made a Comment and not a Reply, that the
managers could see it.

Did I miss a permission setting somewhere, or what could be causing this. I
will be upgraded to 4.2.0 (hopefully) by next month. I’ve done an upgrade
with a test system & saw some errors/warnings I didn’t like.

Thanks!

Stephen Cena
QVII
MIS/IT Dept
850 Hudson Ave.
Rochester, NY. 14620
585-544-0450 x300
sjc@qvii.com
“Thank you for helping us help you help us all.”
–For email related issues, please contact postmaster@qvii.com

Yes, I have a “On Correspond Notify Other Recipients”, Condition “On Correspond”, Action “Notify Other Recipients”, using the stock global template. Stage TransactionCreate.

Stephen Cena
QVII
MIS/IT Dept
850 Hudson Ave.
Rochester, NY. 14620
585-544-0450 x300
sjc@qvii.commailto:sjc@qvii.com
“Thank you for helping us help you help us all.”
–For email related issues, please contact postmaster@qvii.commailto:postmaster@qvii.comFrom: Kenneth Crocker [mailto:kenn.crocker@gmail.com]
Sent: Wednesday, October 23, 2013 6:11 PM
To: Cena, Stephen (ext. 300); rt-users@lists.bestpractical.com
Subject: RE: [rt-users] CC emails not always being sent

Stephen,

Did your notify scrip include “others”. Adding cc’s requires that if they are not listed in the ticket or queue as “cc”.

Kenn

Hi Stephen,

There is configuration option NotifyActor.
If it set to 0, RT does not notify person who performs the update of the
ticket. Even if this person is in CC.
Please check, maybe this is your case.

Best regards,
RafalFrom: “Cena, Stephen (ext. 300)” SJC@qvii.com
To: Kenneth Crocker kenn.crocker@gmail.com,
rt-users@lists.bestpractical.comrt-users@lists.bestpractical.com
Date: 2013-10-25 15:21
Subject: Re: [rt-users] CC emails not always being sent
Sent by: rt-users-bounces@lists.bestpractical.com

Yes, I have a “On Correspond Notify Other Recipients”, Condition “On
Correspond”, Action “Notify Other Recipients”, using the stock global
template. Stage TransactionCreate.

Stephen Cena
QVII
MIS/IT Dept
850 Hudson Ave.
Rochester, NY. 14620
585-544-0450 x300
sjc@qvii.com
“Thank you for helping us help you help us all.”
–For email related issues, please contact postmaster@qvii.com

From: Kenneth Crocker [mailto:kenn.crocker@gmail.com]
Sent: Wednesday, October 23, 2013 6:11 PM
To: Cena, Stephen (ext. 300); rt-users@lists.bestpractical.com
Subject: RE: [rt-users] CC emails not always being sent

Stephen,

Did your notify scrip include “others”. Adding cc’s requires that if they
are not listed in the ticket or queue as “cc”.

Kenn

Rafal - I think that might be it. I just checked, and my RT_Config has that set to 0.
I’ll try changing it to 1 in my RT_SiteConfig, notify the users & see what I get.

Thanks!!Date: Fri, 25 Oct 2013 19:29:55 +0200
From: Rafal Matera RMatera@esselte.com
To: “rt-users@lists.bestpractical.com
rt-users@lists.bestpractical.com
Subject: Re: [rt-users] CC emails not always being sent
Message-ID:
OF203E7DC4.EF7ABE89-ONC1257C0F.005FC31C-C1257C0F.0060203D@esselte.com

Content-Type: text/plain; charset=“us-ascii”

Hi Stephen,

There is configuration option NotifyActor.
If it set to 0, RT does not notify person who performs the update of the ticket. Even if this person is in CC.
Please check, maybe this is your case.

Best regards,
Rafal

Rafal - After making that change, I’m now getting extra emails:

Thu Oct 31 09:20:09 2013: Request 1934 was acted upon.
Transaction: Taken by s.cena
Queue: Network/Wifi Requests
Owner: s.cena
Requestors: XXXXXXXXXXXXXXXXX
Status: new
Ticket <URL: http://helpdesk/Ticket/Display.html?id=1934 >

This transaction appears to have no content

Is this expected when I change NotifyActor to 1, or is this another setting that’s causing this?-----Original Message-----
From: Cena, Stephen (ext. 300)
Sent: Thursday, October 31, 2013 8:51 AM
To: ‘rt-users@lists.bestpractical.com’
Subject: Re: CC emails not always being sent

Rafal - I think that might be it. I just checked, and my RT_Config has that set to 0.
I’ll try changing it to 1 in my RT_SiteConfig, notify the users & see what I get.

Thanks!!

Date: Fri, 25 Oct 2013 19:29:55 +0200
From: Rafal Matera RMatera@esselte.com
To: “rt-users@lists.bestpractical.com
rt-users@lists.bestpractical.com
Subject: Re: [rt-users] CC emails not always being sent
Message-ID:
OF203E7DC4.EF7ABE89-ONC1257C0F.005FC31C-C1257C0F.0060203D@esselte.com

Content-Type: text/plain; charset=“us-ascii”

Hi Stephen,

There is configuration option NotifyActor.
If it set to 0, RT does not notify person who performs the update of the ticket. Even if this person is in CC.
Please check, maybe this is your case.

Best regards,
Rafal

Rafal - After making that change, I’m now getting extra emails:
Is this expected when I change NotifyActor to 1, or is this another setting that’s causing this?

As expected.
http://bestpractical.com/docs/rt/latest/RT_Config.html#NotifyActor

With that config set, RT will send you any email caused as a result of
your action, rather than suppressing them (the RT default).

-kevin

I thought that might be the case. Is there a better way to ensure that CC emails are always sent? Both our Service Dept & the IT Dept will add users to the CC’s as needed. In both RT systems, I have a “On Correspond Notify Others” Scrip and thought that would cover it.

What is the proper/recommended way to ensure all CC users get their emails without extra emails getting generated?

Message: 9Date: Fri, 1 Nov 2013 12:46:42 -0700
From: Kevin Falcone falcone@bestpractical.com
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] CC emails not always being sent
Message-ID: 20131101194642.GI1829@jibsheet.com
Content-Type: text/plain; charset=“us-ascii”

I thought that might be the case. Is there a better way to ensure that
CC emails are always sent? Both our Service Dept & the IT Dept will
add users to the CC’s as needed. In both RT systems, I have a “On
Correspond Notify Others” Scrip and thought that would cover it.

What is the proper/recommended way to ensure all CC users get their emails without extra emails getting generated?

On Correspond Notify CCs is the proper scrip to ensure that Ticket
CCs get their email.

On Correspond Notify other recipients is the proper scrip to ensure
that one time CCs and BCCs get their email.

Please note the difference between Ticket CCs and the one-time-CCs,
these are handled by different Scrip actions.

-kevin

Kevin - Thank you. I’ll go check both systems to be sure those are running/enabled. That sounds like it will work better than the NotifyActor fix I used. That is working, but extra emails are being sent out. I’ll follow up once I get caught up here. Being out for two days sure causes work to pile up!

Message: 10Date: Tue, 5 Nov 2013 16:09:07 -0500
From: Kevin Falcone falcone@bestpractical.com
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] CC emails not always being sent
Message-ID: 20131105210907.GM1829@jibsheet.com
Content-Type: text/plain; charset=“us-ascii”