Can't find a saved search to work with

Hi all,

i am trying to allow my helpdesk staff group to save and edit their
own group of searches - when I give group rights, create a new query
and attempt to save to ‘my saved searches’ they get this message on
the top of the query screen :

“Can’t find a saved search to work with”

I assume I am making an error with rights somewhere along the line -
but can’t determine where. Any thoughts?

Cheers,

Sean Daniels

hi,

did you found a solution for the problem?
the saved searches worked only for my root user and when i add a user root rights, but these rights to much for this user.

greetings
gregor

Greg,

What about the “Search” rights, “LoadSavedSearch”, “ShowSavedSearch”, etc.?

Kenn
LBNLOn Mon, Nov 15, 2010 at 9:59 AM, Gregor Binder gregor.binder@gmx.netwrote:

hi,

did you found a solution for the problem?
the saved searches worked only for my root user and when i add a user root
rights, but these rights to much for this user.

greetings
gregor

these rights are set to the user but doesn’t take effect.

gregor----- Forwarded Message -----

Greg,

What about the “Search” rights, “LoadSavedSearch”, “ShowSavedSearch”,
etc.?

Kenn
LBNL

On Mon, Nov 15, 2010 at 9:59 AM, Gregor Binder < gregor.binder@gmx…net > wrote:

hi,

did you found a solution for the problem?
the saved searches worked only for my root user and when i add a user
root rights, but these rights to much for this user.

greetings
gregor

Greg,

We grant these rights Globally to ALL Privileged users and have no problem
with them.

Kenn
LBNLOn Mon, Nov 15, 2010 at 10:25 AM, Gregor Binder gregor.binder@gmx.netwrote:

these rights are set to the user but doesn’t take effect.

gregor

----- Forwarded Message -----

Greg,

What about the “Search” rights, “LoadSavedSearch”, “ShowSavedSearch”,
etc.?

Kenn
LBNL

On Mon, Nov 15, 2010 at 9:59 AM, Gregor Binder < gregor.binder@gmx…net > wrote:

hi,

did you found a solution for the problem?
the saved searches worked only for my root user and when i add a user
root rights, but these rights to much for this user.

greetings
gregor

I have a few tickets which, when opened, did not properly wrap lines.
The entire issue statement is a single line. When the ticket is selected
and the issue is displayed, RT only shows me the left-most characters
of the statement. Is there a way to edit that statement to insert the
needed NL characters? (RT 3.8.7 on Linux)
Dave Close, Thales Avionics, Irvine California USA
Software integration and performance testing
cell +1 949 394 2124, dave.close@us.thalesgroup.com

I don’t send HTML email and I prefer not to receive it.
HTML email is ugly and a significant security exposure.

Dave,

Set your RT_SiteConfig.pm settings to:

Set($MessageBoxWrap, “HARD”);
*Set($MessageBoxRichText, 0);

Set($PlainTextPre, 1);
Set($PlainTextMono, 1);

This works for us.

Kenn
LBNLOn Mon, Nov 15, 2010 at 11:01 AM, CLOSE Dave (DAE) < Dave.Close@us.thalesgroup.com> wrote:

I have a few tickets which, when opened, did not properly wrap lines.
The entire issue statement is a single line. When the ticket is selected
and the issue is displayed, RT only shows me the left-most characters
of the statement. Is there a way to edit that statement to insert the
needed NL characters? (RT 3.8.7 on Linux)

Dave Close, Thales Avionics, Irvine California USA
Software integration and performance testing
cell +1 949 394 2124, dave.close@us.thalesgroup.com

I don’t send HTML email and I prefer not to receive it.
HTML email is ugly and a significant security exposure.

i gave these rights to all users and groups that i found in my system but it doesn’t work. but i have one group for the admins an in this group i can create a saved-search but these search then appears on all users that are members of the admin group.
but the single user savedsearch have the same problem.

which version do you use of rt?

rights that i set:
CreateSavedSearch
EditSavedSearches
LoadSavedSearch
ShowSavedSearches

version: 3.6.10

greetings
gregor----- Original Message -----

Greg,

We grant these rights Globally to ALL Privileged users and have no
problem with them.

Kenn
LBNL

On Mon, Nov 15, 2010 at 10:25 AM, Gregor Binder < gregor.binder@gmx.net > wrote:

these rights are set to the user but doesn’t take effect.

gregor

----- Forwarded Message -----

Greg,

What about the “Search” rights, “LoadSavedSearch”,
“ShowSavedSearch”,
etc.?

Kenn
LBNL

On Mon, Nov 15, 2010 at 9:59 AM, Gregor Binder < gregor.binder@gmx…net > wrote:

hi,

did you found a solution for the problem?
the saved searches worked only for my root user and when i add a
user
root rights, but these rights to much for this user.

greetings
gregor

Greg,

We are now on 3.8.7, but have had these privileges granted Globally since
3.4.5 and have never had a problem. Perhaps you are granting these rights at
a level that is too granular. I see no reason to keep these rights from
anyone, so why not keep it simple and grant them globally to all privileged?

Kenn
LBNLOn Mon, Nov 15, 2010 at 12:11 PM, Gregor Binder gregor.binder@gmx.netwrote:

i gave these rights to all users and groups that i found in my system but
it doesn’t work. but i have one group for the admins an in this group i can
create a saved-search but these search then appears on all users that are
members of the admin group.
but the single user savedsearch have the same problem.

which version do you use of rt?

rights that i set:
CreateSavedSearch
EditSavedSearches
LoadSavedSearch
ShowSavedSearches

version: 3.6.10

greetings
gregor

----- Original Message -----

Greg,

We grant these rights Globally to ALL Privileged users and have no
problem with them.

Kenn
LBNL

On Mon, Nov 15, 2010 at 10:25 AM, Gregor Binder < gregor.binder@gmx.net > wrote:

these rights are set to the user but doesn’t take effect.

gregor

----- Forwarded Message -----

Greg,

What about the “Search” rights, “LoadSavedSearch”,
“ShowSavedSearch”,
etc.?

Kenn
LBNL

On Mon, Nov 15, 2010 at 9:59 AM, Gregor Binder < gregor.binder@gmx…net > wrote:

hi,

did you found a solution for the problem?
the saved searches worked only for my root user and when i add a
user
root rights, but these rights to much for this user.

greetings
gregor

I asked:

I have a few tickets which, when opened, did not properly wrap lines.
The entire issue statement is a single line. When the ticket is
selected and the issue is displayed, RT only shows me the left-most
characters of the statement. Is there a way to edit that statement to
insert the needed NL characters? (RT 3.8.7 on Linux)

Kenneth Crocker answered:

Set your RT_SiteConfig.pm settings to:
Set($MessageBoxWrap, “HARD”);
Set($MessageBoxRichText, 0);
Set($PlainTextPre, 1);
Set($PlainTextMono, 1);
This works for us.

Thanks, but that doesn’t fix it here. It might help avoid any future
tickets with the problem but doesn’t change the appearance of existing
ones. I’m not referring to attachments (PlainText…).
Dave Close, Thales Avionics, Irvine California USA

Hi,

Any details on reproducing problem and your rt config?

Regards, Ruslan. From phone.
2010 11 15 22:01 пользователь “CLOSE Dave (DAE)” <
Dave.Close@us.thalesgroup.com> написал:

Hi,

I didn’t look into saved searches rights for a while, but recall some
"smartiness" there. You can share searches with members of a group by saving
them with different privacy level. To do this you must be a member of the
group and have right on that group. This means that admin can not save
search for group x unless he is member of that group. He can add himself
temporarily to do the job.

Regards, Ruslan. From phone.

Greg,

We are now on 3.8.7, but have had these privileges granted Globally since
3.4.5 and have never had a problem. Perhaps you are granting these rights
at
a level that is too granular. I see no reason to keep these rights from
anyone, so why not keep it simple and grant them globally to all
privileged?

Kenn
LBNL

i gave these rights to all users and groups that i found in my system but
it doesn’t work. but i have one group for the admins an in this group i
can