Can't attach screen shots RT 4.4.4

Using RT 4.4.4.4, When trying to attach screenshots to a ticket I get the following error. Has anyone else had this issue?

What do the RT logs say?

This is what’s logged after I submit the attachment (log level debug).

Jun 4 13:56:11 rtweb0-ztc RT: [2178] Rendering attachment #1636293 of ‘text/html’ type (/opt/rt4/share/html/Elements/ShowTransactionAttachments:191)
Jun 4 13:56:11 rtweb0-ztc RT: [2178] Rendering attachment #1636337 of ‘text/plain’ type (/opt/rt4/share/html/Elements/ShowTransactionAttachments:191)
Jun 4 13:56:11 rtweb0-ztc RT: [2178] Rendering attachment #1636343 of ‘text/html’ type (/opt/rt4/share/html/Elements/ShowTransactionAttachments:191)
Jun 4 13:56:11 rtweb0-ztc RT: [2178] Rendering attachment #1636348 of ‘text/plain’ type (/opt/rt4/share/html/Elements/ShowTransactionAttachments:191)

Are there any error lines in the log around that time? Those logs look like the ticket display page

No, that’s all it logs.

You are able to reproduce this issue still?

Yes, it happens every time.

And attaching of some binary file works? Is it the same for drag-and-drop and for click-and-select? Attachments from e-mail works?

I can attach PDFs, and even most PNG and JPEG images, but for some reason screenshots throw an error.

Both drag-and-drop and click-and select fail.

That’s weird :slight_smile: Does examination of log files in /var/log/apache2/ give some clue? BTW the screenshots are what file type?

The screenshots are JPEG, but some JPEG images do upload fine. Below is what I get in the apache logs when it fails. I don’t get this message when an upload works.

[Mon Jun 08 11:29:17.459884 2020] [fcgid:warn] [pid 8145:tid 139686320252672] [client x.x.x.x:35615] mod_fcgid: HTTP request length 132274 (so far) exceeds MaxRequestLen (131072), referer: http://example.org.net/Ticket/Update.html?Action=Respond;id=20200424072

You need to set these two config values for your Apache fcgid config:

FcgidConnectTimeout
FcgidMaxRequestLen

If you’re on Ubuntu the config file can be located /etc/apache2/mods-enabled/fcgid.conf

That worked, thank you!