Bug regarding CC: behavior

I have a queue called Testing. When I configure bugs@rtdomain.com to
submit to Testing with action correspond, it correctly creates a ticket.
However, RT adds bugs@rtdomain.com to the CC: list for the ticket.

In the Queue configuration for Testing, there is the field “Reply
Address:” underneath which is written, “(If left blank, will default to
bugs@rtdoamin.com”. (There is no close parenthesis on the web page.) So
I know the default address is bugs@rtdomain.com.

If I actually put the text "bugs@rtdomain.com" in the field, rather than
leaving it blank, then bugs@rtdomain.com is not added to the CC: list
for the new tickets.

In my opinion, this is buggy behavior - it should not add
bugs@rtdomain.com to the CC: list since it’s supposed to pick that up as
the default. (It was causing me the “RT thinks this is a bounce” problem
I had earlier.)

My workaround is to fill in bugs@rtdomain.com for each queue, but there
are a lot queues; and having to do this is wrong, given the word "default"
in the text.

– Asheesh.

I refuse to consign the whole male sex to the nursery. I insist on
believing that some men are my equals.
– Brigid Brophy

I have a queue called Testing. When I configure bugs@rtdomain.com to
submit to Testing with action correspond, it correctly creates a ticket.
However, RT adds bugs@rtdomain.com to the CC: list for the ticket.
I recommend you pay attenstion to $RTAddressRegexp option, see RT config.
Search examples in archives if you don’t know how to write regexps.

In the Queue configuration for Testing, there is the field “Reply
Address:” underneath which is written, “(If left blank, will default to
bugs@rtdoamin.com”. (There is no close parenthesis on the web page.) So
I know the default address is bugs@rtdomain.com.

If I actually put the text "bugs@rtdomain.com" in the field, rather than
leaving it blank, then bugs@rtdomain.com is not added to the CC: list
for the new tickets.

In my opinion, this is buggy behavior - it should not add
bugs@rtdomain.com to the CC: list since it’s supposed to pick that up as
the default. (It was causing me the “RT thinks this is a bounce” problem
I had earlier.)
This should be checked. May be there is some bug in RT. What version
are you using?

My workaround is to fill in bugs@rtdomain.com for each queue, but there
are a lot queues; and having to do this is wrong, given the word "default"
in the text.
This very strange that you use one email address for different queues.
In normal situation people use two different addresses for each queue
first for correspondence and second for comments.

– Asheesh.


I refuse to consign the whole male sex to the nursery. I insist on
believing that some men are my equals.
– Brigid Brophy


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Best regards, Ruslan.