Blank outgoing emails still in RT 4.2.10

Hello,

we had problems with empty outgoing mails from RT. Searching in our log files, I found the same error as gilbert@dido.ca had. I found this mail below and thought the problem would be solved in RT 4.2.10

Now we have RT 4.2.10 but we still have the same problem. Customers receive an empty mail and in the log files I can find the following:
[error]: Failed to downgrade HTML to plain text: Can’t call method “content” on an undefined value at /usr/local/share/perl/5.18.2/HTML/FormatText/WithLinks/AndTables.pm line 217.
[…]

Now I switched to HTML template and found out that now the outgoing mails are OK. But the error messages in the log files are still there.
Should I care about this? When will there be a final solution?

Best regards
Bernhard-----Ursprüngliche Nachricht-----
Von: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] Im Auftrag von Alex Vandiver
Gesendet: Donnerstag, 29. Januar 2015 20:50
An: juniorsa
Cc: rt-users@lists.bestpractical.com
Betreff: Re: [rt-users] RT 4.2.8 reply emails go out blank

On Thu, 29 Jan 2015 11:50:25 -0700 (MST) juniorsa gilbert@dido.ca wrote:

On certain email replies the mail arrives blank to the recipient.

This is caused by failure of the HTML -> Text rendering engine. It triggers on email (or comments/correspondence) which need to be embedded into plain-text templates; the most common failing case is HTML that includes tables.

We’re testing a branch (4.2/html-external-formatter) which we expect to be in 4.2.10; it addresses the problem by adding an optional dependency
(HTML::FormatExternal) which uses an external text-only browser (such as w3m or elinks) to render the HTML to text.

  • Alex

Hi,

you just have to read the release notes [1] or upgrading documentation
[2], it’s described in both.

Chris

[1] https://www.bestpractical.com/release-notes/rt/4.2.10
[2]
https://www.bestpractical.com/docs/rt/4.2/UPGRADING-4.2.html#UPGRADING-FROM-4.2.9-AND-EARLIERAm 24.03.2015 um 09:21 schrieb Eierschmalz, Bernhard:

Hello,

we had problems with empty outgoing mails from RT. Searching in our log files, I found the same error as gilbert@dido.ca had. I found this mail below and thought the problem would be solved in RT 4.2.10

Now we have RT 4.2.10 but we still have the same problem. Customers receive an empty mail and in the log files I can find the following:
[error]: Failed to downgrade HTML to plain text: Can’t call method “content” on an undefined value at /usr/local/share/perl/5.18.2/HTML/FormatText/WithLinks/AndTables.pm line 217.
[…]

Now I switched to HTML template and found out that now the outgoing mails are OK. But the error messages in the log files are still there.
Should I care about this? When will there be a final solution?

Best regards
Bernhard