Best way to avoid sending large attachments via email


#1

I’ve run into a issue (on RT 4.2.9) where an overly large attachment will
cause my (OS X Sierra) server to become resource starved. My guess is that
somewhere between Apache, FastCGI, RT, and postfix, attempting to send
(e.g.) a 50MB attachment using the “On Create Notify AdminCcs” scrip is
causing a timeout or similar.

$MaxAttachmentSize relates to the database, so doesn’t seem helpful in this
case. And was the only setting I could find.

I do like receiving email notifications on create (or modify) so I don’t
want to disable the scrip.

From what I can tell the best thing to do would be to:

Within NotifyOwnerOrAdminCc.pm my guess is that I would want to override
AddAttachment() from SendEmail.pm

… at which point my Perl-fu starts to fail me.

Does this seem like the right solution (to avoiding the sending of large
email attachments)? And does the rough outline of my plan make sense?

Thanks!

Jason


#2

Hi Jason,

Did you ever figure this out? I have a similar issue that having it insert a link when the attachment is large versus attaching it directly would be perfect.

Regards,
Ken


#3

This post was flagged by the community and is temporarily hidden.