Best practical Logo won't load

Hey Folks,

My best Practical Log isn’t showing up on my pages. I added the exception
to my httpd.conf to tell it not to pass the logo through fast_CGI and
restarted httpd, but it’s still not showing up. I have Apache 2.0.52 with
mysql 4.1.22 running on RHEL4.

This is what my httpd.conf looks like:

<VirtualHost *:80>
ServerAdmin sthomson@uua.org
ServerName rt.uua.org
ServerAlias rt2.uua.org
DocumentRoot /opt/rt3/share/html/

RedirectMatch permanent (.*)/$ http://rt2.uua.org$1/index.html

AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
CustomLog /var/log/httpd/rt-access_log combined
ErrorLog /var/log/httpd/rt-error_log

for RT docroot:

<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Pass through requests to for noauth

Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

/opt3/rt3/share/html/NoAuth/images is owned by apache:apache as is the file

It looks like the file is supposed to be here when you click on properties:
http://noauth/images//bplogo.gif

Is the extra slash between images and bplogo.gif supposed to be there? If
not, how do I get rid of it?

Thanks!

Scott

One place to double check is your RT_SiteConfig.pm and make sure that
your settings for the section below (sample from a 3.6.7 system I am
working on) are correct.

In most cases, you should leave $WebPath set to ‘’ (an empty value).

Set($WebPath , “/rt”);

If we’re running as a superuser, run on port 80

Otherwise, pick a high port for this user.

Set($WebPort , 443);# + ($< * 7274) % 32766 + ($< && 1024));

This is the Scheme, server and port for constructing urls to webrt

$WebBaseURL doesn’t need a trailing /

Set($WebBaseURL , “https://something.domain.com:$WebPort”);

Set($WebURL , $WebBaseURL . $WebPath . “/”);

$WebImagesURL points to the base URL where RT can find its images.

Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

$LogoURL points to the URL of the RT logo displayed in the web UI

Set($LogoURL , $WebImagesURL . “bplogo.gif”);On Tue, Dec 9, 2008 at 1:54 PM, Scott Thomson scott.e.thomson@gmail.com wrote:

Hey Folks,

My best Practical Log isn’t showing up on my pages. I added the exception
to my httpd.conf to tell it not to pass the logo through fast_CGI and
restarted httpd, but it’s still not showing up. I have Apache 2.0.52 with
mysql 4.1.22 running on RHEL4.

This is what my httpd.conf looks like:

<VirtualHost *:80>
ServerAdmin sthomson@uua.org
ServerName rt.uua.org
ServerAlias rt2.uua.org
DocumentRoot /opt/rt3/share/html/

RedirectMatch permanent (.*)/$ http://rt2.uua.org$1/index.html

AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
CustomLog /var/log/httpd/rt-access_log combined
ErrorLog /var/log/httpd/rt-error_log

for RT docroot:

<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Pass through requests to for noauth

Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

/opt3/rt3/share/html/NoAuth/images is owned by apache:apache as is the file

It looks like the file is supposed to be here when you click on properties:
http://noauth/images//bplogo.gif

Is the extra slash between images and bplogo.gif supposed to be there? If
not, how do I get rid of it?

Thanks!

Scott


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Aha! Thanks Brian!

It turns out that I was improperly setting WebPath in my site config

I had
Set($WebPath , “/”);

in my site config, I commented it out so that it would use the value from
RT_Config.pm and it started working.

There may have been a reason for that in RT3.4.5 which is what I just
upgraded from.

Cheers!

ScottOn Tue, Dec 9, 2008 at 7:18 PM, Brian Friday brian.friday@gmail.com wrote:

One place to double check is your RT_SiteConfig.pm and make sure that
your settings for the section below (sample from a 3.6.7 system I am
working on) are correct.

In most cases, you should leave $WebPath set to ‘’ (an empty value).

Set($WebPath , “/rt”);

If we’re running as a superuser, run on port 80

Otherwise, pick a high port for this user.

Set($WebPort , 443);# + ($< * 7274) % 32766 + ($< && 1024));

This is the Scheme, server and port for constructing urls to webrt

$WebBaseURL doesn’t need a trailing /

Set($WebBaseURL , “https://something.domain.com:$WebPort”);

Set($WebURL , $WebBaseURL . $WebPath . “/”);

$WebImagesURL points to the base URL where RT can find its images.

Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

$LogoURL points to the URL of the RT logo displayed in the web UI

Set($LogoURL , $WebImagesURL . “bplogo.gif”);

On Tue, Dec 9, 2008 at 1:54 PM, Scott Thomson scott.e.thomson@gmail.com wrote:

Hey Folks,

My best Practical Log isn’t showing up on my pages. I added the
exception
to my httpd.conf to tell it not to pass the logo through fast_CGI and
restarted httpd, but it’s still not showing up. I have Apache 2.0.52 with
mysql 4.1.22 running on RHEL4.

This is what my httpd.conf looks like:

<VirtualHost *:80>
ServerAdmin sthomson@uua.org
ServerName rt.uua.org
ServerAlias rt2.uua.org
DocumentRoot /opt/rt3/share/html/

RedirectMatch permanent (.*)/$ http://rt2.uua.org$1/index.html

AddDefaultCharset UTF-8
AddHandler fastcgi-script .fcgi
CustomLog /var/log/httpd/rt-access_log combined
ErrorLog /var/log/httpd/rt-error_log

for RT docroot:

<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Pass through requests to for noauth

Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

/opt3/rt3/share/html/NoAuth/images is owned by apache:apache as is the
file

It looks like the file is supposed to be here when you click on
properties:
http://noauth/images//bplogo.gif

Is the extra slash between images and bplogo.gif supposed to be there?
If
not, how do I get rid of it?

Thanks!

Scott


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com