Bad URL? I have the symptom, jut can't find the cause

Last week I reported users seeing page that looks something like this after
the login screen.

GNU %# General Public License for more details. %# %# Unless otherwise
specified, all modifications, corrections or %# extensions to this work
which alter its source code become the %# property of Best Practical
Solutions, LLC when submitted for %# inclusion in the work. %# %# %#
END LICENSE BLOCK

I’ve found the symptom, but not the cause…

It seems that whenever someone uses the link http://rtserver/rt/ they’ll
proceed normally into the “RT At A Glance” screen and are able to use RT as
normal. However, those that use the link http://rtserver/rt (note no
trailing slash) get the mangled GPL code above. I’ve looked at the
RT_SiteConfig.pm and httpd.conf, and can’t see a specific line where making
a change would allow both URLs to work.

There’s nothing in the Wiki on this either… anyone got any ideas? You
can find a snippet from my httpd.conf below.

Thanks,
Paul C.

thats because this has nothing to do with rt, its an apache thing take
a look ad directory indexOn Apr 4, 2005, at 3:31 PM, Paul Crossman wrote:

Last week I reported users seeing page that looks something like this
after
the login screen.

GNU %# General Public License for more details. %# %# Unless otherwise
specified, all modifications, corrections or %# extensions to this work
which alter its source code become the %# property of Best Practical
Solutions, LLC when submitted for %# inclusion in the work. %# %# %#
END LICENSE BLOCK

I’ve found the symptom, but not the cause…

It seems that whenever someone uses the link http://rtserver/rt/
they’ll
proceed normally into the “RT At A Glance” screen and are able to use
RT as
normal. However, those that use the link http://rtserver/rt (note no
trailing slash) get the mangled GPL code above. I’ve looked at the
RT_SiteConfig.pm and httpd.conf, and can’t see a specific line where
making
a change would allow both URLs to work.

There’s nothing in the Wiki on this either… anyone got any ideas?
You
can find a snippet from my httpd.conf below.

Thanks,
Paul C.

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-
bounces@lists.bestpractical.com] On Behalf Of Paul Crossman
Sent: Wednesday, March 30, 2005 5:19 PM
To: Drew Barnes
Cc: rt-users@lists.bestpractical.com
Subject: RE: Bad index.html page??? Was (RE: [rt-users] Keep getting
mysq
l is sues when running ‘make initialize-database’)

-----Original Message-----
From: Drew Barnes [mailto:barnesaw@ucrwcu.rwc.uc.edu]
Sent: Wednesday, March 30, 2005 1:55 PM
To: Paul Crossman
Cc: rt-users@lists.bestpractical.com
Subject: Re: Bad index.html page??? Was (RE: [rt-users] Keep getting
mysql
is sues when running ‘make initialize-database’)

Connection to the RT application is possible at this point for me,
but
others get a web page that starts off looking like this…

%# BEGIN LICENSE BLOCK %# %# Copyright © 1996-2003 Jesse Vincent
jesse@bestpractical.com %# %# (Except where explictly superceded
by
other
copyright notices) %# %# This work is made available to you under
the
terms
of Version 2 of %# the GNU General Public License. A copy of that
license

should have %# been provided with this software, but in any event
can
be

snarfed %# from www.gnu.org. %# %# This work is distributed in the
hope
that
it will be useful, but %# WITHOUT ANY WARRANTY; without even the
implied

warranty of %# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
See
the

GNU %# General Public License for more details. %# %# Unless
otherwise
specified, all modifications, corrections or %# extensions to this
work
which alter its source code become the %# property of Best Practical
Solutions, LLC when submitted for %# inclusion in the work. %# %# %#
END

LICENSE BLOCK

This sounds like an httpd.conf problem. What does the section you
set
up for RT look like?

DB

Here’s the sections from my httpd.conf file

<Location /NoAuth/images >
SetHandler default-handler

NameVirtualHost *:80
<VirtualHost *:80>
ServerAdmin root

DocumentRoot /var/www/html/

DocumentRoot /opt/rt3/share/html/
# Adding the following for RT (the ticket tracker)
AddHandler fastcgi-script fcgi
<Directory "/opt/rt3/share/html">
    Options FollowSymLinks ExecCGI
    AllowOverride None
</Directory>
# Pass through requests to display images
Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

Paul C.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon!
(Boston, San Francisco, Austin, Sydney) Contact
training@bestpractical.com
for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon!
(Boston, San Francisco, Austin, Sydney) Contact
training@bestpractical.com for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Steve RIeger
(212) 804-1132 (Work)
(646) 335-8915 (Cell)
chozrim (aim)

thats because this has nothing to do with rt, its an apache thing take
a look ad directory index

Which doesn’t at all preclude it going up on the wiki…

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

  If you can read this... thank a system administrator.  Or two.  --me