Auto-reply script problem

Hello.
In the last week we upgraded our rt instance from 4.0.19 to 4.2.8
Before the upgrade we had a script that would aupo-reply to all new
tickets created by email unless they went to 2 queues in which we would
not auto-reply at all.
Since the upgrade that script is sending out a message on all ticket
correspondence regardless of weather it’s a create or not.
The condition is set to user defined and the code in custom condition is
as follows.
($self->TransactionObj->Type || ‘’) eq ‘Create’
&&
($self->TicketObj->Status || ‘’) ne ‘resolved’
&&
($self->TicketObj->QueueObj->Name || ‘’) ne ‘SafeSentryPro’ ||
‘Security-Appliance-Review-Logs’

What’s wrong here or is it a different problem entirely?

Thanks.

Hello.

Your perl isn’t correct for the logic of the scrip.

(($self->TicketObj->QueueObj->Name || ‘’) ne ‘SafeSentryPro’) ||
(($self->TicketObj->QueueObj->Name || ‘’) ne
’Security-Appliance-Review-Logs’)

-mOn Tue, Dec 22, 2015 at 6:04 PM, norman lists@thekingstech.com wrote:

Hello.

In the last week we upgraded our rt instance from 4.0.19 to 4.2.8
Before the upgrade we had a script that would aupo-reply to all new
tickets created by email unless they went to 2 queues in which we would not
auto-reply at all.
Since the upgrade that script is sending out a message on all ticket
correspondence regardless of weather it’s a create or not.
The condition is set to user defined and the code in custom condition is
as follows.
($self->TransactionObj->Type || ‘’) eq ‘Create’
&&
($self->TicketObj->Status || ‘’) ne ‘resolved’
&&
($self->TicketObj->QueueObj->Name || ‘’) ne ‘SafeSentryPro’ ||
‘Security-Appliance-Review-Logs’

What’s wrong here or is it a different problem entirely?

Thanks.

Hi.

Hi.

Thanks for the help.
However, that has not really fixed the issue.
The way the system should work is that if an email comes in and a ticket
is opened the requester should get an auto response.

Yep. That is “On Create”. Don’t disable that scrip.

They should not get

another response if they reply to that ticket.
At this point if you reply to the ticket it is triggering an auto
response.

Yep. That is “On Correspond”. Disable that scrip.

-m

Hi.
I seem to be missing something.
there is no “on correspond auto-reply to requester” script that i can
see, Only the script i laid out earlier.
If i disable the following script, it fixes the issues but also disables
my aupo-reply on create.
The script is laid out as follows with the code added that i had been
given earlier in this thread.
Condition: “user defined”, with the following code in the “custom
condition” box.

($self->TransactionObj->Type || ‘’) eq ‘Create’
&&
($self->TicketObj->Status || ‘’) ne ‘resolved’
&&
(($self->TicketObj->QueueObj->Name || ‘’) ne ‘SafeSentryPro’) ||
(($self->TicketObj->QueueObj->Name || ‘’) ne
’Security-Appliance-Review-Logs’)

Action: “autoReply To Requesters”.

Template: “AutoReply”

Any help is appreciated.On 12/23/2015 1:16 PM, Matt Zagrabelny wrote:

On Wed, Dec 23, 2015 at 12:13 PM, norman lists@thekingstech.com wrote:

Hi.

Thanks for the help.
However, that has not really fixed the issue.
The way the system should work is that if an email comes in and a ticket
is opened the requester should get an auto response.
Yep. That is “On Create”. Don’t disable that scrip.

They should not get

another response if they reply to that ticket.
At this point if you reply to the ticket it is triggering an auto
response.

Yep. That is “On Correspond”. Disable that scrip.

-m

norman writes:

Hi.
I seem to be missing something.
there is no “on correspond auto-reply to requester” script that i can
see, Only the script i laid out earlier.
If i disable the following script, it fixes the issues but also disables
my aupo-reply on create.
The script is laid out as follows with the code added that i had been
given earlier in this thread.
Condition: “user defined”, with the following code in the “custom
condition” box.

This makes me think your correspondence is going to the create address.
What are your mail aliases?
Do the comment/correspondent have the ticket # in the subject line?

/jeff

The information contained in this e-mail is for the exclusive use of the
intended recipient(s) and may be confidential, proprietary, and/or
legally privileged. Inadvertent disclosure of this message does not
constitute a waiver of any privilege. If you receive this message in
error, please do not directly or indirectly use, print, copy, forward,
or disclose any part of this message. Please also delete this e-mail
and all copies and notify the sender. Thank you.

For alternate languages please go to http://bayerdisclaimer.bayerweb.com