Auto-Generated Emails

How can I change Request Tracker configuration so it can reply to and Auto-Generated Email?

Getting the below message in log file when trying to reply to a message. This message was created by a ticketing system outside my organization.

whatever@whatever.domian was blacklisted for outbound mail on this transaction.

I have read a lot of the threads about Bugzilla but I do not see any fixes.

Thanks In advance for the help

RT goes out of its way to make sure that it does not reply to auto generated emails, as that way can lead to mail loops, ticket deluges, etc when it starts to reply to a system that itself then replies back… repeatedly. So be very careful with even trying this as you can break things horribly.

Warning out of the way, you’ll probably have to make a local copy of lib/RT/Interface/ and put an exception into the CheckForAutoGenerated() subroutine that returns zero if the $From matches whatever@whatever.domian.

Oddly though, a quick grep doesn’t show the error “was blacklisted” and “for outbound mail on this transaction” in the code for our RT 4.,4.4 install. Is this actually coming from RT, or from rules in your MTA (or a gateway its talking to)?


Thanks for the reply

Pretty sure it is RT sending the error here is the messages from the RT Log.

[564] [Mon Sep 16 20:03:05 2019] [info]: <rt-4.2.3-564-1568664185-108.1560109-87-0@Copsean_Service_Inc> whatever@whatever.domian is blacklisted by RT-Squelch-Replies-To header in the incoming message. Skipping (/opt/rt4/sbin/…/lib/RT/Action/

Can you give me a sample of code or where to look that will be very detailed in how to accomplish this task? My Perl skills are not that sophisticated.

Again thanks for the help.

Make a copy of /opt/rt4/lib/RT/Interface/ into /opt/rt4/local/lib/RT/Interface/ (assuming your RT is installed in /opt/rt4 of course). Edit that local copy by finding the sub CheckForAutoGnerated { line and then after these lines:

# Bounces, via mailer-daemon or postmaster
my ( $From ) = ParseSenderAddressFromHead($head);

add in the line:

return 0 if defined $From and $From =~ /whatever\@whatever.domian/i;

Save the edited file, flush your Mason cache and restart the web server. Then test to see if that fixes things.

Having said that, the error you’ve detailed this time is different - its saying its removing inappropriate recipients that are in the "RT-Squelch-Replies-To header. Effectively the incoming email is telling it not to send to a particular email address - whether its auto-generated mail or not.

Thanks for the reply


But the vendor I am communicating with is telling me to replay to the sending address to update the ticket. But using the autoreply script Request Tracker will not reply I get the above Blacklist error.

So I posted to see if some kind of exception can be made.

I am running version 4.2 of Request Tracker (If this make a difference) and cannot find CheckForAutoGnerated in the


Is the vendor you’re dealing with also using RT? In which case it might well be RT being smart trying to stop both instances (yours and theirs) constantly replying back and forth. This is just setting up a massive mail loop between themselves, which you definitely do not want!

Also sorry, we’d don’t have the 4.2 version of RT installed here.

I do not know what the ticketing system is and the people I am conversing with are not the most helpful.