Approvals in 3.8.1 Workflow

We are looking into using RT for approvals (3.8.1). I have the queues
working as described in the wiki (and archives). So far so good. What
I did notice though, when I had multiple requestors they were getting
the first set of e-mails concurrently. This is reminiscent of another
thread that said both approvers were getting the message at the same
time
http://www.gossamer-threads.com/lists/rt/users/76898?search_string=appro
vals;#76898

We never used approvals in <3.8.1 so I don’t know if the behavior was
different then.

Here is what we have observed.

-Two Approvers-

Requestor opens a ticket for approval

Requestor gets automated reply

Approver1 gets an e-mail telling them someone opened a ticket that needs
to be approved and receives one for Approver2 at the same time

Approver2 gets the same e-mail Approver1 received and receives one for
themselves at the same time

Approver1 approves the request, Approver2 gets the AdminCC on it

Requestor gets “Your ticket has been approved by DOT” The approver name
doesn’t show up

Requestor gets “Your request has been approved by username…”

Approver2 gets the “new item pending your approval…” message

Approver2 approves the message

Requestor gets the “your request has been approved…” message

-Single Approver-

Requestor opens a ticket for approval

Requestor gets automated reply

Approver1 gets an e-mail telling them someone opened a ticket that needs
to be approved

Approver1 approves the request

Requestor gets “Your ticket has been approved by DOT” The approver name
doesn’t show up

Requestor gets “Your request has been approved by username…”

Requestor gets the “your request has been approved…” message

I’m not sure if the above is “by design” or if I’m missing something.
The biggest items that strike me are:

-Since both Approvers get the initial e-mail about the request, they
would both go in to approve the ticket. However, Approver2 doesn’t have
anything in his Approvals link until Approver1 approves first (this is
not manager friendly :slight_smile:

-The automated response that doesn’t have the proper username, it looks
like its just a blank space.

Thanks

Helmuth

Hi everyone, just to make sure the problem is me and not the app, can
someone confirm the proper behavior of the Approvals system in RT? Is
it supposed to work as observed below?

Cheers!

HelmuthFrom: Helmuth Ramirez
Sent: Wednesday, August 27, 2008 9:57 AM
To: RT Users
Subject: Approvals in 3.8.1 Workflow

We are looking into using RT for approvals (3.8.1). I have the queues
working as described in the wiki (and archives). So far so good. What
I did notice though, when I had multiple requestors they were getting
the first set of e-mails concurrently. This is reminiscent of another
thread that said both approvers were getting the message at the same
time
http://www.gossamer-threads.com/lists/rt/users/76898?search_string=appro
vals;#76898

We never used approvals in <3.8.1 so I don’t know if the behavior was
different then.

Here is what we have observed.

-Two Approvers-

Requestor opens a ticket for approval

Requestor gets automated reply

Approver1 gets an e-mail telling them someone opened a ticket that needs
to be approved and receives one for Approver2 at the same time

Approver2 gets the same e-mail Approver1 received and receives one for
themselves at the same time

Approver1 approves the request, Approver2 gets the AdminCC on it

Requestor gets “Your ticket has been approved by DOT” The approver name
doesn’t show up

Requestor gets “Your request has been approved by username…”

Approver2 gets the “new item pending your approval…” message

Approver2 approves the message

Requestor gets the “your request has been approved…” message

-Single Approver-

Requestor opens a ticket for approval

Requestor gets automated reply

Approver1 gets an e-mail telling them someone opened a ticket that needs
to be approved

Approver1 approves the request

Requestor gets “Your ticket has been approved by DOT” The approver name
doesn’t show up

Requestor gets “Your request has been approved by username…”

Requestor gets the “your request has been approved…” message

I’m not sure if the above is “by design” or if I’m missing something.
The biggest items that strike me are:

-Since both Approvers get the initial e-mail about the request, they
would both go in to approve the ticket. However, Approver2 doesn’t have
anything in his Approvals link until Approver1 approves first (this is
not manager friendly :slight_smile:

-The automated response that doesn’t have the proper username, it looks
like its just a blank space.

Thanks

Helmuth