Apache2, webmux issue: Can't locate object method "Config" via package "RT" (...) - httpd does not start

Hello,

nice to meet you :slight_smile:

Yesterday I’ve installed version 3.8.1 on my debian box, and I can’t start it.

What I have:
Debian “Etch” with 2.6.21-2
Apache 2.2.4 running with mod_perl/2.0.3 and Perl/v5.8.8 (fastcgi is
currently disabled) and other modules
RT 3.8.1
access to root account :slight_smile:

What I did:
./configure --prefix="/usr/local/rt-3" - successfull
database and user created - successful
config in etc/RT_SiteConfig.pm - done
fixed all dependencies with make fixdeps
tested all dependencies: "All dependencies have been found."
successful 'make install’
reinstall with perl -MCPAN -e’install Bundle::Apache2’
reinstalled like above DBIx::SearchBuilder (desperation, yes)
checked permissions of path to RT.pm - okay
created /etc/apache2/inc/request-tracker included in
/etc/apache2/sites-enabled/ssl-my.ssl.host.name (content: below)
even tried “downgrade” rt to 3.8.0 - nothing changed

What is going on:
When I did ‘apache2ctl graceful’ apache silently died with (in error log):
[Fri Oct 31 09:39:54 2008] [notice] Graceful restart requested, doing restart
[Fri Oct 31 09:39:54 2008] [error] (9)Bad file descriptor:
apr_socket_accept: (client socket)
[Fri Oct 31 09:39:54 2008] [error] (9)Bad file descriptor:
apr_socket_accept: (client socket)
[Fri Oct 31 09:39:55 2008] [error] (9)Bad file descriptor:
apr_socket_accept: (client socket)
[Fri Oct 31 09:39:55 2008] [error] (9)Bad file descriptor:
apr_socket_accept: (client socket)
[Fri Oct 31 09:40:26 2008] [error] Can’t locate object method "Config"
via package “RT” at /usr/local/rt-3/bin/webmux.pl line 100.\nBEGIN
failed–compilation aborted at /usr/local/rt-3/bin/webmux.pl line
101.\nCompilation failed in require at (eval 244) line 1.\n
[Fri Oct 31 09:40:26 2008] [error] Can’t load Perl file:
/usr/local/rt-3/bin/webmux.pl for server my.ssl.host.name:443,
exiting…

…and I had to comment out "Include /etc/apache2/inc/request-tracker"
in in /etc/apache2/sites-enabled/ssl-my.ssl.host.name

I’m writing here because I’m unfortunately not a perl hacker and I
can’t force “this things” to work.
I’ve searched this list archive and web but I can’t find anything corresponding.

== /etc/apache2/inc/request-tracker
Alias /rt "/usr/local/rt-3/share/html"
AddDefaultCharset UTF-8

PerlModule Apache::DBI

PerlRequire “/usr/local/rt-3/bin/webmux.pl”

<Directory /usr/local/rt-3/share/html>
AllowOverride All
Options ExecCGI +FollowSymLinks

<Location /rt/NoAuth/images>
SetHandler default

<Location /rt>
SetHandler perl-script
PerlResponseHandler RT::Mason

PerlHandler RT::Mason - this one was from

http://wiki.bestpractical.com/view/DebianStableInstallGuide

=== end of /etc/apache2/inc/request-tracker

=== parts of /etc/apache2/sites-enabled/ssl-my.ssl.host.name
NameVirtualHost ip.add.re.ss:443

SSLEngine on
DocumentRoot /var/www/
[cut…]

   Include /etc/apache2/inc/some-file
   Include /etc/apache2/inc/some-other-file
   # commented out because server dies
   # Include /etc/apache2/inc/request-tracker
=== end of /etc/apache2/sites-enabled/ssl-my.host.name

=== /usr/local/rt-3/etc/RT_SiteConfig.pm
Set( $rtname, ‘my.ssl.host.name’);
#Set(@Plugins,(qw(Extension::QuickDelete)));
Set($Organization , “my.domain.name”);
Set($OwnerEmail, ‘rtowner’);
Set($RTAddressRegexp, ‘^it@my.host.name$’);
Set($SMTPServer, ‘localhost’);
Set($SMTPFrom, ‘it@my.host.name’);
Set($CorrespondAddress , ‘RT_CorrespondAddressNotSet’);
Set($CommentAddress , ‘RT_CommentAddressNotSet’);

Set($MinimumPasswordLength , “8”);
Set($Timezone , ‘Europe/Warsaw’);

Set($DatabaseType , ‘mysql’);
Set($DatabasePassword , ‘very-long-pw’);

Set($PlainTextPre, 1);
Set($MaxAttachmentSize , 50000000);
Set($WebDefaultStylesheet, ‘web2’);

Set($WebDomain, ‘my.host.name’ );
Set($WebPath, “/rt”);
Set($WebPort, 443);# + ($< * 7274) % 32766 + ($< && 1024));
Set($WebBaseURL, ‘https://’ . RT->Config->Get(‘WebDomain’) . ‘:’ .
RT->Config->Get(‘WebPort’));
Set($WebURL, RT->Config->Get(‘WebBaseURL’) . RT->Config->Get(‘WebPath’) . “/”);
Set($WebSecureCookies, 1);
Set( %GnuPG,
Enable => 1,
OutgoingMessagesFormat => ‘RFC’, # Inline
AllowEncryptDataInDB => 0,
);
1;
=== end of RT_SiteConfig.pm

Also I added to /etc/aliases:
it: “|/usr/local/rt-3/bin/rt-mailgate --queue ‘General’ --action
correspond --url https://my.ssl.host.name/rt

I have no clue :slight_smile:

Thanks in advance.

best regards,
Olgierd Ziolko
"Real stupidity beats artificial intelligence every time."

Hi Olgierd,

I ran into the same kind of problem two days ago.
I first installed RT 3.6.x using debian packages, then installed 3.8.1 from
tarball to get the same error as yours.
Looked like the system-wide RT modules (/usr/share/request-tracker3.6/ or
something like that) were loaded instead of the ones located into /opt/rt3/
(the new ones).
Simply removing the debian packages (request-tracker3.6) or making sure the
previous modules were not available was enough to solve the problem.

However I’m very lazy and did not try to understand why the module search
path caused that. Shame on me.

Hope it helps,

-seb

Olgierd Ziółko wrote:

Hello,

nice to meet you :slight_smile:

Yesterday I’ve installed version 3.8.1 on my debian box, and I can’t start
it.

What I have:
Debian “Etch” with 2.6.21-2
Apache 2.2.4 running with mod_perl/2.0.3 and Perl/v5.8.8 (fastcgi is
currently disabled) and other modules
RT 3.8.1
access to root account :slight_smile:

What I did:
./configure --prefix="/usr/local/rt-3" - successfull
database and user created - successful
config in etc/RT_SiteConfig.pm - done
fixed all dependencies with make fixdeps
tested all dependencies: "All dependencies have been found."
successful 'make install’
reinstall with perl -MCPAN -e’install Bundle::Apache2’
reinstalled like above DBIx::SearchBuilder (desperation, yes)
checked permissions of path to RT.pm - okay
created /etc/apache2/inc/request-tracker included in
/etc/apache2/sites-enabled/ssl-my.ssl.host.name (content: below)
even tried “downgrade” rt to 3.8.0 - nothing changed

What is going on:
When I did ‘apache2ctl graceful’ apache silently died with (in error log):
[Fri Oct 31 09:39:54 2008] [notice] Graceful restart requested, doing
restart
[Fri Oct 31 09:39:54 2008] [error] (9)Bad file descriptor:
apr_socket_accept: (client socket)
[Fri Oct 31 09:39:54 2008] [error] (9)Bad file descriptor:
apr_socket_accept: (client socket)
[Fri Oct 31 09:39:55 2008] [error] (9)Bad file descriptor:
apr_socket_accept: (client socket)
[Fri Oct 31 09:39:55 2008] [error] (9)Bad file descriptor:
apr_socket_accept: (client socket)
[Fri Oct 31 09:40:26 2008] [error] Can’t locate object method "Config"
via package “RT” at /usr/local/rt-3/bin/webmux.pl line 100.\nBEGIN
failed–compilation aborted at /usr/local/rt-3/bin/webmux.pl line
101.\nCompilation failed in require at (eval 244) line 1.\n
[Fri Oct 31 09:40:26 2008] [error] Can’t load Perl file:
/usr/local/rt-3/bin/webmux.pl for server my.ssl.host.name:443,
exiting…

…and I had to comment out "Include /etc/apache2/inc/request-tracker"
in in /etc/apache2/sites-enabled/ssl-my.ssl.host.name

I’m writing here because I’m unfortunately not a perl hacker and I
can’t force “this things” to work.
I’ve searched this list archive and web but I can’t find anything
corresponding.

== /etc/apache2/inc/request-tracker
Alias /rt "/usr/local/rt-3/share/html"
AddDefaultCharset UTF-8

PerlModule Apache::DBI

PerlRequire “/usr/local/rt-3/bin/webmux.pl”

<Directory /usr/local/rt-3/share/html>
AllowOverride All
Options ExecCGI +FollowSymLinks

<Location /rt/NoAuth/images>
SetHandler default

<Location /rt>
SetHandler perl-script
PerlResponseHandler RT::Mason

PerlHandler RT::Mason - this one was from

http://wiki.bestpractical.com/view/DebianStableInstallGuide

=== end of /etc/apache2/inc/request-tracker

=== parts of /etc/apache2/sites-enabled/ssl-my.ssl.host.name
NameVirtualHost ip.add.re.ss:443

SSLEngine on
DocumentRoot /var/www/
[cut…]

   Include /etc/apache2/inc/some-file
   Include /etc/apache2/inc/some-other-file
   # commented out because server dies
   # Include /etc/apache2/inc/request-tracker
=== end of /etc/apache2/sites-enabled/ssl-my.host.name

=== /usr/local/rt-3/etc/RT_SiteConfig.pm
Set( $rtname, ‘my.ssl.host.name’);
#Set(@Plugins,(qw(Extension::QuickDelete)));
Set($Organization , “my.domain.name”);
Set($OwnerEmail, ‘rtowner’);
Set($RTAddressRegexp, ‘^it@my.host.name$’);
Set($SMTPServer, ‘localhost’);
Set($SMTPFrom, ‘it@my.host.name’);
Set($CorrespondAddress , ‘RT_CorrespondAddressNotSet’);
Set($CommentAddress , ‘RT_CommentAddressNotSet’);

Set($MinimumPasswordLength , “8”);
Set($Timezone , ‘Europe/Warsaw’);

Set($DatabaseType , ‘mysql’);
Set($DatabasePassword , ‘very-long-pw’);

Set($PlainTextPre, 1);
Set($MaxAttachmentSize , 50000000);
Set($WebDefaultStylesheet, ‘web2’);

Set($WebDomain, ‘my.host.name’ );
Set($WebPath, “/rt”);
Set($WebPort, 443);# + ($< * 7274) % 32766 + ($< && 1024));
Set($WebBaseURL, ‘https://’ . RT->Config->Get(‘WebDomain’) . ‘:’ .
RT->Config->Get(‘WebPort’));
Set($WebURL, RT->Config->Get(‘WebBaseURL’) . RT->Config->Get(‘WebPath’) .
"/");
Set($WebSecureCookies, 1);
Set( %GnuPG,
Enable => 1,
OutgoingMessagesFormat => ‘RFC’, # Inline
AllowEncryptDataInDB => 0,
);
1;
=== end of RT_SiteConfig.pm

Also I added to /etc/aliases:

it: “|/usr/local/rt-3/bin/rt-mailgate --queue ‘General’ --action
correspond --url https://my.ssl.host.name/rt

I have no clue :slight_smile:

Thanks in advance.

best regards,

Olgierd Ziolko
"Real stupidity beats artificial intelligence every time."


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

View this message in context: http://www.nabble.com/Apache2%2C-webmux-issue%3A--error--Can't-locate-object-method-"Config"-via-package-"RT"-(...)---httpd-does-not-start-tp20263778p20265993.html

Hi Sebastien,

Thank you very much - I completely forgot about installed earlier rt
3.6 from packages.

When I removed request-tracker3.6 rt3.6-apache2 rt3.6-clients
rt3.6-rtfm apache started - uff - thank you.
I don’t had enough patience to trying to strace or sth.

Now I’m fighting with another issue[1], but I think, that I can
resolve this - now I have working Apache.

[1] probably 2 instances of Mason?
[Sun Nov 2 14:59:00 2008] [warning]: [Mason] Cannot resolve file to
component: /usr/local/rt-3/share/html/index.html (is file outside
component root?) at
/usr/local/share/perl/5.8.8/HTML/Mason/ApacheHandler.pm line 852.
(/usr/local/share/perl/5.8.8/HTML/Mason/ApacheHandler.pm:852)

Thank you, Sebastian2008/11/2 Sebastien Lefevre seb.lefevre@gmail.com:

Hi Olgierd,

I ran into the same kind of problem two days ago.
I first installed RT 3.6.x using debian packages, then installed 3.8.1 from
tarball to get the same error as yours.
Looked like the system-wide RT modules (/usr/share/request-tracker3.6/ or
something like that) were loaded instead of the ones located into /opt/rt3/
(the new ones).
Simply removing the debian packages (request-tracker3.6) or making sure the
previous modules were not available was enough to solve the problem.

However I’m very lazy and did not try to understand why the module search
path caused that. Shame on me.

Hope it helps,

-seb

Olgierd Ziółko wrote:

Hello,

nice to meet you :slight_smile:

Yesterday I’ve installed version 3.8.1 on my debian box, and I can’t start
it.

What I have:
Debian “Etch” with 2.6.21-2
Apache 2.2.4 running with mod_perl/2.0.3 and Perl/v5.8.8 (fastcgi is
currently disabled) and other modules
RT 3.8.1
access to root account :slight_smile:

What I did:
./configure --prefix="/usr/local/rt-3" - successfull
database and user created - successful
config in etc/RT_SiteConfig.pm - done
fixed all dependencies with make fixdeps
tested all dependencies: "All dependencies have been found."
successful 'make install’
reinstall with perl -MCPAN -e’install Bundle::Apache2’
reinstalled like above DBIx::SearchBuilder (desperation, yes)
checked permissions of path to RT.pm - okay
created /etc/apache2/inc/request-tracker included in
/etc/apache2/sites-enabled/ssl-my.ssl.host.name (content: below)
even tried “downgrade” rt to 3.8.0 - nothing changed

What is going on:
When I did ‘apache2ctl graceful’ apache silently died with (in error log):
[Fri Oct 31 09:39:54 2008] [notice] Graceful restart requested, doing
restart
[Fri Oct 31 09:39:54 2008] [error] (9)Bad file descriptor:
apr_socket_accept: (client socket)
[Fri Oct 31 09:39:54 2008] [error] (9)Bad file descriptor:
apr_socket_accept: (client socket)
[Fri Oct 31 09:39:55 2008] [error] (9)Bad file descriptor:
apr_socket_accept: (client socket)
[Fri Oct 31 09:39:55 2008] [error] (9)Bad file descriptor:
apr_socket_accept: (client socket)
[Fri Oct 31 09:40:26 2008] [error] Can’t locate object method "Config"
via package “RT” at /usr/local/rt-3/bin/webmux.pl line 100.\nBEGIN
failed–compilation aborted at /usr/local/rt-3/bin/webmux.pl line
101.\nCompilation failed in require at (eval 244) line 1.\n
[Fri Oct 31 09:40:26 2008] [error] Can’t load Perl file:
/usr/local/rt-3/bin/webmux.pl for server my.ssl.host.name:443,
exiting…

…and I had to comment out "Include /etc/apache2/inc/request-tracker"
in in /etc/apache2/sites-enabled/ssl-my.ssl.host.name

I’m writing here because I’m unfortunately not a perl hacker and I
can’t force “this things” to work.
I’ve searched this list archive and web but I can’t find anything
corresponding.

== /etc/apache2/inc/request-tracker
Alias /rt "/usr/local/rt-3/share/html"
AddDefaultCharset UTF-8

PerlModule Apache::DBI

PerlRequire “/usr/local/rt-3/bin/webmux.pl”

<Directory /usr/local/rt-3/share/html>
AllowOverride All
Options ExecCGI +FollowSymLinks

<Location /rt/NoAuth/images>
SetHandler default

<Location /rt>
SetHandler perl-script
PerlResponseHandler RT::Mason

PerlHandler RT::Mason - this one was from

http://wiki.bestpractical.com/view/DebianStableInstallGuide

=== end of /etc/apache2/inc/request-tracker

=== parts of /etc/apache2/sites-enabled/ssl-my.ssl.host.name
NameVirtualHost ip.add.re.ss:443

SSLEngine on
DocumentRoot /var/www/
[cut…]

   Include /etc/apache2/inc/some-file
   Include /etc/apache2/inc/some-other-file
   # commented out because server dies
   # Include /etc/apache2/inc/request-tracker
=== end of /etc/apache2/sites-enabled/ssl-my.host.name

=== /usr/local/rt-3/etc/RT_SiteConfig.pm
Set( $rtname, ‘my.ssl.host.name’);
#Set(@Plugins,(qw(Extension::QuickDelete)));
Set($Organization , “my.domain.name”);
Set($OwnerEmail, ‘rtowner’);
Set($RTAddressRegexp, ‘^it@my.host.name$’);
Set($SMTPServer, ‘localhost’);
Set($SMTPFrom, ‘it@my.host.name’);
Set($CorrespondAddress , ‘RT_CorrespondAddressNotSet’);
Set($CommentAddress , ‘RT_CommentAddressNotSet’);

Set($MinimumPasswordLength , “8”);
Set($Timezone , ‘Europe/Warsaw’);

Set($DatabaseType , ‘mysql’);
Set($DatabasePassword , ‘very-long-pw’);

Set($PlainTextPre, 1);
Set($MaxAttachmentSize , 50000000);
Set($WebDefaultStylesheet, ‘web2’);

Set($WebDomain, ‘my.host.name’ );
Set($WebPath, “/rt”);
Set($WebPort, 443);# + ($< * 7274) % 32766 + ($< && 1024));
Set($WebBaseURL, ‘https://’ . RT->Config->Get(‘WebDomain’) . ‘:’ .
RT->Config->Get(‘WebPort’));
Set($WebURL, RT->Config->Get(‘WebBaseURL’) . RT->Config->Get(‘WebPath’) .
"/");
Set($WebSecureCookies, 1);
Set( %GnuPG,
Enable => 1,
OutgoingMessagesFormat => ‘RFC’, # Inline
AllowEncryptDataInDB => 0,
);
1;
=== end of RT_SiteConfig.pm

Also I added to /etc/aliases:

it: “|/usr/local/rt-3/bin/rt-mailgate --queue ‘General’ --action
correspond --url https://my.ssl.host.name/rt

I have no clue :slight_smile:

Thanks in advance.

best regards,

Olgierd Ziolko
"Real stupidity beats artificial intelligence every time."


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


View this message in context: http://www.nabble.com/Apache2%2C-webmux-issue%3A--error--Can't-locate-object-method-"Config"-via-package-"RT"-(...)---httpd-does-not-start-tp20263778p20265993.html
Sent from the Request Tracker - User mailing list archive at Nabble.com.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Olgierd Ziolko
"Real stupidity beats artificial intelligence every time."