Apache problem

Hi all,

Thanks to the docs available I’ve been able to install webrt2…However:

The Readme file included something like adding

DocumentRoot /path/to/rt2/WebRT/html ServerName your.rt.server.hostname PerlModule Apache::DBI PerlFreshRestart On PerlRequire /path/to/rt2/bin/webmux.pl SetHandler perl-script PerlHandler RT::Mason

to httpd.conf or apache.conf, which i did, making the necessary
adjustments…

However on running “apachectl configtest” apache refuses to recognise
"PerlModule Apache::DBI"
“PerlFreshRestart on”
"PerlRequire"
as correct syntax …

Does anyone have ideas on what I could do?
Greg,
Computer Frontiers International

  ,,,
 /'^'\
( o o )

oOOO–(_)–OOOo----------------------

|+ However on running “apachectl configtest” apache refuses to recognise
|+ “PerlModule Apache::DBI”
|+ “PerlFreshRestart on”
|+ “PerlRequire”
|+ as correct syntax …

Do you have mod_perl installed?

-darrin

Hi,

I’m taking a blind stab - but my guess is make sure you have apache
built with mod_perl

… it seems like a problem with something like that.

AndrewOn Saturday, October 13, 2001, at 11:55 AM, greg@space.cfi.co.ug wrote:

Hi all,

Thanks to the docs available I’ve been able to install webrt2…However:

The Readme file included something like adding

DocumentRoot /path/to/rt2/WebRT/html ServerName your.rt.server.hostname PerlModule Apache::DBI PerlFreshRestart On PerlRequire /path/to/rt2/bin/webmux.pl SetHandler perl-script PerlHandler RT::Mason

to httpd.conf or apache.conf, which i did, making the necessary
adjustments…

However on running “apachectl configtest” apache refuses to recognise
"PerlModule Apache::DBI"
“PerlFreshRestart on”
"PerlRequire"
as correct syntax …

Does anyone have ideas on what I could do?

Greg,
Computer Frontiers International

  ,,,
 /'^'\
( o o )

oOOO–(_)–OOOo----------------------


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Andrew Yager
Real World Technology Solutions
Real People Real SolUtions™
ph: (02) 9945 2567 fax: (02) 9945 2566
mob: 0405 15 2568

Yes mod_perl is installed and several other perl scripts are working fine
on the box…

Greg,
Computer Frontiers International

  ,,,
 /'^'\
( o o )

oOOO–(_)–OOOo----------------------On Fri, 12 Oct 2001, Darrin Walton wrote:

|+ However on running “apachectl configtest” apache refuses to recognise
|+ “PerlModule Apache::DBI”
|+ “PerlFreshRestart on”
|+ “PerlRequire”
|+ as correct syntax …

Do you have mod_perl installed?

-darrin

Apache was built with mod_perl on this box…

Greg,
Computer Frontiers International

  ,,,
 /'^'\
( o o )

oOOO–(_)–OOOo----------------------On Sat, 13 Oct 2001, Andrew Yager wrote:

Hi,

I’m taking a blind stab - but my guess is make sure you have apache
built with mod_perl

… it seems like a problem with something like that.

Andrew

On Saturday, October 13, 2001, at 11:55 AM, greg@space.cfi.co.ug wrote:

Hi all,

Thanks to the docs available I’ve been able to install webrt2…However:

The Readme file included something like adding

DocumentRoot /path/to/rt2/WebRT/html ServerName your.rt.server.hostname PerlModule Apache::DBI PerlFreshRestart On PerlRequire /path/to/rt2/bin/webmux.pl SetHandler perl-script PerlHandler RT::Mason

to httpd.conf or apache.conf, which i did, making the necessary
adjustments…

However on running “apachectl configtest” apache refuses to recognise
"PerlModule Apache::DBI"
“PerlFreshRestart on”
"PerlRequire"
as correct syntax …

Does anyone have ideas on what I could do?

Greg,
Computer Frontiers International

  ,,,
 /'^'\
( o o )

oOOO–(_)–OOOo----------------------


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


Andrew Yager
Real World Technology Solutions
Real People Real SolUtions™
ph: (02) 9945 2567 fax: (02) 9945 2566
mob: 0405 15 2568
http://www.rwts.com.au/


Was mod_perl built statically or dynamically (as a DSO in libexec)?

Could you include in your reply the output of “httpd -l”?

R.

The output of httpd -l is

Compiled-in modules:
http_core.c
mod_so.c
suexec: disabled; invalid wrapper /usr/local/sbin/suexec

Greg,
Computer Frontiers International

  ,,,
 /'^'\
( o o )

oOOO–(_)–OOOo----------------------On Thu, 18 Oct 2001, Richard Soderberg wrote:

Was mod_perl built statically or dynamically (as a DSO in libexec)?

Could you include in your reply the output of “httpd -l”?

R.

-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of
greg@space.cfi.co.ug
Sent: Saturday, October 13, 2001 2:46 PM
To: Andrew Yager
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] apache problem

Apache was built with mod_perl on this box…


Greg,
Computer Frontiers International

  ,,,
 /'^'\
( o o )

oOOO–(_)–OOOo----------------------

On Sat, 13 Oct 2001, Andrew Yager wrote:

Hi,

I’m taking a blind stab - but my guess is make sure you have apache
built with mod_perl

… it seems like a problem with something like that.

Andrew

On Saturday, October 13, 2001, at 11:55 AM, greg@space.cfi.co.ug wrote:

Hi all,

Thanks to the docs available I’ve been able to install
webrt2…However:

The Readme file included something like adding

DocumentRoot /path/to/rt2/WebRT/html ServerName your.rt.server.hostname PerlModule Apache::DBI PerlFreshRestart On PerlRequire /path/to/rt2/bin/webmux.pl SetHandler perl-script PerlHandler RT::Mason

to httpd.conf or apache.conf, which i did, making the necessary
adjustments…

However on running “apachectl configtest” apache refuses
to recognise

“PerlModule Apache::DBI”
“PerlFreshRestart on”
"PerlRequire"
as correct syntax …

Does anyone have ideas on what I could do?

Greg,
Computer Frontiers International

  ,,,
 /'^'\
( o o )

oOOO–(_)–OOOo----------------------


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


Andrew Yager
Real World Technology Solutions
Real People Real SolUtions™
ph: (02) 9945 2567 fax: (02) 9945 2566
mob: 0405 15 2568
http://www.rwts.com.au/



rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users